Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 283121 - media-sound/hydrogen-0.9.4_beta failed
Summary: media-sound/hydrogen-0.9.4_beta failed
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-29 15:01 UTC by skobk.in
Modified: 2009-08-29 19:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description skobk.in 2009-08-29 15:01:44 UTC
* hydrogen-0.9.4-beta.tar.gz RMD160 SHA1 SHA256 size ;-) ...            [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
>>> Unpacking source...
>>> Unpacking hydrogen-0.9.4-beta.tar.gz to /var/tmp/portage/media-sound/hydrogen-0.9.4_beta/work
>>> Source unpacked in /var/tmp/portage/media-sound/hydrogen-0.9.4_beta/work
>>> Compiling source in /var/tmp/portage/media-sound/hydrogen-0.9.4_beta/work/hydrogen-0.9.4-beta ...
 * prefix=/usr destdir=/var/tmp/portage/media-sound/hydrogen-0.9.4_beta/image/ alsa=1 debug=0 jack=0 lrdf=0 portaudio=0 lash=0 flac=1 CC=i686-pc-linux-gnu-gcc CXX=i686-pc-linux-gnu-g++
scons: Reading SConscript files ...

scons: warning: The Options class is deprecated; use the Variables class instead.
File "/var/tmp/portage/media-sound/hydrogen-0.9.4_beta/work/hydrogen-0.9.4-beta/Sconstruct", line 246, in <module>
Checking for C header file sndfile.h... yes
Checking for C header file alsa/asoundlib.h... yes
Checking for C header file zlib.h... yes
Checking for C header file libtar.h... yes
Checking for C header file FLAC/all.h... yes

=================================================================
 Hydrogen build script

 Revision: exported
 Platform: linux2
 Release build
 Prefix: /usr
 Destdir: /var/tmp/portage/media-sound/hydrogen-0.9.4_beta/image/
=================================================================
Feature Overview:

      lash: disabled
      alsa: enabled
      jack: disabled
libarchive: disabled (using libtar instead)
 portaudio: disabled
  portmidi: disabled

=================================================================

scons: done reading SConscript files.
scons: Building targets ...
g++ -o gui/src/Mixer/Mixer.o -c -O3 -fomit-frame-pointer -funroll-loops -DALSA_SUPPORT -DFLAC_SUPPORT -DLADSPA_SUPPORT -DOSS_SUPPORT -DQT_CORE_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_XML_LIB -DQT_SHARED -I/usr/lib/lash-1.0 -I. -Igui/src -I3rdparty/install/include -Ilibs/hydrogen/include -Igui/src/UI -I/usr/include/lash-1.0 -I/usr/include/qt4 -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtXml gui/src/Mixer/Mixer.cpp
uic -o gui/src/UI/ui_about_dialog.h gui/src/UI/about_dialog.ui
g++ -o gui/src/AboutDialog.o -c -O3 -fomit-frame-pointer -funroll-loops -DALSA_SUPPORT -DFLAC_SUPPORT -DLADSPA_SUPPORT -DOSS_SUPPORT -DQT_CORE_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_XML_LIB -DQT_SHARED -I/usr/lib/lash-1.0 -I. -Igui/src -I3rdparty/install/include -Ilibs/hydrogen/include -Igui/src/UI -I/usr/include/lash-1.0 -I/usr/include/qt4 -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtXml gui/src/AboutDialog.cpp
uic -o gui/src/SoundLibrary/ui_SoundLibraryImportDialog_UI.h gui/src/SoundLibrary/SoundLibraryImportDialog_UI.ui
uic -o gui/src/SoundLibrary/ui_SoundLibraryRepositoryDialog_UI.h gui/src/SoundLibrary/SoundLibraryRepositoryDialog_UI.ui
g++ -o gui/src/SoundLibrary/SoundLibraryImportDialog.o -c -O3 -fomit-frame-pointer -funroll-loops -DALSA_SUPPORT -DFLAC_SUPPORT -DLADSPA_SUPPORT -DOSS_SUPPORT -DQT_CORE_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_XML_LIB -DQT_SHARED -I/usr/lib/lash-1.0 -I. -Igui/src -I3rdparty/install/include -Ilibs/hydrogen/include -Igui/src/UI -I/usr/include/lash-1.0 -I/usr/include/qt4 -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtXml gui/src/SoundLibrary/SoundLibraryImportDialog.cpp
g++ -o gui/src/SoundLibrary/SoundLibraryRepositoryDialog.o -c -O3 -fomit-frame-pointer -funroll-loops -DALSA_SUPPORT -DFLAC_SUPPORT -DLADSPA_SUPPORT -DOSS_SUPPORT -DQT_CORE_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_XML_LIB -DQT_SHARED -I/usr/lib/lash-1.0 -I. -Igui/src -I3rdparty/install/include -Ilibs/hydrogen/include -Igui/src/UI -I/usr/include/lash-1.0 -I/usr/include/qt4 -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtXml gui/src/SoundLibrary/SoundLibraryRepositoryDialog.cpp
g++ -o gui/src/PlayerControl.o -c -O3 -fomit-frame-pointer -funroll-loops -DALSA_SUPPORT -DFLAC_SUPPORT -DLADSPA_SUPPORT -DOSS_SUPPORT -DQT_CORE_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_XML_LIB -DQT_SHARED -I/usr/lib/lash-1.0 -I. -Igui/src -I3rdparty/install/include -Ilibs/hydrogen/include -Igui/src/UI -I/usr/include/lash-1.0 -I/usr/include/qt4 -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtXml gui/src/PlayerControl.cpp
In file included from gui/src/PlayerControl.cpp:40:
libs/hydrogen/include/hydrogen/hydrogen.h:194: ошибка: ‘uint32_t’ has not been declared
scons: *** [gui/src/PlayerControl.o] Error 1
scons: building terminated because of errors.
 *
 * ERROR: media-sound/hydrogen-0.9.4_beta failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2887:  Called die
 * The specific snippet of code:
 *       scons CUSTOMCCFLAGS="${CFLAGS}" CUSTOMCXXFLAGS="${CXXFLAGS}" MAKEOPTS="${MAKEOPTS}" ${myconf} || die "scons failed"
 *  The die message:
 *   scons failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-sound/hydrogen-0.9.4_beta/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/hydrogen-0.9.4_beta/temp/environment'.
 * This ebuild is from an overlay named 'proaudio': '/usr/local/portage/layman/pro-audio/'
 *

>>> Failed to emerge media-sound/hydrogen-0.9.4_beta, Log file:

>>>  '/var/tmp/portage/media-sound/hydrogen-0.9.4_beta/temp/build.log'

 * Messages for package media-sound/hydrogen-0.9.4_beta:

 *
 * ERROR: media-sound/hydrogen-0.9.4_beta failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2887:  Called die
 * The specific snippet of code:
 *       scons CUSTOMCCFLAGS="${CFLAGS}" CUSTOMCXXFLAGS="${CXXFLAGS}" MAKEOPTS="${MAKEOPTS}" ${myconf} || die "scons failed"
 *  The die message:
 *   scons failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-sound/hydrogen-0.9.4_beta/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/hydrogen-0.9.4_beta/temp/environment'.
 * This ebuild is from an overlay named 'proaudio': '/usr/local/portage/layman/pro-audio/'
------------------------------------
pc ~ # emerge --info
Portage 2.2_rc40 (default/linux/x86/2008.0, gcc-4.4.1, glibc-2.10.1-r0, 2.6.28-gentoo-r5 i686)
=================================================================
System uname: Linux-2.6.28-gentoo-r5-i686-Intel-R-_Core-TM-2_CPU_6300_@_1.86GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 29 Aug 2009 13:45:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.9
dev-lang/python:     2.6.2-r1, 3.1.1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.6.3, 1.7.9-r1, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -msse -msse2 -mmmx -m3dnow -msse3 -mfpmath=sse -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=core2 -msse -msse2 -mmmx -m3dnow -msse3 -mfpmath=sse -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages metadata-transfer parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://ftp.linux.ee/pub/gentoo/distfiles/ http://mirror.yandex.ru/gentoo-distfiles/ ftp://mirror.yandex.ru/gentoo-distfiles/ "
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1"
LINGUAS="en ru"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/games /usr/local/portage/layman/java-overlay /usr/local/portage/layman/sunrise /usr/local/portage/layman/synce /usr/local/portage/layman/qutim-overlay /usr/local/portage/layman/pro-audio"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl alsa aspell bzip2 cdr cli cracklib crypt cups dbus dri dvd esd fortran gdbm gpm hal iconv isdnlog java jpeg jpeg2k jre kde lm_sensors mmx mp3 mudflap ncurses nls nptl nptlonly opengl openmp pam pcre perl php png pppd python qt qt3 qt4 readline reflection samba session spell spl sse sse2 sse3 ssl ssse3 sysfs tcpd unicode x86 xcomposite xine xorg xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" SANE_BACKENDS="nothing coolscan3 hp hp3500 hp3900 snapscan" USERLAND="GNU" VIDEO_CARDS="fglrx radeonhd radeon vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Reproducible: Always

Steps to Reproduce:
1. layman -a pro-audio
2. emerge hydrogen
3.
Comment 1 Samuli Suominen (RETIRED) gentoo-dev 2009-08-29 19:21:01 UTC
0.9.4_beta isn't in portage, report it to proaudio overlay maintainers directly.

but...

*hydrogen-0.9.4_rc2 (29 Aug 2009)

  29 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
  +hydrogen-0.9.4_rc2.ebuild:
  Version bump.