Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 283015 - media-video/mplayer segfaults on mkv files when built with sys-devel/gcc-4.4.1
Summary: media-video/mplayer segfaults on mkv files when built with sys-devel/gcc-4.4.1
Status: RESOLVED DUPLICATE of bug 269975
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL: http://aur.archlinux.org/packages.php...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-28 10:45 UTC by parafin
Modified: 2009-09-19 15:50 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description parafin 2009-08-28 10:45:14 UTC
After upgrading to sys-devel/gcc-4.4.1 and re-emerging media-video/mplayer I get this every time I try playing .mkv video:

MPlayer SVN-r29463-4.4.1 (C) 2000-2009 MPlayer Team

Playing Californication (S01E01) - Pilot.mkv.

[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_AC3), -aid 0, -alang und
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1280x720  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform


MPlayer interrupted by signal 11 in module: init_audio_codec
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.

Enabling custom-cflags USE-flag in mplayer helps. I also tried patch from URL (more pricesely this one: http://repos.archlinux.org/viewvc.cgi/mplayer/repos/extra-i686/liba52_gcc_bug.patch?revision=45786) - it didn't help.
Comment 1 parafin 2009-08-28 10:47:59 UTC
note ~ # emerge --info mplayer
Portage 2.2_rc40 (default/linux/x86/2008.0/desktop, gcc-4.4.1, glibc-2.10.1-r0, 2.6.26.2 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.26.2-i686-Intel-R-_Pentium-R-_M_processor_1500MHz-with-gentoo-2.0.1
Timestamp of tree: Wed, 26 Aug 2009 20:30:01 +0000
distcc 3.1 i686-pc-linux-gnu [enabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p28
dev-lang/python:     2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -fomit-frame-pointer -ftracer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium-m -fomit-frame-pointer -ftracer -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="assume-digests buildpkg ccache distcc distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://vesnet/ http://mirror.yandex.ru/gentoo-distfiles/"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage/layman/alon-barlev /usr/local/portage/layman/pro-audio"
SYNC="rsync://server/gentoo-portage/"
USE="X a52 aac acpi adns alsa aspell audiofile bash-completion berkdb bzip2 cairo caps cdparanoia cracklib crypt cscope cups curl cxx dbus djvu dri dts dvb dvd dvdread encode exif expat faac faad fam fbcon ffmpeg fftw flac fltk fontconfig foomaticdb ftp gd gdbm geoip gif gimp glib gmp gpm graphviz gtk gtk2 iconv id3tag idn imagemagick imap imlib ipv6 ithreads jack javascript jpeg jpeg2k ladspa lame lash lcms libsamplerate lua lzo mad matroska mbox midi mmap mmx mmxext mng mp3 mpeg ncurses network nls nocd nptl nsplugin offensive ogg opengl pam pcre pdf perl pic png ppds pulseaudio python qt3support qt4 quicktime raw readline ruby sasl sdl session slang sndfile speex spell sqlite sse sse2 ssl svg tcl tcltk tcpd theora threads threadsafe tiff timidity tk truetype unicode usb video videos vim-syntax vorbis webkit wifi win32codecs x264 x86 xcb xface xml xosd xpm xulrunner xv xvid zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" SANE_BACKENDS="net" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

media-video/mplayer-1.0_rc2_p20090731-r1 was built with the following:
USE="X a52 aac alsa ass cddb cdparanoia custom-cflags dts dvb dvd enca encode faac faad fbcon ftp gif iconv ipv6 jack jpeg ladspa live lzo mad mmx mmxext mng mp3 network opengl osdmenu png pulseaudio quicktime rtc sdl shm speex sse sse2 theora tremor truetype unicode vorbis win32codecs x264 xanim xv xvid -3dnow -3dnowext -aalib (-altivec) -bidi -bindist -bl -cdio -cpudetection -custom-cpuopts -debug -dga -dirac -directfb -doc -dv -dvdnav -dxr3 -esd -ggi -gmplayer -joystick -libcaca -lirc -md5sum -mp2 -nas -nut -openal -opencore-amr -oss -pnm -pvr -radio -rar -real -samba -schroedinger -ssse3 -svga -teletext -tga -v4l -v4l2 -vdpau -vidix -xinerama -xscreensaver -xvmc -zoran" VIDEO_CARDS="-mga -nvidia -s3virge -tdfx -vesa"
CFLAGS="-O2 -march=pentium-m -fomit-frame-pointer -ftracer -pipe -fomit-frame-pointer -D__STDC_LIMIT_MACROS"
CXXFLAGS="-O2 -march=pentium-m -fomit-frame-pointer -ftracer -pipe -fomit-frame-pointer -D__STDC_LIMIT_MACROS"
Comment 2 Steve Kutnar 2009-08-31 03:28:33 UTC
Same issue here, ~amd64, no-multilib

Portage 2.2_rc40 (default/linux/amd64/2008.0/no-multilib, gcc-4.4.1-asneeded, glibc-2.10.1-r0, 2.6.30-gentoo-r5 x86_64)
=================================================================                                                      
System uname: Linux-2.6.30-gentoo-r5-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4400+-with-gentoo-2.0.1           
Timestamp of tree: Sat, 29 Aug 2009 17:30:01 +0000                                                                     
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.9
dev-lang/python:     2.6.2-r1, 3.1.1
dev-util/cmake:      2.6.4-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8-sse3 -O2 -pipe -floop-interchange -floop-strip-mine -floop-block"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8-sse3 -O2 -pipe -floop-interchange -floop-strip-mine -floop-block"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="assume-digests distlocks fixpackages metadata-transfer parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.mirrors.tds.net/gentoo ftp://gentoo.netnitco.net/pub/mirrors/gentoo/source/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,-z,combreloc"
LINGUAS="en en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/vmware /usr/local/portage/layman/kde-testing /usr/local/portage/layman/zugaina /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X Xaw3d a52 aac acpi akode alsa amd64 ao branding bzip2 cairo caps cdda cddb cdparanoia cli cracklib crypt css cups curl dbus dga dri dv dvd dvdr dvdread encode exif expat faac faad fam fat fbcon ffmpeg fftw flac fontconfig fortran geoip ggi gif glib gmp gnutls gphoto2 gpm gs gtk hal hfs hyperestraier iconv icu id3tag idn ieee1394 imagemagick imlib ipv6 isdnlog ithreads java jfs joystick jpeg jpeg2k kde kdehiddenvisibility kontact lame lcms libsamplerate lm_sensors lzo mad matroska mbox mjpeg mmap mmx mmxext mng modplug motif mp3 mpeg mplayer msn mtp mudflap musepack musicbrainz ncurses network network-cron nls nptl nptlonly nsplugin ntfs offensive ogg openal opengl openmp openssl oscar oss pam pcre pdf perl plasma plotutils png pppd qt3support qt4 quicktime rar readline reflection rle ruby samba schroedinger sdl semantic-desktop session smp sndfile speex spell spl sse sse2 sse3 ssl startup-notification stats subversion suid svg sysfs syslog tcpd theora threads tiff truetype unicode usb utempter vcd vdpau vim-syntax vnc vorbis wavpack wmf wxwidgets x264 xcomposite xfs xft xine xml xorg xpm xscreensaver xslt xv xvid xvmc zlib" ALSA_CARDS="emu10k1 usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="joystick evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Steve Kutnar 2009-08-31 03:31:24 UTC
Can the summary be updated to include "Matroska", to help others find this bug?  That's what I searched for originally.
Comment 4 Martin Doucha 2009-09-14 18:51:42 UTC
I can confirm the bug, building with USE="custom-cflags" seems to fix the problem for now.
Comment 5 Steve Dibb (RETIRED) gentoo-dev 2009-09-19 15:50:48 UTC

*** This bug has been marked as a duplicate of bug 269975 ***