Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 283002 - media-gfx/f-spot fails to start: GConf.Client.gconf_client_get_default
Summary: media-gfx/f-spot fails to start: GConf.Client.gconf_client_get_default
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal with 2 votes (vote)
Assignee: Denis Dupeyron
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-28 07:50 UTC by Henrik Johansson
Modified: 2010-01-09 09:21 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Debug output (gdb-fspot.log,5.34 KB, text/plain)
2009-11-12 22:39 UTC, Roger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Henrik Johansson 2009-08-28 07:50:33 UTC
f-spot doesn't start on my computer. This applies to v0.6.0.0, v0.6.1.0 and v0.6.1.1. I ran 'emerge f-spot -e' and 'emerge world -e' but it didn't help. Running f-spot in a terminal generates the following error message.


$ f-spot
** No session dbus found. Starting one **

(/usr/lib/f-spot/f-spot.exe:4470): GLib-GObject-CRITICAL **: gtype.c:2458: initialization assertion failed, use IA__g_type_init() prior to this function

(/usr/lib/f-spot/f-spot.exe:4470): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

(/usr/lib/f-spot/f-spot.exe:4470): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
Stacktrace:

  at (wrapper managed-to-native) GConf.Client.gconf_client_get_default () <0x00004>
  at (wrapper managed-to-native) GConf.Client.gconf_client_get_default () <0xffffffff>
  at GConf.Client..ctor () <0x00046>
  at FSpot.Platform.PreferenceBackend.get_Client () <0x00039>
  at FSpot.Platform.PreferenceBackend.AddNotify (string,System.EventHandler`1<FSpot.NotifyEventArgs>) <0x00069>
  at FSpot.Preferences.get_Backend () <0x00087>
  at FSpot.Preferences.TryGet<object> (string,object&) <0x00097>
  at FSpot.Preferences.Get<object> (string) <0x00043>
  at FSpot.Driver.Main (string[]) <0x0019b>
  at (wrapper runtime-invoke) FSpot.Driver.runtime_invoke_int_object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

	mono [0x80c626a]
	mono [0x80f0b7c]
	[0xb806e40c]
	/usr/lib/libgconf-2.so.4 [0xb6455af0]
	[0xb8068657]
	[0xb80685ca]
	[0xb8068202]
	[0xb8068110]
	[0xb8067d58]
	[0xb80657a4]
	[0xb805e484]
	[0xb805e203]
	mono(mono_runtime_exec_main+0x152) [0x8161f75]
	mono(mono_runtime_run_main+0x159) [0x8163fa5]
	mono(mono_main+0x18f0) [0x80b06bc]
	mono [0x805b4a5]
	/lib/libc.so.6(__libc_start_main+0xe6) [0xb7e0ea66]
	mono [0x805b3e1]

Debug info from gdb:


=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

Aborted

Reproducible: Always

Steps to Reproduce:
1. Start f-spot in a terminal
Actual Results:  
f-spot doesn't start and I get the error message above

Expected Results:  
f-spot should start
Comment 1 Marcus Wißmann 2009-08-28 12:57:59 UTC
Hello Henrik,

if you aren't using gnome you have to start gconfd-2 before starting f-spot.
I'm using this little bash script to solve this problem:

#!/bin/bash
/usr/libexec/gconfd-2 &
/usr/bin/f-spot

Does this solve your problem?

Greetings
Marcus
Comment 2 Viktor S 2009-08-28 13:00:07 UTC
If Marcus' solution doesn't work or gconfd-2 already is started, please attach emerge --info and the output of mono -V :-)
Comment 3 Henrik Johansson 2009-08-28 15:24:50 UTC
(In reply to comment #2)
> If Marcus' solution doesn't work or gconfd-2 already is started, please attach
> emerge --info and the output of mono -V :-)
> 

Unfortunately Marcus' solution didn't work. gconfd-2 wasn't started but it didn't make any difference when I started it. Here's my 'emerge --info':

Portage 2.1.6.13 (default/linux/x86/2008.0, gcc-4.4.1, glibc-2.10.1-r0, 2.6.28-gentoo-r5 i686)
=================================================================
System uname: Linux-2.6.28-gentoo-r5-i686-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.0.1
Timestamp of tree: Fri, 28 Aug 2009 07:00:01 +0000
distcc 3.1 i686-pc-linux-gnu [enabled]
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.5.4-r2, 2.6.2-r1, 3.1.1
dev-util/cmake:      2.6.3-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distcc distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.sunet.se/pub/Linux/distributions/gentoo/distfiles http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac alsa audacious bzip2 cairo cracklib crypt cups dbus dri dvd encode exif ffmpeg firefox flac gif gimp gtk gtk2 hal hardened hddtemp imlib jpeg lirc mad mmx mmx2 mmxext mono mp3 mplayer msn nls nptl nptlonly nsplugin nvidia ogg oggvorbis opengl pam pdf perl png quicktime raw readline rtc samba scanner scrobbler se_swedb server srt sse sse2 ssl svg sysfs teletext theora thunar tiff truetype tv udev unicode usb v4l v4l2 vim-syntax vorbis win32codecs wma x86 xmp xorg xv xvid" ALSA_CARDS="intel8x0 cmipci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIRC_DEVICES="pctv" SANE_BACKENDS="nothing" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



And 'mono -V':

Mono JIT compiler version 2.4.2.3 (tarball Mon Aug 24 17:36:43 CEST 2009)
Copyright (C) 2002-2008 Novell, Inc and Contributors. www.mono-project.com
	TLS:           __thread
	GC:            Included Boehm (with typed GC)
	SIGSEGV:       altstack
	Notifications: epoll
	Architecture:  x86
	Disabled:      none
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2009-08-29 16:46:14 UTC
This looks like upstream bug in URL. This was a problem with the gconf-sharp binding, which has been fixed in gconf-sharp for many moons now. It could possibly be that you have an old version of gconf-sharp lying around. Try searching for gconf-sharp.dll in /usr/local and /usr/lib:
find /usr/local /usr/lib{32,64,} -name 'gconf-sharp.dll'
and post the output.
Comment 5 Henrik Johansson 2009-08-29 16:59:40 UTC
# find /usr/local /usr/lib{32,64,} -name 'gconf-sharp.dll'
find: `/usr/lib32': No such file or directory
find: `/usr/lib64': No such file or directory
/usr/lib/mono/gac/gconf-sharp/2.24.0.0__35e10195dab3c99f/gconf-sharp.dll
/usr/lib/mono/gtk-sharp-2.0/gconf-sharp.dll
Comment 6 Henrik Johansson 2009-09-05 22:04:21 UTC
Any idea what could be wrong? Is there something else I can try?
Comment 7 Markus 2009-09-21 13:24:56 UTC
I got the same problem and I have no idea how to solve it.
Only v0.5.0.3-r1 is working.

I am not using gnome but comment #1 unfortunately didn't change anything.
Comment 8 Viktor S 2009-09-21 21:02:42 UTC
I realize it might not be a viable solution for everyone, but asking on IRC might get you help faster than on the bugzilla where bugs are (unfortunately) easily forgotten. Remember the bug# and ask in #gentoo. Please don't kill me for giving this tip bonsaikitten. ;)
Comment 9 Brian Beardall 2009-10-26 21:51:00 UTC
I possibly had the same problem and it was related to media-libs/jpeg. Several of the packages were compiled for jpeg-7 and others for jpeg-6. By re-installing jpeg-7 I was able to get a preserved-rebuild list for portage-2.2_rc46. Then after about 50 packages were rebuilt against the newer version I was able to get f-spot working again. I hope this helps.
Comment 10 Oo.et.oO 2009-11-04 20:54:30 UTC
same prob here.
gconfd-2 running.  using media-libs/jpeg-6b-r8
Comment 11 Roger 2009-11-12 22:32:23 UTC
Negative here. I've tried all proposed solutions and still get the same error!

Even trying to build f-spot with nostrip & noclean and trying to get a trace with gdb is futile as gdb doesn't see f-spot.exe as an executable.

... rebuilding mono as (strace) stdout dictacts.

(Everything F-Spot does, could be completed via a script, along with putting all tagging into a text file. :-/ )
Comment 12 Roger 2009-11-12 22:39:42 UTC
Created attachment 210087 [details]
Debug output

Well, I *think* debug USE flag automagickly turns on gdb output? <shrugs> mono.. blah.
Comment 13 Oo.et.oO 2009-12-11 22:55:17 UTC
what's going on with this?   we can't be the only ones using f-spot.  it's gnome's default photo wrangler, no?  i need the new features in 6.0.
Comment 14 Roger 2009-12-11 23:25:15 UTC
So far, from what I've seen, if you want to start f-spot these days, you have to also be using the Gnome desktop. :-/

Whatever it is, Gnome is starting a daemon of something (gconfd???) and F-Spot is looking for it.  If it can't find it, it quits like this.

(Switched from using DWM back to Gnome to be able to start F-Spot. :-/)
Comment 15 Roger 2010-01-08 08:23:49 UTC
This bug (as well as others) may likely be already fixed with the latest F-Spot releases.

From what I hear from the f-spot irc, one dev states he fixed (my) missing g_type error (crash) in 0.6.1.3

See Bug #299489 for version bump request of f-spot-0.6.1.5
Comment 16 Henrik Johansson 2010-01-08 11:54:42 UTC
0.6.1.5 works fine, thanks roger!
Comment 17 Roger 2010-01-09 01:21:59 UTC
I didn't submit the version bump request and modified ebuild. I only made mention here & on f-spot IRC. ;-)

Please note, my attempt to install of 0.6.1.5 failed with a sandbox violation.  I posted the relevant debug info to the bug page of the version bump request.

Glad to see it works.  I'll try to fix the ebuild myself if somebody else doens't tackle it before I do.

One thing I'd really like to do, is grab the import code/algorithms from f-spot that import photos from digital devices.  I like f-spot's import and folder style/structures as it's easily navigatable from console/commandline.  But the f-spot GUI is starting to require more X resources and getting worse with it's eye candy.  So, I think it would be nice to import and show photos using tags through the Bash console.  And use the GUI for the wife & kids.

Since you've mentioned this fixes things, I'll close this bug.
Comment 18 Henrik Johansson 2010-01-09 09:21:13 UTC
(In reply to comment #17)
> Please note, my attempt to install of 0.6.1.5 failed with a sandbox violation. 

Same thing for me, i just used the sandbox violation patch from earlier versions.