Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 282826 - kde-base/superkaramba-4.3.0 fails to compile [python3 + gcc 4.4]
Summary: kde-base/superkaramba-4.3.0 fails to compile [python3 + gcc 4.4]
Status: RESOLVED DUPLICATE of bug 312663
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-26 19:32 UTC by Michael B
Modified: 2010-04-13 17:12 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael B 2009-08-26 19:32:14 UTC
When  I try to emerge superkaramba,  fails at about 50% compiled

Reproducible: Always

Steps to Reproduce:
1.emerge kde-base/superkaramba
2.
3.

Actual Results:  
 50%] Building CXX object superkaramba/src/CMakeFiles/superkaramba.dir/python/karamba.o                                                      
In file included from /usr/include/python3.1/Python.h:72,                                                                                     
                 from /var/tmp/portage/kde-base/superkaramba-4.3.0/work/superkaramba-4.3.0/superkaramba/src/python/karamba.cpp:30:            
/usr/include/python3.1/longobject.h:36:5: warning: "SIZEOF_SOCKET_T" is not defined                                                           
/var/tmp/portage/kde-base/superkaramba-4.3.0/work/superkaramba-4.3.0/superkaramba/src/python/karamba.cpp: In constructor 'KarambaPython::KarambaPython(const ThemeFile&, bool)':                                                                                                            
/var/tmp/portage/kde-base/superkaramba-4.3.0/work/superkaramba-4.3.0/superkaramba/src/python/karamba.cpp:362: error: 'Py_InitModule' was not declared in this scope                                                                                                                         
/var/tmp/portage/kde-base/superkaramba-4.3.0/work/superkaramba-4.3.0/superkaramba/src/python/karamba.cpp:366: error: 'PyString_FromString' was not declared in this scope                                                                                                                   
make[2]: *** [superkaramba/src/CMakeFiles/superkaramba.dir/python/karamba.o] Error 1                                                          
make[1]: *** [superkaramba/src/CMakeFiles/superkaramba.dir/all] Error 2                                                                       
make: *** [all] Error 2                                                           

Expected Results:  
be able to compile

This was found when trying to revdep-rebuild, Some of my widgets in kde do not work. :
Portage 2.1.6.13 (default/linux/x86/2008.0, gcc-4.4.1, glibc-2.10.1-r0, 2.6.30-gentoo-r4-bostwick-server i686)
=================================================================                                             
System uname: Linux-2.6.30-gentoo-r4-bostwick-server-i686-Intel-R-_Core-TM-2_Duo_CPU_E8500_@_3.16GHz-with-gentoo-2.0.1
Timestamp of tree: Wed, 26 Aug 2009 17:15:01 +0000                                                                    
app-shells/bash:     4.0_p28                                                                                          
dev-java/java-config: 2.1.8-r1                                                                                        
dev-lang/python:     2.6.2-r1, 3.1.1                                                                                  
dev-util/cmake:      2.6.4-r2                                                                                         
sys-apps/baselayout: 2.0.1                                                                                            
sys-apps/openrc:     0.4.3-r3                                                                                         
sys-apps/sandbox:    2.0                                                                                              
sys-devel/autoconf:  2.13, 2.63-r1                                                                                    
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11                                                                 
sys-devel/binutils:  2.19.1-r1                                                                                        
sys-devel/gcc-config: 1.4.1                                                                                           
sys-devel/libtool:   2.2.6a                                                                                           
virtual/os-headers:  2.6.30-r1                                                                                        
ACCEPT_KEYWORDS="x86 ~x86"                                                                                            
CBUILD="i686-pc-linux-gnu"                                                                                            
CFLAGS="-O2 -march=i686 -pipe"                                                                                        
CHOST="i686-pc-linux-gnu"                                                                                             
CONFIG_PROTECT="/etc /usr/share/config"                                                                               
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"                                                                                                                 
CXXFLAGS="-O2 -march=i686 -pipe"                                                                                                              
DISTDIR="/usr/portage/distfiles"                                                                                                              
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ ftp://ftp.gtlib.gatech.edu/pub/gentoo http://www.gtlib.gatech.edu/pub/gentoo http://gentoo.mirrors.pair.com/ ftp://gentoo.mirrors.pair.com/ http://lug.mtu.edu/gentoo/ ftp://lug.mtu.edu/gentoo/ "
LDFLAGS="-Wl,-O1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="# 7zip X a52 aac acl acpi activefilter admin administrator alsa amarok2 apache2 apm archive arts aspell backtrace bash-completion berkdb branding bugzilla bzip2 cairo calendar chm cisco cli clipboard cmake colordiff colors corefonts cracklib crypt css csv cups curl curlwrappers cvs cxx db2 dbus disk-partition dns dri dvd dvdnav dvdr dvdread ebook editor eds embedded encode esd evo excel exchange exif faac faad faillog fat fbsplash festival ffmpeg filter finger firebird firefox firefox3 flash fortran ftp gcrypt gdbm gecko geoip gif gmail google google-gadgets gpm groupwise grub gs gstreamer gtkspell hal hpn http http-forms http-server httpd hub icons iconv ieee1394 injection inkjar inline iostats iproute2 ipsec ipv6 irc irda isdnlog iso14755 jabber java javascript john joystick jpeg jpeg2k jpg kate kde kde4 lcms ldap libcaca libedit libnotify libssh2 lirc lm_sensors log4j logwatch mail md5sum meanwhile mime mjpeg mng mono mp3 mp4 mpeg msn msql mssql mudflap multiuser munin-apache munin-dhcp munin-irc munin-surfboard mysql mysqli nat ncurse ncurses net network network-cron networking nfs nfsv3 nfsv4 nids nls nmap nptl nptlonly nss ntfs ntp objc objc++ objc-gc odbc openal opengl openid openmp openssl opensslcrypt openvpn oracle otr pam passwd passwordsave pastebin pcap pcre pda pdf perl perl-geoipupdate php pidgin plasma player plugins pm-utils png podcast pop pop3d posix postproc postscript pppd pptp prediction ps python python-bindings python3 pythong qmake qt3 qt3support qt4 radio rar raw rdesktop react readline recode reflection regex rrdtool rss samba scanner screen search serial server session sftp shadow skype sms smtp sndfile snes snmp sockets socks socks5 solver speech spell spl spoof-source sql sqlite sqlite3 ssh ssl stats subversion suexec svg sysfs tcl tcpd tcpdump tcpmd5 tcpwrapper tftp themes theora thumbnail thunderbird tk tls tordns tos trace transcode tts ui unicode unzip upnp url usb utils v4l v4l2 vcd video video-file videos visual vlc vnc vorbis wav wavpack weather web webkit webmail wifi wildcards win32codecs winetools wireshark wma wma-fixed wmf wmp wps x264 x86 xine xinerama xml xorg xterm yahoo zeroconf zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-08-26 20:27:26 UTC
You failed to read a warning which is printed during installation of dev-util/cmake with USE="python3".
Comment 2 Michael B 2009-08-28 15:29:49 UTC
I dont think this bug should be closed, because it still is broken. The message simply says submit patch with any bugs because python is experimental. The problem is still there is just hasnt been fixed or patched. 
Comment 3 Dean Adams 2010-03-21 16:58:24 UTC
Got this error, saw the -fPIC note to recompile, did that against python, showed breakage errors but continued on anyway. Still bombs out. 



Linking CXX shared library ../../lib/libsuperkaramba.so                                                                                                                                   
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.4/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib64/python2.6/config/libpython2.6.a(abstract.o): relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC                                                                                                                            
/usr/lib64/python2.6/config/libpython2.6.a: could not read symbols: Bad value                                                                                                             
collect2: ld returned 1 exit status                                                                                                                                                       
make[2]: *** [lib/libsuperkaramba.so.4.3.0] Error 1                                                                                                                                       
make[1]: *** [superkaramba/src/CMakeFiles/superkaramba.dir/all] Error 2                                                                                                                   
make: *** [all] Error 2                                                                                                                                                                   
 * ERROR: kde-base/superkaramba-4.3.5 failed:                                                                                                                                             
 *   Make failed!                                                                                                                                                                         
 *                                                                                                                                                                                        
 * Call stack:                                                                                                                                                                            
 *     ebuild.sh, line   54:  Called src_compile                                                                                                                                          
 *   environment, line 4229:  Called kde4-meta_src_compile                                                                                                                                
 *   environment, line 3314:  Called kde4-base_src_compile                                                                                                                                
 *   environment, line 2991:  Called cmake-utils_src_compile                                                                                                                              
 *   environment, line 1121:  Called _execute_optionaly 'src_compile'                                                                                                                     
 *   environment, line  552:  Called enable_cmake-utils_src_compile                                                                                                                       
 *   environment, line 1496:  Called cmake-utils_src_make                                                                                                                                 
 *   environment, line 1140:  Called die                                                                                                                                                  
 * The specific snippet of code:                                                                                                                                                          
 *           emake "$@" || die "Make failed!";                                                                                                                                            
 *                                                                                                                                                                                        
 * If you need support, post the output of 'emerge --info =kde-base/superkaramba-4.3.5',                                                                                                  
 * the complete build log and the output of 'emerge -pqv =kde-base/superkaramba-4.3.5'.                                                                                                   
 * The complete build log is located at '/var/tmp/portage/kde-base/superkaramba-4.3.5/temp/build.log'.                                                                                    
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/superkaramba-4.3.5/temp/environment'.                                                                             
 * S: '/var/tmp/portage/kde-base/superkaramba-4.3.5/work/superkaramba-4.3.5'                                                                                                              

>>> Failed to emerge kde-base/superkaramba-4.3.5, Log file:



emerge --info =kde-base/superkaramba-4.3.5
Portage 2.1.7.17 (default/linux/amd64/10.0, gcc-4.3.4, glibc-2.10.1-r1, 2.6.28-gentoo-r5 x86_64)
=================================================================                               
                        System Settings                                                         
=================================================================                               
System uname: Linux-2.6.28-gentoo-r5-x86_64-Dual_Core_AMD_Opteron-tm-_Processor_170-with-gentoo-2.0.1
Timestamp of tree: Sat, 20 Mar 2010 05:45:01 +0000                                                   
app-shells/bash:     4.0_p35                                                                         
dev-java/java-config: 2.1.10                                                                         
dev-lang/python:     2.5.4-r3, 2.6.4-r1                                                              
dev-util/cmake:      2.6.4-r3                                                                        
sys-apps/baselayout: 2.0.1                                                                           
sys-apps/openrc:     0.6.0-r1                                                                        
sys-apps/sandbox:    1.6-r2                                                                          
sys-devel/autoconf:  2.13, 2.63-r1                                                                   
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.3                                            
sys-devel/binutils:  2.18-r3                                                                         
sys-devel/gcc:       4.3.4                                                                           
sys-devel/gcc-config: 1.4.1                                                                          
sys-devel/libtool:   2.2.6b                                                                          
virtual/os-headers:  2.6.30-r1                                                                       
ACCEPT_KEYWORDS="amd64"                                                                              
ACCEPT_LICENSE="* -@EULA"                                                                            
CBUILD="x86_64-pc-linux-gnu"                                                                         
CFLAGS="-march=athlon64 -O2 -pipe -ggdb -fPIC"                                                       
CHOST="x86_64-pc-linux-gnu"                                                                          
CONFIG_PROTECT="/etc /lib/modules /usr/lib64/X11 /usr/share/X11 /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"                                                                                   
CXXFLAGS="-march=athlon64 -O2 -pipe -ggdb -fPIC"                                                                                                                                          
DISTDIR="/usr/portage/distfiles"                                                                                                                                                          
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"                                           
GENTOO_MIRRORS="http://gentoo.osuosl.org/ ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://ftp.gtlib.gatech.edu/pub/gentoo http://www.gtlib.gatech.edu/pub/gentoo ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://gentoo.cites.uiuc.edu/pub/gentoo/ "
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl amd64 apache apache2 arts audiofile bitmap-fonts bzip2 cairo caps cdr cli cracklib crypt ctype cups cxx dbus dri dvd dvdr dvdread en encode fbcon ffmpeg firefox flash foomaticdb fortran gd gdbm gif gimpprint glitz gnome gphoto2 gpm gtk gtk2 hal iconv imagemagick imlib java javascript jpeg kde kerberos latin1 ldap libwww live lm_sensors lzo mad mikmod mime mmx modules mpeg mudflap multilib mysql mysqli ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openmp pam pcre pdf pdflib perl php pmount png ppds pppd python qt3support quicktime rdesktop readline reflection scanner sdl session slp spell spl sse sse2 ssl svg swat sysfs tcpd theora tiff truetype truetype-fonts type1-fonts unicode userlocales vcd winbind wmf xanim xine xorg xvid yahoo zlib" ALSA_CARDS="emu10k1x" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Dean Adams 2010-03-21 17:02:12 UTC
Forgot to add this.

http://www.gentoo.org/proj/en/base/amd64/howtos/index.xml?part=1&chap=3


3.f. Case 3: Lack of `-fPIC' flag in the software to be built

This is the most common case. It is a real bug in the build system and should be fixed in the ebuild, preferably with a patch that is sent upstream. Assuming the error message looks like this:

Code Listing 6.1: A sample error message

.libs/assert.o: relocation R_X86_64_32 against `a local symbol' can not be used
when making a shared object; recompile with -fPIC .libs/assert.o: could not
read symbols: Bad value

This means that the file assert.o was not compiled with the -fPIC flag, which it should. When you fix this kind of error, make sure only objects that are used in shared libraries are compiled with -fPIC.

In this case, globally adding -fPIC to C[XX]FLAGS resolves the issue, although this practice is discouraged because the executables end up being PIC-enabled, too. 
Comment 5 Andreas K. Hüttel gentoo-dev 2010-03-23 19:17:38 UTC
CCing python, since the miscompiled file is /usr/lib64/python2.6/config/libpython2.6.a(abstract.o)
Comment 6 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-03-24 06:28:05 UTC
(In reply to comment #5)
> CCing python, since the miscompiled file is
> /usr/lib64/python2.6/config/libpython2.6.a(abstract.o)

dev-lang/python:2.6 installs only /usr/lib64/libpython2.6.a, not /usr/lib64/python2.6/config/libpython2.6.a.
Comment 7 Andreas K. Hüttel gentoo-dev 2010-03-28 19:10:48 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > CCing python, since the miscompiled file is
> > /usr/lib64/python2.6/config/libpython2.6.a(abstract.o)
> 
> dev-lang/python:2.6 installs only /usr/lib64/libpython2.6.a, not
> /usr/lib64/python2.6/config/libpython2.6.a.
> 

Dean, what's the output of 
equery belongs /usr/lib64/python2.6/config/libpython2.6.a
???
Comment 8 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-04-13 17:12:25 UTC

*** This bug has been marked as a duplicate of bug 312663 ***