Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 282573 - media-libs/libcaca-0.99_beta16 fails to build with =media-libs/freeglut-2.6*
Summary: media-libs/libcaca-0.99_beta16 fails to build with =media-libs/freeglut-2.6*
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: Highest normal (vote)
Assignee: media-video herd
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard:
Keywords:
: 282762 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-24 14:46 UTC by Steffen Hau
Modified: 2009-08-26 07:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to fix undefined reference error (libcaca-0.99_beta16-fix-undefined-symbol-glu.patch,622 bytes, patch)
2009-08-24 15:04 UTC, Steffen Hau
Details | Diff
Ebuild patch which includes patch from comment #1 (libcaca-ebuild.patch,329 bytes, patch)
2009-08-24 15:05 UTC, Steffen Hau
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Hau 2009-08-24 14:46:42 UTC
My emerge -e @system stopped at compiling libcaca with:

libtool: link: i686-pc-linux-gnu-gcc -march=core2 -O2 -pipe -fomit-frame-pointer -mfpmath=sse -msse3 -Wall -Wpointer-arith -Wcast-align -Wcast-qual -Wstrict-prototypes -Wshadow -Waggregate-return -Wmissing-prototypes -Wnested-externs -Wsign-compare -Wl,-O1 -Wl,-znow -Wl,--sort-common -s -o .libs/cacafire aafire.o  -Wl,--as-needed -L/usr/lib ../caca/.libs/libcaca.so -lncursesw /usr/lib/libglut.so -lm /usr/lib/libGL.so /usr/lib/libXmu.so /usr/lib/libXt.so /usr/lib/libSM.so -luuid /usr/lib/libICE.so -lpthread /usr/lib/libXxf86vm.so /usr/lib/libXi.so /usr/lib/libXext.so /usr/lib/libX11.so /usr/lib/libxcb.so /usr/lib/libXdmcp.so -ldl /usr/lib/libXau.so -lz
../caca/.libs/libcaca.so: undefined reference to `gluOrtho2D'
collect2: ld returned 1 exit status
make[2]: *** [cacafire] Error 1
make[2]: *** Waiting for unfinished jobs....
libtool: link: i686-pc-linux-gnu-gcc -march=core2 -O2 -pipe -fomit-frame-pointer -mfpmath=sse -msse3 -Wall -Wpointer-arith -Wcast-align -Wcast-qual -Wstrict-prototypes -Wshadow -Waggregate-return -Wmissing-prototypes -Wnested-externs -Wsign-compare -Wl,-O1 -Wl,-znow -Wl,--sort-common -s -o .libs/cacaplay cacaplay.o  -Wl,--as-needed -L/usr/lib ../caca/.libs/libcaca.so -lncursesw /usr/lib/libglut.so -lm /usr/lib/libGL.so /usr/lib/libXmu.so /usr/lib/libXt.so /usr/lib/libSM.so -luuid /usr/lib/libICE.so -lpthread /usr/lib/libXxf86vm.so /usr/lib/libXi.so /usr/lib/libXext.so /usr/lib/libX11.so /usr/lib/libxcb.so /usr/lib/libXdmcp.so -ldl /usr/lib/libXau.so -lz
mv -f .deps/cacademo.Tpo .deps/cacademo.Po
../caca/.libs/libcaca.so: undefined reference to `gluOrtho2D'
collect2: ld returned 1 exit status
make[2]: *** [cacaplay] Error 1
libtool: link: i686-pc-linux-gnu-gcc -march=core2 -O2 -pipe -fomit-frame-pointer -mfpmath=sse -msse3 -Wall -Wpointer-arith -Wcast-align -Wcast-qual -Wstrict-prototypes -Wshadow -Waggregate-return -Wmissing-prototypes -Wnested-externs -Wsign-compare -Wl,-O1 -Wl,-znow -Wl,--sort-common -s -o .libs/cacaview cacaview-cacaview.o cacaview-common-image.o  /usr/lib/libImlib2.so -L/usr/X11R6/lib /usr/lib/libfreetype.so -Wl,--as-needed -L/usr/lib ../caca/.libs/libcaca.so -lncursesw /usr/lib/libglut.so -lm /usr/lib/libGL.so /usr/lib/libXmu.so /usr/lib/libXt.so /usr/lib/libSM.so -luuid /usr/lib/libICE.so -lpthread /usr/lib/libXxf86vm.so /usr/lib/libXi.so /usr/lib/libXext.so /usr/lib/libX11.so /usr/lib/libxcb.so /usr/lib/libXdmcp.so -ldl /usr/lib/libXau.so -lz
../caca/.libs/libcaca.so: undefined reference to `gluOrtho2D'
collect2: ld returned 1 exit status
make[2]: *** [cacaview] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-libs/libcaca-0.99_beta16/work/libcaca-0.99.beta16/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-libs/libcaca-0.99_beta16/work/libcaca-0.99.beta16'
make: *** [all] Error 2

The build is done against media-libs/freeglut-2.6.0_rc1, whose /usr/lib/glut.so is no longer linked against libGLU.so (ChangeLog says, it's no longer needed). If I try to compile libcaca against freeglut-2.4.0-r1 (which is linked against libGLU.so), compilation works without any errors. As libcaca needs libGLU.so, there should be a fix, that includes '-lGLU'.

Reproducible: Always

Steps to Reproduce:
1. compile libcaca against freeglut-2.6.0_rc1
2.
3.

Actual Results:  
Compilation failes
Comment 1 Steffen Hau 2009-08-24 15:04:42 UTC
Created attachment 202161 [details, diff]
Patch to fix undefined reference error

This patch includes '-lGLU' in configure.ac, so that 'l-GLU' is used, when libcaca.so is linked and also in all other depend things.
Comment 2 Steffen Hau 2009-08-24 15:05:34 UTC
Created attachment 202162 [details, diff]
Ebuild patch which includes patch from comment #1

This is a patched ebuild for libcaca which uses the patch from comment #1
Comment 3 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-08-24 19:54:18 UTC
Fixed.
Comment 4 Alexis Ballier gentoo-dev 2009-08-26 07:41:37 UTC
*** Bug 282762 has been marked as a duplicate of this bug. ***