Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 282089 - media-video/vlc-0.9.10 prevents upgrade of www-client/mozilla-firefox-3.5.2-r1
Summary: media-video/vlc-0.9.10 prevents upgrade of www-client/mozilla-firefox-3.5.2-r1
Status: RESOLVED DUPLICATE of bug 285370
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Alexis Ballier
Depends on: 284780
  Show dependency tree
Reported: 2009-08-20 11:41 UTC by Toralf Förster
Modified: 2009-10-19 01:41 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

vlc-0.9.10 xulrunner-1.9.1.x support (vlc-0.9.10.ebuild,11.01 KB, patch)
2009-08-21 05:01 UTC, Jory A. Pratt
Details | Diff
actual patch and not the ebuild. (vlc-0.9.10-xulrunner191-support.patch,938 bytes, patch)
2009-08-21 05:03 UTC, Jory A. Pratt
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2009-08-20 11:41:07 UTC
n22 /usr/src # emerge --nospinner --newuse --update --ask --verbose --deep --tree --with-bdeps=y world

These are the packages that would be merged, in reverse order:

Calculating dependencies ... done!
[nomerge      ] media-video/vlc-0.9.10  USE="X a52 aac alsa cdda cddax cddb cdio dbus dts dvd ffmpeg flac gcrypt libnotify mmx mp3 mpeg ncurses nsplugin ogg opengl png qt4 sdl sse svg truetype vorbis win32codecs x264 xml xv -aalib (-altivec) -arts -atmo -avahi -bidi -dc1394 -debug -dirac -directfb -dvb -esd -fbcon -fluidsynth -fontconfig -ggi -gnome -gnutls -hal -httpd -id3tag -jack -kate -libass -libcaca -libsysfs -libv4l2 -lirc -live -lua -matroska -modplug -musepack -optimisememory -oss -pda -pulseaudio -pvr -remoteosd -rtsp -run-as-root -samba -schroedinger -sdl-image -seamonkey -shout -skins -speex -stream -svga -taglib -theora -twolame -upnp -v4l -v4l2 -vcdinfo -vcdx -vlm -xinerama -xosd -zvbi"
[ebuild     UD]  net-libs/xulrunner- [] USE="dbus java startup-notification -custom-optimization -gnome" 33,415 kB
[ebuild     U ] www-client/mozilla-firefox-3.5.2-r1 [3.0.13] USE="alsa%* dbus java startup-notification -bindist -custom-optimization -gnome -iceweasel -mozdevelop -restrict-javascript (-xulrunner%*)" LINGUAS="de en -af -ar -as% -be -bg -bn -bn_BD% -bn_IN -ca -cs -cy -da -el -en_GB -en_US -eo -es -es_AR -es_CL% -es_ES -es_MX% -et -eu -fa% -fi -fr -fy -fy_NL -ga -ga_IE -gl -gu -gu_IN -he -hi -hi_IN -hr% -hu -id -is -it -ja -ka -kk% -kn -ko -ku -lt -lv -mk -ml% -mn -mr -nb -nb_NO -nl -nn -nn_NO -oc -or% -pa -pa_IN -pl -pt -pt_BR -pt_PT -rm% -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -ta% -ta_LK% -te -th -tr -uk -vi% -zh_CN -zh_TW (-zh%)" 45,825 kB
[ebuild     U ]  net-libs/xulrunner- [] USE="alsa%* dbus java python%* startup-notification -custom-optimization -debug% -gnome" 9 kB
[ebuild     U ]   x11-libs/cairo-1.8.8 [1.8.6-r1] USE="X opengl svg -cleartype -debug -directfb -doc -glitz -xcb" 6,491 kB

Total: 4 packages (3 upgrades, 1 downgrade), Size of downloads: 85,739 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:


  ('ebuild', '/', 'net-libs/xulrunner-', 'merge') pulled in by
    <net-libs/xulrunner-1.9.1 required by ('installed', '/', 'media-video/vlc-0.9.10', 'nomerge')
    (and 2 more)

  ('ebuild', '/', 'net-libs/xulrunner-', 'merge') pulled in by
    >=net-libs/xulrunner-[java] required by ('ebuild', '/', 'www-client/mozilla-firefox-3.5.2-r1', 'merge')
    (and 2 more)

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

Reproducible: Always

n22 /usr/src # emerge --info
Portage (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, i686)
System uname: Linux-
Timestamp of tree: Thu, 20 Aug 2009 11:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="de en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa apache2 berkdb bluetooth branding bzip2 cairo cdda cddax cddb cdio cdr cli consolekit cracklib crypt cups curl dbus dri dts dvd dvdr eds emboss encode evo exif fam fastbuild firefox flac fortran gdbm geoip gif gmp gpm gstreamer gtk hyphenation iconv ipv6 isdnlog java jpeg kde ldap libnotify mad mbox mikmod mmx mp3 mp4 mpeg mudflap mysql nano-syntax ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime rdesktop readline reflection sdl session slp spell spl sse sse2 ssl ssse3 startup-notification svg sysfs tcpd tiff tk truetype unicode usb vcd vim-syntax vorbis win32codecs wmf x264 x86 xml xorg xpm xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard evdev mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" USERLAND="GNU" VIDEO_CARDS="intel"
Comment 1 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-08-20 14:06:21 UTC
... and mozilla-firefox-3.5.2-r1 is going stable (bug 280393)
Comment 2 Daniel Cater 2009-08-20 14:13:51 UTC
I reported a similar problem in bug 282101 where Epiphany 2.24 (latest stable) requires Xulrunner 1.9.0 but Firefox 3.5 (latest stable) requires Xulrunner 1.9.1. Both of these Xulrunner builds are in the same slot (1.9) and hence the failure. The only reason I didn't hit this bug is because I have "-nsplugin" in my USE flags (which is where the Xulrunner dependency for VLC comes from).
Comment 3 Toralf Förster gentoo-dev 2009-08-20 14:23:56 UTC
(In reply to comment #2)
> The only reason I didn't hit this bug is because I have "-nsplugin" in
> my USE flags (which is where the Xulrunner dependency for VLC comes from).
heh - good hint for a temporary hack :-)

Comment 4 Jory A. Pratt gentoo-dev 2009-08-21 04:19:32 UTC
The actual bug should be more about how vlc-0.9.10 has always worked with xulrunner-1.9.1.x but fails to make the define for NPFUNCTIONS_H which is what actually prevents the current build from working. This is one of them bugs that should actually be fixed in vlc-0.9.10 rather then holding up a stabilization of xulrunner-1.9.1.x/firefox-3.5.x.
Comment 5 Jory A. Pratt gentoo-dev 2009-08-21 05:01:07 UTC
Created attachment 201836 [details, diff]
vlc-0.9.10 xulrunner-1.9.1.x support 

Here is a simple patch that enables proper check for the xulrunner headers. This patch is fully tested on x86_64, there are QA issues that will cause a failure but can be worked around in the ebuild for 64bit archs.
Comment 6 Jory A. Pratt gentoo-dev 2009-08-21 05:03:24 UTC
Created attachment 201838 [details, diff]
actual patch and not the ebuild.

Sorry clicked wrong file, this is the actual patch that would be required for vlc-0.9.10 to compile with xulrunner-
Comment 7 Oliver Schwabedissen 2009-08-21 05:16:25 UTC
I have similar problems, not only vlc-0.9.10 is blocking xulrunner- and therefore firefox-3.5:


  ('ebuild', '/', 'net-libs/xulrunner-', 'merge') pulled in by
    >=net-libs/xulrunner-[java] required by ('ebuild', '/', 'www-client/mozilla-firefox-3.5.2-r1', 'merge')
    (and 4 more)

  ('installed', '/', 'net-libs/xulrunner-', 'nomerge') pulled in by
    =net-libs/xulrunner-1.9.0*:1.9 required by ('installed', '/', 'dev-java/swt-3.4-r3', 'nomerge')
    =net-libs/xulrunner-1.9.0* required by ('installed', '/', 'app-office/openoffice-3.0.0', 'nomerge')
    <net-libs/xulrunner-1.9.1 required by ('installed', '/', 'media-video/vlc-0.9.10', 'nomerge')
    (and 4 more)

BTW: is there a way to see the "4 more" packages requiring xulrunner <

For the moment I've masked mozilla-firefox-3.5.2 and emerged unstable firefox-3.0.13 to get around the bugs in v3.0.11 and 3.0.12.
Comment 8 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-09-13 10:08:59 UTC
@aballier: can we get vlc-1.0.1 stable?
Comment 9 Alexis Ballier gentoo-dev 2009-09-13 14:14:30 UTC
(In reply to comment #8)
> @aballier: can we get vlc-1.0.1 stable?

yes if you can get the required pulseaudio stable too.
Comment 10 Samuli Suominen (RETIRED) gentoo-dev 2009-09-13 16:02:00 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > @aballier: can we get vlc-1.0.1 stable?
> yes if you can get the required pulseaudio stable too.

That should be now possible since Diego fixed libtool's test suite so it can go stable :-)
Comment 11 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-10-19 01:41:29 UTC
We'll handle this with 1.0.2...

*** This bug has been marked as a duplicate of bug 285370 ***