Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 282013 - net-im/pidgin-2.6.1 version bump
Summary: net-im/pidgin-2.6.1 version bump
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo net-im Herd
URL: http://developer.pidgin.im/wiki/Chang...
Whiteboard:
Keywords:
: 282056 282314 282376 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-19 11:02 UTC by Jeroen Roovers (RETIRED)
Modified: 2009-08-23 15:33 UTC (History)
19 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Proposed ebuild (pidgin-2.6.1.ebuild,4.41 KB, text/plain)
2009-08-20 01:08 UTC, Todd Eisenberger
Details
Modified version of the above ebuild (pidgin-2.6.1.ebuild,4.42 KB, text/plain)
2009-08-20 05:55 UTC, Randall Wald
Details
Added gconf dependency (pidgin-2.6.1.ebuild,4.44 KB, text/plain)
2009-08-21 10:17 UTC, kirin yuri
Details
Fixed ebuild ( use vv && ! use gstreamer -> die ) (pidgin-2.6.1.ebuild,4.51 KB, text/plain)
2009-08-21 11:48 UTC, kirin yuri
Details
pidgin-2.6.1.ebuild.diff (pidgin-2.6.1.ebuild.diff,1.14 KB, patch)
2009-08-22 10:46 UTC, Lars Wendler (Polynomial-C)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers (RETIRED) gentoo-dev 2009-08-19 11:02:36 UTC
Followed 2.6.0 rapidly.
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-08-19 18:09:58 UTC
And needs the same fix like pidgin-2.5.7 needed:

http://developer.pidgin.im/ticket/9520
Comment 2 Asbjorn Sannes 2009-08-19 19:39:40 UTC
And add dependency for "net-dns/libidn" and introduce a use-flag for video and voice, say "vv" and add "vv? ( net-libs/farsight2 )" to dependencies, and "$(use_enable vv)" to the econf line ..

Works for me atleast on ~amd64 :)

Comment 3 Dani Soufi 2009-08-19 20:20:00 UTC
(In reply to comment #0)
> Followed 2.6.0 rapidly.
> 
Pidgin 2.6.1 is released with few crash fixes:
    * Fix a crash when some users send you a link in a Yahoo IM
    * Fix compilation with GTK+ < 2.6.0
    * Fix compilation on Windows 
Probably we should work on it and not on 2.6.0 anymore? Any ebuilds suggested?
Comment 4 Olivier Crete (RETIRED) gentoo-dev 2009-08-19 20:29:55 UTC
I will do it in the near future.. There are some dependency changes since 2.5.x.. the most important of which is the requirement for Farsight2 (for the VV features). So I have to bump gstreamer and farsight2 first..
Comment 5 Thomas Sachau gentoo-dev 2009-08-20 00:13:41 UTC
*** Bug 282056 has been marked as a duplicate of this bug. ***
Comment 6 Todd Eisenberger 2009-08-20 01:08:57 UTC
Created attachment 201756 [details]
Proposed ebuild

Here's an ebuild.  Use the farsight keyword to enable new voice/video support.  Only tested it on my machine so far, so may have some problems.
Comment 7 Randall Wald 2009-08-20 05:55:24 UTC
Created attachment 201761 [details]
Modified version of the above ebuild

Similar to (and based on) the above ebuild, but adds optional, USE-based dependency on libidn (and passes --disable-idn to the ./configure script if the USE flag is disabled), as well as switching from "farsight" to "vv" for both USE flag and --enable flag. Some testing with the ./configure script shows that --enable-farsight and --enable-vv produce identical results when used alone; --enable-farsight --disable-vv gives the same result as including neither, while --disable-farsight --enable-vv gives an error about vv's dependencies not being met. I'm not sure what that says about the relative importance of farsight and vv to the ./configure script, but from the user's perspective, vv is likely to be more meaningful.
Comment 8 kirin yuri 2009-08-21 09:55:32 UTC
I'm trying to build pidgin 2.6.1 with this ebuild. It's says:

checking for gconftool-2... no
./configure: line 22210: gconftool-2: command not found
Using config source for schema installation
Using $(sysconfdir)/gconf/schemas as install directory for schema files
checking for FARSIGHT... yes
configure: error:
Dependencies for voice/video were not met.
Install the necessary gstreamer and farsight packages first.
Or use --disable-vv if you do not need voice/video support.


I have gstreamer-0.10.24 and farsight2-0.0.10 already installed.

Some dependency is missing?
Comment 9 kirin yuri 2009-08-21 10:17:04 UTC
Created attachment 201848 [details]
Added gconf dependency

I have added one line to ebuild:

        vv? ( >=net-libs/farsight2-0.0.9
                gnome-base/gconf )

because with USE="-vv" ebuild success. I have tested it on my machine.
Comment 10 kirin yuri 2009-08-21 11:48:44 UTC
Created attachment 201856 [details]
Fixed ebuild ( use vv && ! use gstreamer -> die )

Sorry sorry sorry for SPAMing you!

The source of my problem was use-flag "gstreamer". Emerging pidgin with "vv" and without "gstreamer" failed (even if i had gstreamer installed as dependency for another program).

Now final fixed ebuild (and it's work). Gconf is not needed. So i've added test: if you emerging with "vv", you must use flag "gstreamer".
Comment 11 Lars Wendler (Polynomial-C) gentoo-dev 2009-08-21 13:05:29 UTC
When you do the bump for pidgin, please fix bug #236761 as well. 
Currently pidgin fails to compile for everybody who doesn't have dev-util/intltool installed on his system. It's a build-time dependency:


------8<------8<-------8<-------8<------
checking whether NLS is requested... yes
checking for intltool-update... no
checking for intltool-merge... no
checking for intltool-extract... no
configure: error: The intltool scripts were not found. Please install intltool.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/net-im/pidgin-2.5.8/work/pidgin-2.5.8/config.log
 *
 * ERROR: net-im/pidgin-2.5.8 failed.
Comment 12 Olivier Crete (RETIRED) gentoo-dev 2009-08-21 14:26:45 UTC
Using die on flag combinations is wrong.. The enable should just enable gst is vv is required. That said, I think I will just use the "gstreamer" flag to enable vv
Comment 13 Olivier Crete (RETIRED) gentoo-dev 2009-08-22 03:38:43 UTC
its now in the tree.
Comment 14 Olivier Crete (RETIRED) gentoo-dev 2009-08-22 03:42:33 UTC
Its also fixed..
Comment 15 Randall Wald 2009-08-22 07:15:59 UTC
Wow, I wouldn't have thought that the --enable-gstreamer flag to ./configure would have the same effect as both --enable-farsight and --enable-vv, but apparently it does. So yea, I guess we all stand corrected there.
Comment 16 Randall Wald 2009-08-22 07:37:38 UTC
Though, if you don't mind me asking, why include a dependency on gst-plugins-meta? I mean, you're not including gnome-media, which includes the gstreamer-properties necessary to choose microphone input; what does gst-plugins-meta give you aside from making it easier to compile gnome-media (which also depends on gst-plugins-meta) later down the road?

And why remove the idn stuff? Now it won't build on my system, because I don't have libidn installed; shouldn't I be able to disable a USE flag and have it pass --disable-idn to the ./configure script so it won't complain anymore? Or at the very least add libidn to the dependencies unconditionally, so it will be able to build.
Comment 17 Märt Bakhoff 2009-08-22 09:27:55 UTC
I just tried emerging pidgin-2.6.1 after --sync, but failed:

checking for GSTINTERFACES... yes
checking for FARSIGHT... yes
checking for IDN... no
no
configure: error:
GNU Libidn development headers not found.
Use --disable-idn if you do not need it.

 *  The die message:
 *   econf failed

Need to add idn useflag or --disable-idn ?
Comment 18 Lars Wendler (Polynomial-C) gentoo-dev 2009-08-22 10:45:55 UTC
Reopening... because of the above mentioned problems.
Comment 19 Lars Wendler (Polynomial-C) gentoo-dev 2009-08-22 10:46:58 UTC
Created attachment 201924 [details, diff]
pidgin-2.6.1.ebuild.diff

How about this fix to the ebuild?
It should fix the idn stuff and adds $(use_enable gstreamer vv) sto the ebuild as well.
Comment 20 Xake 2009-08-22 14:57:15 UTC
Could you fix bug #282282 at the same time (pidgin-2.6.1 being packed using a broken intltool), mrpouet mentioned a sed that worked for epiphany...
Comment 21 Olivier Crete (RETIRED) gentoo-dev 2009-08-22 15:05:13 UTC
I should not do these things when I'm half asleep..
Comment 22 Olivier Crete (RETIRED) gentoo-dev 2009-08-22 15:25:33 UTC
The gst-plugins-meta is to make sure you have some sink/source installed. And also preferably some codecs.
Comment 23 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-08-22 15:43:34 UTC
*** Bug 282314 has been marked as a duplicate of this bug. ***
Comment 24 R Bar-On 2009-08-22 23:01:46 UTC
has anyone actually successfully used voice or video in 2.6.1?  I emerged successfully from the build in the tree (and configure said voice and video is being compiled), but if I got to Conversation -> Media in a conversation window, all the options are grayed out.

http://developer.pidgin.im/wiki/GSoC2008/VoiceAndVideo says:
"Make sure you have:

    * gstreamer0.10-plugins-good
    * gstreamer0.10-plugins-bad (not sure which version, but it needs to include the gstrtpbin plugin)
    * gstreamer0.10-plugins-farsight >= 0.12.6 "

the ebuild in the tree currently does not depend on media-plugins/gst-plugins-farsight.  Should it?
Comment 25 R Bar-On 2009-08-22 23:06:17 UTC
and yes, I am attempting this with an gmail/XMPP account
Comment 26 Olivier Crete (RETIRED) gentoo-dev 2009-08-22 23:46:44 UTC
No, gst-plugins-farsight no longer is a farsight2 dependency, all the required plugins have moved to gst-plugins-bad. It will also only work if the other end supports calling (so he has to be running either Empathy or a N8x0 or the windows GTalk standalone client or pidgin 2.6.x or the windows/mac google video plugin).
Comment 27 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-08-23 01:36:08 UTC
*** Bug 282376 has been marked as a duplicate of this bug. ***
Comment 28 Dani Soufi 2009-08-23 08:44:46 UTC
Pidgin crashes when trying to initiate a video call on missing `encoding` in libtheora.
Crash log:

(21:04:05) mediamanager: gst pipeline error: Could not encode stream.
(21:04:05) mediamanager: Debug details: theoraenc.c(1007): theora_enc_chain (): /GstPipeline:pipeline0/GstBin:conf_0x2d43b90/FsRtpConference:fsrtpconference0/GstBin:discover_1_96/GstTheoraEnc:theoraenc0:
libtheora has been compiled with the encoder disabled
(21:04:05) mediamanager: gst pipeline error: Internal data flow error.
(21:04:05) mediamanager: Debug details: gstbasesrc.c(2378): gst_base_src_loop (): /GstPipeline:pipeline0/GstBin:pidgindefaultvideosrc/GstBin:pidgindefaultvideosrc/GstGConfVideoSrc:gconfvideosrc0/GstBin:bin3/GstV4l2Src:v4l2src0:
streaming task paused, reason error (-5)
(21:04:05) GLib: gmem.c:136: failed to allocate 3382854549 bytes

Fixed it by recompiling libtheora with encode* flag.
Comment 29 Jeroen Roovers (RETIRED) gentoo-dev 2009-08-23 15:33:37 UTC
(In reply to comment #28)
> Pidgin crashes when trying to initiate a video call on missing `encoding` in
> libtheora.

This has nothing to do with bumping the ebuild or the necessary changes. Please go and file a new bug for this new issue.