Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 281676 - Emerge openoffice failed if XML::Parser perl module not installed
Summary: Emerge openoffice failed if XML::Parser perl module not installed
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-16 13:48 UTC by Andrey Voronov
Modified: 2013-12-19 15:14 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (build.log,6.46 KB, text/plain)
2009-08-16 13:51 UTC, Andrey Voronov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Voronov 2009-08-16 13:48:44 UTC
gnome-extra/libgsf-1.14.15: merge crash if XML::Parse Perl module not installed

Reproducible: Always
Comment 1 Andrey Voronov 2009-08-16 13:51:05 UTC
Created attachment 201414 [details]
Build log
Comment 2 Andrey Voronov 2009-08-16 13:51:52 UTC
Portage 2.2_rc38 (default/linux/x86/10.0/desktop, gcc-4.4.1, glibc-2.10.1-r0, 2.6.30-gentoo-r5 i686)
=================================================================                                   
System uname: Linux-2.6.30-gentoo-r5-i686-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 16 Aug 2009 11:00:02 +0000                                                     
app-shells/bash:     4.0_p28                                                                           
dev-java/java-config: 2.1.8-r1                                                                         
dev-lang/python:     2.6.2-r1, 3.1                                                                     
dev-util/cmake:      2.6.4-r2                                                                          
sys-apps/baselayout: 2.0.1                                                                             
sys-apps/openrc:     0.4.3-r3                                                                          
sys-apps/sandbox:    2.0                                                                               
sys-devel/autoconf:  2.13, 2.63-r1                                                                     
sys-devel/automake:  1.7.9-r1, 1.10.2, 1.11                                                            
sys-devel/binutils:  2.19.1-r1                                                                         
sys-devel/gcc-config: 1.4.1                                                                            
sys-devel/libtool:   2.2.6a                                                                            
virtual/os-headers:  2.6.30-r1                                                                         
ACCEPT_KEYWORDS="x86 ~x86"                                                                             
CBUILD="i686-pc-linux-gnu"                                                                             
CFLAGS="-mtune=core2 -march=core2 -mmmx  -msse  -msse2 -msse3 -mssse3 -mfpmath=sse -O2 -pipe"          
CHOST="i686-pc-linux-gnu"                                                                              
CONFIG_PROTECT="/etc /usr/share/config"                                                                
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-mtune=core2 -march=core2 -mmmx  -msse  -msse2 -msse3 -mssse3 -mfpmath=sse -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en ru"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/kde-testing /usr/local/portage/layman/devnull /usr/local/portage/layman/voff-overlay /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa bash-completion branding bzip2 cairo cdr cleartype cli cracklib custom-cflags custom-optimization dbus dri dts dv dvd dvdr emacs emacs23icons emboss encode evo ffmpeg firefox flac fortran gdbm gif git glibc-omitfp gpm gtk hal iconv ieee1394 isdnlog ithreads jpeg kde libnotify mad melt mikmod mmx mp3 mp4 mpeg mudflap ncurses nptl nptlonly objc objc++ objc-gc ogg opengl openmp pch pcre pdf perl png ppds pppd python qt3support qt4 quicktime readline reflection sdl session spell spl sse sse2 sse3 ssl ssse3 startup-notification svg sysfs tcpd threads truetype unicode usb vdpau vorbis win32codecs x264 x86 xcb xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Patrick Lauer gentoo-dev 2009-08-17 15:06:19 UTC
It's a strange bug in xml-parser module, every now and then it "stops working", a simple re-merge fixes the problem. I'm not aware of any reliable solution for this.
Comment 4 Jeroen Roovers gentoo-dev 2013-12-19 15:14:53 UTC

*** This bug has been marked as a duplicate of bug 41124 ***