Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 28115 - environment is filled up during init and this causes hotplug to print an error
Summary: environment is filled up during init and this causes hotplug to print an error
Status: RESOLVED DUPLICATE of bug 32069
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Martin Schlemmer (RETIRED)
: 28116 (view as bug list)
Depends on:
Reported: 2003-09-07 06:52 UTC by Adrian Gligor
Modified: 2005-07-17 13:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Gligor 2003-09-07 06:52:32 UTC
during init, the environment is filled up with a lot of funtions defined in the 
init scripts. every script adds its functions, and the environment gets bigger. 
this is related to bug 21438 (xargs error), but this time it affects hotplug. 
hotplug complains like this:
* Starting USB and PCI hotplugging...
modules.usbmap unparsabale line
modules.usbmap unparsabale line
[DUMP] <- here it dumps the whole environment, which is huge, and delays startup 
about two minutes. hotplug works, only the error message is disturbing

Reproducible: Always
Steps to Reproduce:
1. Install Gentoo 1.4
2. Set up hotplug/genkernel
3. Do install only GRP binaries, no source packages
4. boot and watch

Actual Results:  
the bug occured
hotplug actually works

Expected Results:  
* Starting USB and PCI hotplugging... [ok]
and no dump

*  sys-apps/baselayout
      Latest version available:
      Latest version installed:

*  sys-apps/hotplug
      Latest version available: 20030501-r2
      Latest version installed: 20030501-r2

Portage 2.0.49-r3 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r1, 2.4.20-gentoo-r5)
System uname: 2.4.20-gentoo-r5 i686 Pentium III (Coppermine)
distcc 2.9 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
CFLAGS="-O2 -march=pentium3 -funroll-loops -pipe"
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config 
/usr/kde/2/share/config /usr/kde/3/share/config /usr/X11R6/lib/X11/xkb 
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O2 -march=pentium3 -funroll-loops -pipe"
FEATURES="sandbox autoaddcvs ccache distcc"
GENTOO_MIRRORS=" http://distro.ibiblio.
USE="x86 oss apm avi crypt encode foomaticdb gif jpeg libg++ libwww mad mikmod 
mpeg ncurses nls pdflib png quicktime xml2 zlib gdbm berkdb slang readline svga 
java ruby sdl gpm tcpd pam perl python esd imlib oggvorbis qt motif opengl ldap 
cdr X gtk gtk2 alsa mmx sse cups dga gphoto2 scanner spell ssl truetype xmms xv 
-gnome -arts -kde"
Comment 1 Heinrich Wendel (RETIRED) gentoo-dev 2003-09-07 08:05:47 UTC
*** Bug 28116 has been marked as a duplicate of this bug. ***
Comment 2 Martin Schlemmer (RETIRED) gentoo-dev 2003-09-14 07:38:27 UTC
Hmm, what about ?
Comment 3 Adrian Gligor 2003-10-12 14:07:28 UTC
still the same... could the bug be in hotplug, instead of baselayout?
Comment 4 Jonathan Kraut 2003-10-26 15:25:07 UTC
I had this problem and tried something.
In my case, it seemed to be caused by an incorrectly formatted .usermap file,
in my case from media-sound/usbmidi-1/0
The file that was incorrect was /etc/hotplug/usb/ezusbmidi.usermap
The delimiter in the old file was single spaces.  By following the format
in /etc/hotplug/usb.distmap, and restarting hotplug, the "unparsable" error
message went away as did the copious output. 
I've submitted Bug 32069 to fix it in this case.
Comment 5 Adrian Gligor 2003-10-29 14:19:15 UTC
Thank you Jonathan, I'm sure you have the right idea, but I still cannot
find the file that causes the problem...

orion hotplug # pwd
orion hotplug # find ./ -iname '*.*map'

Every single one looks ok to me...
By the way, what do you mean by "the format
in /etc/hotplug/usb.distmap"? In my case, there are only spaces as delimiters
too. How is yours formatted?
Comment 6 Seemant Kulleen (RETIRED) gentoo-dev 2003-10-29 17:56:27 UTC

*** This bug has been marked as a duplicate of 32069 ***
Comment 7 Jonathan Kraut 2003-10-30 06:47:49 UTC
The delimiter in the old file was _a_ single space (sorry should have been
more clear.)  In the new file it looks tab delimited but the tabs are replaced
by several spaces (maybe it originally was tabs and got recoded somehow?).
See the attachment (ezusbmidi.usermap) on 32069 for an example.