Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 281085 - kde-base/kjots-4.3.5 fails with paralel make
Summary: kde-base/kjots-4.3.5 fails with paralel make
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 300393 313999
  Show dependency tree
 
Reported: 2009-08-11 09:54 UTC by Ewan A. A. Gunn
Modified: 2010-05-29 11:27 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments
Emerge --info (emergeinfo,3.58 KB, text/plain)
2009-08-11 09:54 UTC, Ewan A. A. Gunn
Details
Build log (buildlog,12.53 KB, text/plain)
2009-08-11 09:55 UTC, Ewan A. A. Gunn
Details
build log (kjots-4.3.5-build.log,12.88 KB, text/plain)
2010-01-27 14:12 UTC, Andreas K. Hüttel
Details
emerge --info output (kjots-4.3.5-emerge-info,4.39 KB, text/plain)
2010-01-27 14:12 UTC, Andreas K. Hüttel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ewan A. A. Gunn 2009-08-11 09:54:01 UTC
Emerging @kde to get kde4.3.  kjots fails emerge with attached log.  Changing from -j3 to -j1 allowed for a successful emerge.

Reproducible: Always

Steps to Reproduce:
1. Set -j3
2. Emerge kde-base/kjots

Actual Results:  
Emerge failed with the attached log.

Expected Results:  
Emerged successfully.
Comment 1 Ewan A. A. Gunn 2009-08-11 09:54:31 UTC
Created attachment 200914 [details]
Emerge --info
Comment 2 Ewan A. A. Gunn 2009-08-11 09:55:15 UTC
Created attachment 200916 [details]
Build log
Comment 3 mulander 2009-09-03 20:50:11 UTC
I have the same issue while upgrading from 4.3.0 to 4.3.1.
I also have -j3 in MAKEOPTS.
Comment 4 mulander 2009-09-03 20:57:44 UTC
I confirm that changing -j3 to -j1 emerges correctly.
Comment 5 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-09-04 12:59:07 UTC
(In reply to comment #4)
> I confirm that changing -j3 to -j1 emerges correctly.

That is a workaround for a parallel make issue.
Comment 6 Samuli Suominen gentoo-dev 2009-11-09 21:47:46 UTC
I can confirm kjots-4.3.3 emerged fine here with -j9.
Comment 7 N Addy 2009-11-29 14:58:19 UTC
-j3 (or -j9) does nothing for me.
Comment 8 Samuli Suominen gentoo-dev 2009-12-05 21:11:36 UTC
Try 4.3.4
Comment 9 Andreas K. Hüttel gentoo-dev 2010-01-27 14:10:02 UTC
The problem is still present in 4.3.5. See attached build log and emerge --info.
Comment 10 Andreas K. Hüttel gentoo-dev 2010-01-27 14:12:20 UTC
Created attachment 217602 [details]
build log
Comment 11 Andreas K. Hüttel gentoo-dev 2010-01-27 14:12:44 UTC
Created attachment 217604 [details]
emerge --info output
Comment 12 Andreas K. Hüttel gentoo-dev 2010-01-27 14:14:41 UTC
(In reply to comment #9)
> The problem is still present in 4.3.5. See attached build log and emerge
> --info.
> 

And it's not reproducible, so it seems to be a typical parallel make / timing issue.
Comment 13 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-04-02 10:40:41 UTC
Is this still reproducable with 4.4.2?
Comment 14 Andreas K. Hüttel gentoo-dev 2010-05-29 11:27:22 UTC
Unable to reproduce on 4.4.3 and no duplicates for a while. So resolving...