Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 281047 - dev-db/mysql-community fails to build with sys-devel/gcc-4.4
Summary: dev-db/mysql-community fails to build with sys-devel/gcc-4.4
Status: RESOLVED DUPLICATE of bug 271475
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-08-11 00:52 UTC by Adam Gregoire
Modified: 2009-08-15 15:37 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for mysql-extras patchset (mysql-extras-gcc44.patch,1.38 KB, patch)
2009-08-11 00:53 UTC, Adam Gregoire
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Gregoire 2009-08-11 00:52:06 UTC
dev-db/mysql-community fails to build with gcc 4.4 due to conversion from const char* to char* in the mysql-extras patchset.

Reproducible: Always

Steps to Reproduce:
1. Compile mysql-community with gcc4.4.
2. Build fails.


Actual Results:  
Did not compile.

Expected Results:  
Compiled correctly.

Portage 2.2_rc37 (default/linux/amd64/10.0, gcc-4.4.1, glibc-2.10.1-r0, 2.6.30-gentoo-r4 x86_64)
=================================================================                               
System uname: Linux-2.6.30-gentoo-r4-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 10 Aug 2009 08:30:02 +0000                                                      
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1, 3.1
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -mtune=native -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=native -mtune=native -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--ask"
FEATURES="assume-digests ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirrors.tera-byte.com/pub/gentoo http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://gentoo.osuosl.org/ ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="   "
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 avi bzip2 cairo cli cracklib crypt dbus djvu dri ffmpeg fortran glitz gpm hal iconv ipv6 isdnlog jpeg jpeg2k lcms lm_sensors mad mmx mng mpeg mudflap multilib ncurses nls nptl nptlonly ogg openal opengl openmp pam pcre pdf png pppd readline reflection sdl session smp spl sse sse2 sse3 ssl ssse3 svg sysfs tcpd theora tiff truetype unicode vdpau vim-syntax vorbis wmf xcomposite xorg xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


ha_innodb.cc: In function ‘bool innodb_I_S_buffer_pool_content(THD*, TABLE_LIST*)’:                                                                             
ha_innodb.cc:6748: error: invalid conversion from ‘const char*’ to ‘char*’      
make[4]: *** [ha_innodb.o] Error 1
Comment 1 Adam Gregoire 2009-08-11 00:53:54 UTC
Created attachment 200880 [details, diff]
patch for mysql-extras patchset
Comment 2 Mike Auty gentoo-dev 2009-08-15 15:37:15 UTC

*** This bug has been marked as a duplicate of bug 271475 ***