Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 280934 - dev-lang/tcl-8.5.7 - application-specific initialization failed: out of stack space (infinite loop?)
Summary: dev-lang/tcl-8.5.7 - application-specific initialization failed: out of stack...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: HPPA Linux
: High normal (vote)
Assignee: TCL/TK Project
URL:
Whiteboard:
Keywords:
: 306853 352187 (view as bug list)
Depends on: 406607 410511 410515 445206
Blocks: 280845
  Show dependency tree
 
Reported: 2009-08-10 00:20 UTC by Jeroen Roovers
Modified: 2013-02-10 09:37 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-lang:tcl-8.5.7:20090810-000018.log [hppa,fail] (20090810-000018.log.gz,7.16 KB, application/x-gzip)
2009-08-10 00:21 UTC, Jeroen Roovers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2009-08-10 00:20:40 UTC
Mon Aug 10 02:19:34 CEST 2009
Portage 2.1.6.13 (default/linux/hppa/2008.0, gcc-4.2.4, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r4-JeR parisc)
=================================================================
System uname: Linux-2.6.30-gentoo-r4-JeR-parisc-PA8700_-PCX-W2-with-gentoo-2.0.1
Timestamp of tree: Sun, 09 Aug 2009 15:45:01 +0000
distcc 3.1 hppa2.0-unknown-linux-gnu [disabled]
app-shells/bash:     3.2_p39
dev-lang/python:     2.6.2-r1
dev-util/cmake:      2.6.4-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3, 2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="hppa"
CBUILD="hppa2.0-unknown-linux-gnu"
CFLAGS="-O2 -pipe -mschedule=8000 -march=2.0 -g -ggdb -Wall"
CHOST="hppa2.0-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /var/bind /var/www/localhost/htdocs/wordpress/wp-config.php"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -mschedule=8000 -march=2.0 -g -ggdb -Wall"
DISTDIR="/keeps/gentoo/distfiles"
FEATURES="autoaddcvs buildpkg cvs distlocks fixpackages notitles parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict test test-fail-continue unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://mirror.netcologne.de/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://gentoo.tiscali.nl/ "
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en nl he"
MAKEOPTS="-j3"
PKGDIR="/keeps/gentoo/packages/elmer"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/dev/shm/"
PORTDIR="/keeps/gentoo/portage"
PORTDIR_OVERLAY="/keeps/gentoo/local"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip X Xaw3d a52 aac aalib abyss accessibility acl ads agg alsa amr amrnb amrwb ao aoss apache2 ares artist-screen asf async asyncns audiofile audit automount avfs bash-completion berkdb bidi bittorrent bittorrent-external bl bluetooth bzip2 c++ cairo caps captury catalogs cblas cdb cddb cdparanoia cdr chardet cjk clarens cli colors cracklib crypt cups curl custom-cflags custom-cxxflags cxx dbi dbtool dbus designer designer-plugin device-mapper dga dia dirac directfb djbfft djvu domainkeys dri drm dts dv dvd dvdr dvdread ebook edl elf emacs enca encode esd examples exif expat fame fastbuild fastcgi fbcon ffmpeg filter flac fluidsynth fontconfig fontforge foomaticdb fortran ftp gadu galago gcrypt gd gdbm geant4 geoip ggi gif gimp gimpprint glep glib glut gmp gnokii gnome gnutls google-gadgets gphoto2 gpm gps gs gsl gsm gtk gtk2 gtkhtml guidexml hal hepmc hesiod hppa i18n ical icecast iconv icu idea idn imagemagick imlib immqt-bc inquisitio ipv6 isc isdnlog ithreads jack javascript jbig jingle jpeg jpeg2k judy kde kerberos kpathsea lapack lasi latex lcms ldap leim libass libcaca libffi libmms libnotify libotf libsamplerate libwww live lm_sensors logrotate logwatch lua lyrics-screen lzo mad manhole matroska mbrola memcache metis mhash mikmod mmap mng modplug motif mozbranding mp3 mplayer mssql mudflap musepack musicbrainz mysql nas nautilus ncurses netpbm network-cron nfconntrack nfs nls nntp nptl nptlonly nsplugin ntlm offensive ogg openal openexr opengl openmp openssl oss ots overlays pam pango pbs pch pcre pdf pdo-external perl php plasma plotutils plugins png policykit portage portaudio postgres povray ppds pppd pulseaudio python pyzord qalculate qdbm qt3 qt3support qt4 quotas raw readline recode reflection rle rpc rrdtool rtc ruby samba sasl scanner schroedinger scim sdl seamonkey server session sid slang slp sms sndfile snmp song-screen soundex speex spell spl sqlite srt srtp ssh ssl startup-notification subtitles subversion suhosin supernodal svg swat sysfs syslog talkfilters tcl tcpd test tftp tga theora threads thumbnail thunar-vfs tidy tiff timidity tk tools truetype tslib tunepimp twolame udev unicode unzip urandom usb userlocales utempter utf v4l v4l2 vanim vcd vidix vim-syntax vorbis watchdog wavpack webdav webinstall webkit winbind wlan wma wmf xanim xattr xcb xchattext xcomposite xface xml xml2 xmp xmpi xorg xpm xrandr xscreensaver xsettings xulrunner xv xvid xvmc zip zip-external zlib" ALSA_CARDS="ad1889 usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_ftp proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev joystick keyboard mouse acecad aiptek calcomp citron digitaledge dmc dynapro elo2300 elographics fpit hyperpen jamstudio magellan microtouch mutouch palmax penmount spaceorb summa synaptics tek4957 tslib ur98 virtualbox wacom void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en nl he" USERLAND="GNU" VIDEO_CARDS="stifb fbdev matrox dummy"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers gentoo-dev 2009-08-10 00:21:21 UTC
Created attachment 200761 [details]
dev-lang:tcl-8.5.7:20090810-000018.log [hppa,fail]
Comment 2 Jeroen Roovers gentoo-dev 2009-08-10 00:28:50 UTC
Looks a lot like bug #279528, but perhaps with the stack limit being reached before a segfault occurs.

Standard stack limit on Gentoo/HPPA:

elmer ~ # ulimit -s
8192
Comment 3 Jeroen Roovers gentoo-dev 2009-08-10 00:43:20 UTC
Fails the same way with USE=-threads.

After a `ulimit -s unlimited' in the same shell and running emerge again, src_install() succeeds.
Comment 4 Federico Ferri (RETIRED) gentoo-dev 2009-08-10 00:56:23 UTC
may be related to: http://sourceforge.net/tracker/?func=detail&atid=110894&aid=1889719&group_id=10894
Comment 5 Federico Ferri (RETIRED) gentoo-dev 2009-08-10 01:06:03 UTC
so you should be able to compile it by adding -DTCL_NO_STACK_CHECK=1 to your CFLAGS. do you confirm?
Comment 6 Jeroen Roovers gentoo-dev 2009-08-10 01:48:56 UTC
(In reply to comment #5)
> so you should be able to compile it by adding -DTCL_NO_STACK_CHECK=1 to your
> CFLAGS. do you confirm?

Yes, that does seem to work around the problem. Any ideas how to put this in the ebuild? Just a `use hppa && append-cflags -DTCL_NO_STACK_CHECK=1' maybe?
Comment 7 Federico Ferri (RETIRED) gentoo-dev 2009-08-10 15:47:15 UTC
> Yes, that does seem to work around the problem. Any ideas how to put this in
> the ebuild? Just a `use hppa && append-cflags -DTCL_NO_STACK_CHECK=1' maybe?

yes I was thinking something like that. 

Comment 8 Federico Ferri (RETIRED) gentoo-dev 2009-08-10 15:54:20 UTC
updated tcl-8.5.7.ebuild in CVS ;-)
Comment 9 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-10-25 20:36:46 UTC
I got the exact same issue while trying to emerge dev-tcltk/expect on ppc.
Is it really hardware specific ?
Comment 10 Jeroen Roovers gentoo-dev 2009-10-25 20:50:40 UTC
Why on Earth did you remove hppa from CC?
Comment 11 Chris J Arges 2010-02-10 16:20:18 UTC
(In reply to comment #9)
> I got the exact same issue while trying to emerge dev-tcltk/expect on ppc.
> Is it really hardware specific ?
> 

Same here, I would recommend "append-cflags "-DTCL_NO_STACK_CHECK=1"" for ppc as well.

Comment 12 Raúl Porcel (RETIRED) gentoo-dev 2010-03-06 17:12:23 UTC
*** Bug 306853 has been marked as a duplicate of this bug. ***
Comment 13 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2010-03-06 17:39:12 UTC
(In reply to comment #10)
> Why on Earth did you remove hppa from CC?
> 

Sorry, it was not intentional...
Comment 14 Jeroen Roovers gentoo-dev 2010-08-10 02:42:47 UTC
Anyone feel like committing this?

Index: tcl-8.5.7.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.7.ebuild,v
retrieving revision 1.13
diff -u -B -r1.13 tcl-8.5.7.ebuild
--- tcl-8.5.7.ebuild    15 Jun 2010 23:46:51 -0000      1.13
+++ tcl-8.5.7.ebuild    10 Aug 2010 02:42:11 -0000
@@ -45,7 +45,7 @@
 
 src_compile() {
        # workaround stack check issues, bug #280934
-       if use hppa; then
+       if use hppa || use ppc; then
                append-cflags "-DTCL_NO_STACK_CHECK=1"
        fi

Index: tcl-8.5.8-r1.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.8-r1.ebuild,v
retrieving revision 1.4
diff -u -B -r1.4 tcl-8.5.8-r1.ebuild
--- tcl-8.5.8-r1.ebuild 16 Jun 2010 07:40:18 -0000      1.4
+++ tcl-8.5.8-r1.ebuild 10 Aug 2010 02:42:11 -0000
@@ -42,7 +42,7 @@
 
 src_configure() {
        # workaround stack check issues, bug #280934
-       if use hppa; then
+       if use hppa || use ppc; then
                append-cflags "-DTCL_NO_STACK_CHECK=1"
        fi

Index: tcl-8.5.8.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.8.ebuild,v
retrieving revision 1.3
diff -u -B -r1.3 tcl-8.5.8.ebuild
--- tcl-8.5.8.ebuild    15 Jun 2010 23:46:51 -0000      1.3
+++ tcl-8.5.8.ebuild    10 Aug 2010 02:42:11 -0000
@@ -45,7 +45,7 @@
 
 src_compile() {
        # workaround stack check issues, bug #280934
-       if use hppa; then
+       if use hppa || use ppc; then
                append-cflags "-DTCL_NO_STACK_CHECK=1"
        fi

Comment 15 Justin Lecher gentoo-dev 2010-08-10 06:19:01 UTC
Go ahead.
Comment 16 Jeroen Roovers gentoo-dev 2010-08-10 14:43:14 UTC
(In reply to comment #15)
> Go ahead.

It won't do. After reviewing this bug and bug #306853, it appears this isn't affecting ppc (I can't reproduce it like volkmar can), but bug #306853 was filed for a ppc64 system, and someone with an x86 had it as well.

We'd have to go for a generic append-flags but I have no idea how that would affect our distribution/what upstreams thinks of this.
Comment 17 Jeroen Roovers gentoo-dev 2011-01-21 16:04:51 UTC
*** Bug 352187 has been marked as a duplicate of this bug. ***
Comment 18 Mark Loeser (RETIRED) gentoo-dev 2011-07-23 15:35:43 UTC
This was discussed here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=452679

Looks like there is an upstream solution already.
Comment 19 Mark Loeser (RETIRED) gentoo-dev 2011-12-22 22:57:47 UTC
Anyone care if I apply the patch from upstream?
Comment 20 Justin Lecher gentoo-dev 2011-12-23 06:49:38 UTC
(In reply to comment #19)
> Anyone care if I apply the patch from upstream?

Please go ahead.
Comment 21 Mark Loeser (RETIRED) gentoo-dev 2011-12-26 18:50:13 UTC
I should have checked this first... tcl-8.5.10 already has this patch applied.  Its been in the tree for awhile now, could we just go ahead with that version?
Comment 22 Justin Lecher gentoo-dev 2011-12-26 19:24:04 UTC
8.5.7 is quite all, so going for .10 makes sense.
Comment 23 Justin Lecher gentoo-dev 2011-12-26 20:34:35 UTC
(In reply to comment #22)
> 8.5.7 is quite all, so going for .10 makes sense.

* /all/old ;)
Comment 24 Brent Baude (RETIRED) gentoo-dev 2012-01-04 20:46:04 UTC
ppc done
Comment 25 Justin Lecher gentoo-dev 2012-04-02 06:05:54 UTC
We need to wait for that other bug to remove the broken versions.
Comment 26 Justin Lecher gentoo-dev 2013-02-10 09:37:25 UTC
+  10 Feb 2013; Justin Lecher <jlec@gentoo.org> -tcl-8.4.19.ebuild,
+  -tcl-8.5.11-r1.ebuild, -tcl-8.5.13.ebuild:
+  Drop old fixes #280934
+