Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 280883 - upgrade to kernel gentoo-sources-2.6.30-r4 makes system unbootable
Summary: upgrade to kernel gentoo-sources-2.6.30-r4 makes system unbootable
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-09 13:46 UTC by denis
Modified: 2011-09-02 15:57 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info for eltaith (emerge_info-nahoy_kbiki_at_hushmail_com-2009-08-15-2125.txt,24.07 KB, text/plain)
2009-08-16 02:33 UTC, Robert R. Russell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description denis 2009-08-09 13:46:29 UTC
When using LILO bootloader and upgrading from gentoo sources 2.6.25-r7 to 2.6.30-r4 the system will NOT find initrd/initramfs unless option "large-memory" is added to lilo.conf
Comment 1 denis 2009-08-09 13:50:49 UTC
Reproduceable always. 
Using old working intiramfs image that works fine with 2.6.25, try using it with 2.6.30. On boot you get message  Unable to find RAM disk image ... at 0.. 

Added "large-memory" to lilo.conf eliminates the problem & kernel boots fine.
Comment 2 Mike Pagano gentoo-dev 2009-08-09 22:53:50 UTC
Reopen with emerge --info and size for bzImage and initrd.

Then this will be reassigned to lilo maintainers, as it's not a kernel bug.
Comment 3 denis 2009-08-10 07:53:33 UTC
Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.10.1-r0, 2.6.30-gentoo-r4_siberia x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r4_siberia-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E7200_@_2.53GHz-with-glibc2.2.5
Timestamp of tree: Sun, 09 Aug 2009 10:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.8-r1
dev-lang/python:     2.4.4-r13, 2.5.4-r3
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2 -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=core2 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="C"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"


Sizes:
- new kernel: 2944160 vmlinuz_2.6.30-gentoo-r4_gcc-4.3.2_2-9-Aug-09
- old kernel: 3100376 vmlinuz_2.6.25-gentoo-r7_gcc-4.3.2_2-Dec-21-08
- initramfs : 4538378 initramfs.gz

How I discovered that this (large-memory) was the problem was:
 I was putting test programs into my initramfs, like hello world, and different busybox, and scripts etc ... And then the initramfs was enlarged to the size that lilo complained that it was unable to fit the kern image and initrd into the 15 -16M hole ..... So it will relocate it to high mem. You've seen that one?

And then after booting with this message my initramfs was suddenly discovered. So then I've found the "large-memory" option, and switching it on/off makes my initramfs to be found/not at boot.

Hope this helps.

Yea, my lilo.conf

compact
lba32
boot=/dev/sda
map=/boot/.map
prompt
timeout=150
delay=50
vga=normal
default=Siberia
# >= 2.6.30 will NOT boot without this !->
large-memory

image=/boot/vmlinuz_2.6.25-gentoo-r7_gcc-4.3.2_2-Dec-21-08
	label=Siberia_old
	initrd=/boot/initramfs.gz
	read-only
	append="udev"

image=/boot/vmlinuz_2.6.30-gentoo-r4_gcc-4.3.2_2-9-Aug-09
	label=Siberia
	initrd=/boot/initramfs.gz
	read-only
	append="udev"

Comment 4 Mike Pagano gentoo-dev 2009-08-11 00:04:05 UTC
Assigning to lilo maintainer, not a kernel bug.
Comment 5 Robert R. Russell 2009-08-16 02:18:40 UTC
(In reply to comment #4)
> Assigning to lilo maintainer, not a kernel bug.
> 

I was getting the same error message/kernel panic from gentoo-sources-2.6.30-r4 using grub-0.97-r9 until I downgraded to vanilla-sources-2.6.29.4 which would boot the same initramfs I tried with gentoo-sources-2.6.30-r4 but not complete the switch_root correctly. I resolved the problem by moving my system off of lvm and back to msdos style partitions with vanilla-sources-2.6.29.4 as the kernel.
Comment 6 Robert R. Russell 2009-08-16 02:33:23 UTC
Created attachment 201377 [details]
emerge --info for eltaith

Here is the emerge --info for my system. The initramfs was about 16MB uncompressed. Dynamically linked glibc based. I do have another system using vanilla-sources-2.6.28.9 or .10. I will build a gentoo-sources-2.6.30-r4 test kernel on it and check to see if it will boot correctly with the older initramfs and much smaller initramfs.
Comment 7 denis 2009-08-23 13:10:10 UTC
(In reply to comment #6)
> Created an attachment (id=201377) [edit]
> emerge --info for eltaith
> 
> Here is the emerge --info for my system. The initramfs was about 16MB
> uncompressed. Dynamically linked glibc based. I do have another system using
> vanilla-sources-2.6.28.9 or .10. I will build a gentoo-sources-2.6.30-r4 test
> kernel on it and check to see if it will boot correctly with the older
> initramfs and much smaller initramfs.
>

I thought I mention that my system also does not use p-tables and I've been using LVM2 from the start (so on emerging lilo you need to enable lvm support). I'm still using LVM, since I've managed to upgrade the kernel & boot fine.
 

Comment 8 Tony Vroon gentoo-dev 2011-09-02 15:57:38 UTC
Please note that I am no longer the LILO maintainer. I am assuming that this got fixed; my apologies for not responding.