Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 280347 - new ebuild included for makemkv
Summary: new ebuild included for makemkv
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 1 vote (vote)
Assignee: Steve Dibb (RETIRED)
Whiteboard: EBUILD
Depends on:
Reported: 2009-08-04 17:24 UTC by A. Person
Modified: 2011-12-02 23:35 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---

makemkv ebuild (makemkv-1.4.6.ebuild,1.33 KB, text/plain)
2009-08-05 14:51 UTC, A. Person
makemkv patch (rand.patch,352 bytes, patch)
2009-08-05 14:51 UTC, A. Person
Details | Diff
fixed site url, qt4 deps, emake (makemkv-1.4.6.ebuild,1.18 KB, text/plain)
2009-08-30 14:33 UTC, Nikoli
new version (makemkv-1.4.7.ebuild,1.10 KB, text/plain)
2009-09-28 19:32 UTC, Nikoli
updated ebuild (makemkv-1.4.8.ebuild,1.25 KB, text/plain)
2009-10-27 15:48 UTC, A. Person
added desktop entry and icon, small fixes (makemkv-1.4.8.ebuild,1.23 KB, text/plain)
2009-11-19 13:23 UTC, Nikoli
new version, old ebuild (makemkv-1.4.9.ebuild,1.22 KB, text/plain)
2009-12-04 13:47 UTC, Nikoli
wrong file (1,1.31 KB, text/plain)
2010-01-20 23:38 UTC, Nikoli
new version, renamed ebuild (makemkv-1.4.11.ebuild,1.22 KB, text/plain)
2010-01-20 23:41 UTC, Nikoli
new version, renamed ebuild (makemkv-1.4.12.ebuild,1.22 KB, text/plain)
2010-02-03 14:29 UTC, Nikoli
new version, renamed ebuild (makemkv-1.5.0.ebuild,1.22 KB, text/plain)
2010-03-04 22:25 UTC, Nikoli
version bump (makemkv-1.6.2.ebuild,1.50 KB, text/plain)
2010-11-28 12:22 UTC, DarkNRG
New ebuild that patches makefile (makemkv-1.6.4.ebuild,1.57 KB, text/plain)
2011-02-09 21:01 UTC, Neil Bothwick
makefile patch (makefile-1.6.4.patch,463 bytes, patch)
2011-02-09 21:01 UTC, Neil Bothwick
Details | Diff
1.6.6 ebuild (makemkv-1.6.6.ebuild,1.53 KB, text/plain)
2011-04-03 13:44 UTC, Daniel Witzel
1.6.7 ebuild (makemkv-1.6.7.ebuild,1.55 KB, text/plain)
2011-04-17 11:36 UTC, Daniel Witzel
1.6.8 Ebuild (makemkv-1.6.8.ebuild,1.55 KB, text/plain)
2011-04-30 16:31 UTC, Daniel Witzel
version bump to 1.6.9 (makemkv-1.6.9.ebuild,1.55 KB, application/octet-stream)
2011-05-28 16:11 UTC, Daniel Witzel
Version bump to 1.6.10 (makemkv-1.6.10.ebuild,1.55 KB, application/octet-stream)
2011-06-10 14:18 UTC, Daniel Witzel
Version bump to 1.6.12 (makemkv-1.6.12.ebuild,1.55 KB, text/plain)
2011-07-11 19:25 UTC, Daniel Witzel

Note You need to log in before you can comment on or make changes to this bug.
Description A. Person 2009-08-04 17:24:54 UTC
makemkv is the best ripper I've found for DVDs and the only ripper I've found for Blu-Rays except for dumphd.  It is very reliable.

Here is an ebuild and patch:

# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit multilib eutils



KEYWORDS="~amd64 ~x86"


src_unpack() {
#       check_license
        unpack ${A}
        epatch "${FILESDIR}/rand.patch"

src_compile() {
        cd "${MY_P}"
        emake -f makefile.linux || die "make failed"

src_install() {
        # install oss package
        cd "${MY_P}" out/ out/
        dosym /usr/$(get_libdir)/${PV}
        dosym /usr/$(get_libdir)/${PV}
        into /usr
        dobin out/makemkv

        # install bin package
        cd ../"${MY_PB}"
        into /usr
        if use x86; then
                dobin bin/i386/makemkvcon
        elif use amd64; then
                dobin bin/amd64/makemkvcon

--- makemkv_v1.4.6_beta_oss/libmakemkv/src/world.cpp    2009-08-03 01:39:28.000000000 -0700
+++ makemkv_v1.4.6_beta_oss/libmakemkv/src/world.cpp    2009-08-04 09:41:27.000000000 -0700
@@ -22,6 +22,7 @@
 #include <libmkv/libmkv.h>
 #include <lgpl/osslabi.h>
 #include <lgpl/zlibabi.h>
+#include <cstdlib>

 #include <stdio.h>

Reproducible: Always
Comment 1 James Earl Spahlinger 2009-08-04 23:44:59 UTC
Please attach both the ebuild and the patch to this bug seperately.
Comment 2 A. Person 2009-08-05 14:51:14 UTC
Created attachment 200259 [details]
makemkv ebuild
Comment 3 A. Person 2009-08-05 14:51:53 UTC
Created attachment 200260 [details, diff]
makemkv patch
Comment 4 James Earl Spahlinger 2009-08-06 00:21:00 UTC
Thank you for this ebuild, you may also want to investigate putting your ebuild in the sunrise overlay which is located at When/if the ebuild is put into sunrise, please let us know on this bug.

Comment 5 Nikoli 2009-08-30 14:33:38 UTC
Created attachment 202708 [details]
fixed site url, qt4 deps, emake
Comment 6 Nikoli 2009-09-28 19:32:49 UTC
Created attachment 205530 [details]
new version
Comment 7 Nikoli 2009-10-15 02:26:54 UTC
1.4.8 is out, ebuild for 1.4.7 works fine.
Comment 8 A. Person 2009-10-24 16:10:11 UTC
There is actually an icon included with the program:

Comment 9 A. Person 2009-10-24 20:53:10 UTC
It would also be great to have this ebuild depend on individual qt ebuilds instead of the meta ebuild.
Comment 10 A. Person 2009-10-26 15:32:27 UTC
I've got the icon installing in a new ebuild, and I'm working on the correct qt deps.  I'll post it when it's done.
Comment 11 A. Person 2009-10-27 15:46:59 UTC
Here is a new ebuild.  It renames to 1.4.8, installs the icon, and fixes the qt dep.  makemkv only depends on qt-gui.
Comment 12 A. Person 2009-10-27 15:48:04 UTC
Created attachment 208438 [details]
updated ebuild
Comment 13 Nikoli 2009-11-19 13:23:34 UTC
Created attachment 210612 [details]
added desktop entry and icon, small fixes
Comment 14 Nikoli 2009-11-19 13:32:52 UTC
>It would also be great to have this ebuild depend on individual qt ebuilds
instead of the meta ebuild.

Grant, read other comments and attachments sometime, qt4 depend was fixed two months before your message.
Also your build still uses wrong url to homepage, does not support gcc chost, cflags and ldflags, uses unnecessary src_unpack, has spaces instead of tabulation.
Please obsolete it.
Comment 15 A. Person 2009-11-19 14:28:57 UTC
Comment 16 A. Person 2009-12-04 13:27:32 UTC
1.4.9 released.  Renaming works.
Comment 17 Nikoli 2009-12-04 13:47:54 UTC
Created attachment 212010 [details]
new version, old ebuild

renamed :)
Comment 18 Nikoli 2010-01-20 23:38:19 UTC
Created attachment 217022 [details]
wrong file
Comment 19 Nikoli 2010-01-20 23:41:35 UTC
Created attachment 217024 [details]
new version, renamed ebuild
Comment 20 Nikoli 2010-02-03 14:29:37 UTC
Created attachment 218289 [details]
new version, renamed ebuild
Comment 21 Nikoli 2010-03-04 22:25:44 UTC
Created attachment 222119 [details]
new version, renamed ebuild
Comment 22 Steve Dibb (RETIRED) gentoo-dev 2010-03-08 14:29:15 UTC
Since these guys have switched to a shareware model, I've personally lost interest in looking at it, and doubt it'll make it into the tree.
Comment 23 Steve Dibb (RETIRED) gentoo-dev 2010-03-09 02:14:23 UTC
(In reply to comment #22)
> Since these guys have switched to a shareware model, I've personally lost
> interest in looking at it, and doubt it'll make it into the tree.

Apologies if that sounded overly gloom and doom. :)  Feel free to CC me if things change, though.
Comment 24 A. Person 2010-03-09 17:00:44 UTC
Are you sure the Linux version is shareware?

Could you clarify a bit.  It won't make it into the tree because it's shareware, or because you've lost interest?
Comment 25 Steve Dibb (RETIRED) gentoo-dev 2010-06-07 21:03:33 UTC
(In reply to comment #24)
> Are you sure the Linux version is shareware?

> Could you clarify a bit.  It won't make it into the tree because it's
> shareware, or because you've lost interest?

A bit of both.  I'm not necessarily opposed to it going into the tree, just me personally taking care of it.

The build system could be cleaned up quite a bit as well.

Comment 26 Steve Dibb (RETIRED) gentoo-dev 2010-06-09 15:58:48 UTC
Alright guys,

I know it's not ideal, but I've uploaded an ebuild for 1.5.6 to the official multimedia overlay:

Have fun, and thanks for the work.
Comment 27 A. Person 2010-06-09 21:22:27 UTC
Thanks Steve.
Comment 28 Steve Dibb (RETIRED) gentoo-dev 2010-06-09 21:36:06 UTC
(In reply to comment #27)
> Thanks Steve.

No problem.

If you guys have any ebuild issues, just post em here
Comment 29 DarkNRG 2010-11-28 12:22:41 UTC
Created attachment 255731 [details]
version bump
Comment 30 Stéphane 2010-12-12 17:34:52 UTC
The ebuild isn't downloading the current version of makemkv and doesn't find the 1.5.8 (current is 1.6.2).

During the compile time, there's a probleme of place of compile (compilator wants to be in a repository he can't cd...)

I have ended the compile on myself without problem.
Comment 31 John Stile 2010-12-23 17:50:00 UTC
Version is now at 1.6.3.
Comment 32 Richard H. 2011-01-04 21:09:52 UTC
1.6.3 works for me by simply renaming the 1.6.2 ebuild
Comment 33 Neil Bothwick 2011-02-09 11:08:06 UTC
1.6.4 is out now. Renaming the ebuild gives the following error. Downloading and compiling following the instruction on does the same. I haven't tested with any other version as they appear to be no longer available.

mkdir -p out
x86_64-pc-linux-gnu-gcc -march=core2 -O2 -pipe -Wl,-O1 -Wl,--as-needed -D_linux_ -oout/makemkv.full -Imakemkvgui/inc -Ilibmakemkv/inc -Isstring/inc -Ilibdriveio/inc \
makemkvgui/src/aboutbox.cpp makemkvgui/src/client.cpp makemkvgui/src/dirselectbox.cpp makemkvgui/src/logic.cpp makemkvgui/src/logtext.cpp makemkvgui/src/main.cpp makemkvgui/src/nativefiledialog.cpp makemkvgui/src/mainwnd.cpp makemkvgui/src/marshall.cpp makemkvgui/src/progress.cpp makemkvgui/src/scsiinfo.cpp makemkvgui/src/settingdlg.cpp makemkvgui/src/uisync.cpp makemkvgui/src/viteminfo.cpp makemkvgui/src/backupdlg.cpp makemkvgui/src/lstring.cpp makemkvgui/src/notify.cpp makemkvgui/src/str/en_utf16.cpp makemkvgui/src/api_posix.cpp makemkvgui/src/api_linux.cpp makemkvgui/src/logic_posix.cpp makemkvgui/src/notify_linux.cpp tmp/qt_rsrc.cpp tmp/moc_mainwnd.cpp tmp/moc_logtext.cpp tmp/moc_dirselectbox.cpp tmp/moc_aboutbox.cpp tmp/moc_settingdlg.cpp tmp/moc_backupdlg.cpp sstring/src/sstring.cpp libdriveio/src/srlist.cpp \
-I/usr/include/qt4 -I/usr/lib/qt4/include -L/usr/lib/qt4 -L/usr/lib/qt4/lib -lc -lstdc++ -lQtGui -lQtCore \
-lpthread -lz -lrt
objcopy --strip-all --strip-debug --strip-unneeded --discard-all out/ out/ 
objcopy --strip-all --strip-debug --strip-unneeded --discard-all out/ out/ 
/var/tmp/portage/media-video/makemkv-1.6.4/temp/ccezipcC.o: In function `notifyInit()':
notify_linux.cpp:(.text+0x7d): undefined reference to `QDBusMessage::QDBusMessage()'
notify_linux.cpp:(.text+0x102): undefined reference to `QDBusConnection::sessionBus()'
notify_linux.cpp:(.text+0x13e): undefined reference to `QDBusInterface::QDBusInterface(QString const&, QString const&, QString const&, QDBusConnection const&, QObject*)'
notify_linux.cpp:(.text+0x14d): undefined reference to `QDBusConnection::~QDBusConnection()'
notify_linux.cpp:(.text+0x19b): undefined reference to `QDBusAbstractInterface::isValid() const'
notify_linux.cpp:(.text+0x3c1): undefined reference to `QDBusAbstractInterface::call(QDBus::CallMode, QString const&, QVariant const&, QVariant const&, QVariant const&, QVariant const&, QVariant const&, QVariant const&, QVariant const&, QVariant const&)'
notify_linux.cpp:(.text+0x3cc): undefined reference to `QDBusMessage::operator=(QDBusMessage const&)'
notify_linux.cpp:(.text+0x3d4): undefined reference to `QDBusMessage::~QDBusMessage()'
notify_linux.cpp:(.text+0x43a): undefined reference to `QDBusMessage::type() const'
notify_linux.cpp:(.text+0x450): undefined reference to `QDBusMessage::~QDBusMessage()'
notify_linux.cpp:(.text+0x4df): undefined reference to `QDBusMessage::arguments() const'
notify_linux.cpp:(.text+0x552): undefined reference to `QDBusMessage::~QDBusMessage()'
notify_linux.cpp:(.text+0x580): undefined reference to `QDBusMessage::~QDBusMessage()'
notify_linux.cpp:(.text+0x5d7): undefined reference to `QDBusConnection::~QDBusConnection()'
/var/tmp/portage/media-video/makemkv-1.6.4/temp/ccezipcC.o: In function `notifyEvent(QMainWindow*, unsigned long, char const*, QString const&)':
notify_linux.cpp:(.text+0x7b6): undefined reference to `QDBusAbstractInterface::call(QDBus::CallMode, QString const&, QVariant const&, QVariant const&, QVariant const&, QVariant const&, QVariant const&, QVariant const&, QVariant const&, QVariant const&)'
notify_linux.cpp:(.text+0x7c3): undefined reference to `QDBusMessage::~QDBusMessage()'
collect2: ld returned 1 exit status
distcc[7380] ERROR: compile makemkvgui/src/aboutbox.cpp on localhost failed
make: *** [out/makemkv.full] Error 1
emake failed
 * ERROR: media-video/makemkv-1.6.4 failed (compile phase):
 *   make failed
 * Call stack:
 *, line  56:  Called src_compile
 *   environment, line 2407:  Called die
 * The specific snippet of code:
 *       emake GCC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}" -f makefile.linux || die "make failed"
 * If you need support, post the output of 'emerge --info =media-video/makemkv-1.6.4',
 * the complete build log and the output of 'emerge -pqv =media-video/makemkv-1.6.4'.
 * This ebuild is from an overlay named 'digimed': '/mnt/portage/local/'
 * The complete build log is located at '/var/log/portage/media-video:makemkv-1.6.4:20110209-110449.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/makemkv-1.6.4/temp/environment'.
 * S: '/var/tmp/portage/media-video/makemkv-1.6.4/work/makemkv-1.6.4'

% emerge --info
Portage 2.2.0_alpha23 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.2, glibc-2.13-r0, 2.6.37-gentoo-1 x86_64)
System uname: Linux-2.6.37-gentoo-1-x86_64-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Wed, 09 Feb 2011 07:15:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1, 3.1.3
dev-util/cmake:      2.8.3-r1
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers: (sys-kernel/linux-headers)
Repositories: gentoo multimedia Mythtv-Ebuilds kde kde-sunset sunrise digimed
Installed sets: @kde4, @kvm, @lxf, @missingdeps, @system, @temp, @zenus-deps
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=core2 -O2 -pipe"
CONFIG_PROTECT="/etc /etc/env.d /usr/share/config /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/init.d /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe"
EMERGE_DEFAULT_OPTS="--alphabetical --jobs --load-average 5"
FEATURES="assume-digests binpkg-logs buildpkg distcc distlocks fixlafiles fixpackages metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3 -l5"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/mnt/portage/layman/multimedia /mnt/portage/mythtv/Gentoo /mnt/portage/layman/kde /mnt/portage/layman/kde-sunset /mnt/portage/layman/sunrise /mnt/portage/local"
USE="X a52 aac aalib acl acpi alsa amd64 apache2 audiofile berkdb bluetooth branding bzip2 cairo cddb cdr cli consolekit cracklib crypt css cups curl cxx dbus directfb dts dv dvb dvd dvdr ebook encode exif fam ffmpeg flac foomaticdb gdbm gdu gif gimp gnutls gpg gphoto2 gpm gtk hal iconv id3 ieee1394 imagemagick imap jabber java jbig jpeg jpeg2k kde kipi libnotify libwww lm_sensors lzma mad mailwrapper matroska mmx mmxext mng modules mp3 mp4 mpeg mplayer mudflap multilib musicbrainz mysql ncurses nptl nptlonly nsplugin ntfs nvidia offensive ogg ogm opengl openmp oss pango pcre pda pdf png policykit ppds pppd python qt3support qt4 quicktime rdesktop readline reiserfs samba scanner sdl semantic-desktop session slp snmp spell sse sse2 ssl ssse3 startup-notification svg sysfs tcpd theora threads tiff truetype udev unicode usb v4l v4l2 vnc vorbis wav webkit x264 xcb xcomposite xfs xinerama xml xmp xorg xscreensaver xulrunner xv xvid xvmc zlib zsh-completion zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon nikon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FOO2ZJS_DEVICES="hp1020 hp1022" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse aiptek" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" LIRC_DEVICES="devinput mceusb" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" SANE_BACKENDS="genesys" USERLAND="GNU" VIDEO_CARDS="vesa nv nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 

Comment 34 A. Person 2011-02-09 18:10:10 UTC
Have you tried this:

We just need a simple patch.
Comment 35 Neil Bothwick 2011-02-09 21:01:13 UTC
Created attachment 261963 [details]
New ebuild that patches makefile
Comment 36 Neil Bothwick 2011-02-09 21:01:37 UTC
Created attachment 261965 [details, diff]
makefile patch
Comment 37 A. Person 2011-02-18 20:22:08 UTC
makemkv-1.6.5 is out but it fails to compile if I rename, even after removing the patch.
Comment 38 Allan Snider 2011-02-19 22:46:04 UTC
(In reply to comment #37)
> makemkv-1.6.5 is out but it fails to compile if I rename, even after removing
> the patch.

Seems like the makefile.linux doesn't like the GCC variable being overridden by the make invocation of the ebuild, as it looses some defines.  I didn't delve into this, but just worked around it but providing the missing defines in the src_compile() section of the ebuild:

src_compile() {
   cd "${MY_P}"                                         
   emake GCC="$(tc-getCC) ${CFLAGS} ${LDFLAGS} -Os -D_GNU_SOURCE -D_linux_" -f makefile.linux || die "make failed"

This isn't a fix.  I believe the makemkv makefile needs some attention.
Comment 39 Daniel Witzel 2011-04-03 13:43:28 UTC
makemkv 1.6.6 compiles without any patching. tested on ~amd64 platform see attachment.
Comment 40 Daniel Witzel 2011-04-03 13:44:44 UTC
Created attachment 268333 [details]
1.6.6 ebuild

1.6.4 bug was fixed upstream it looks like as all i did was remove the epatch function and it compiled on ~amd64
Comment 41 Daniel Witzel 2011-04-17 11:36:15 UTC
Created attachment 270257 [details]
1.6.7 ebuild

New version comes new ebuild. added checks for qt-dbus as it is needed for compiling.
Comment 42 Daniel Witzel 2011-04-30 16:31:54 UTC
Created attachment 271639 [details]
1.6.8 Ebuild

Same as 1.6.7 just renamed
Comment 43 Daniel Witzel 2011-05-28 16:11:51 UTC
Created attachment 274899 [details]
version bump to 1.6.9
Comment 44 Steve Dibb (RETIRED) gentoo-dev 2011-06-09 19:06:30 UTC
(In reply to comment #43)
> Created attachment 274899 [details]
> version bump to 1.6.9

Bumped in multimedia overlay, thanks guys
Comment 45 A. Person 2011-06-09 21:50:02 UTC
1.6.10 is available for download.  Renaming works for me.
Comment 46 Daniel Witzel 2011-06-10 14:18:03 UTC
Created attachment 276511 [details]
Version bump to 1.6.10

renamed ebuild for the lazy, and of course tested it ;)
Comment 47 Daniel Witzel 2011-07-11 19:25:34 UTC
Created attachment 279803 [details]
Version bump to 1.6.12

Update to version 1.6.12, verified to work
Comment 48 A. Person 2011-07-12 21:17:45 UTC
Steve, could you bump it in the multimedia overlay?
Comment 49 Steve Dibb (RETIRED) gentoo-dev 2011-07-12 23:52:51 UTC
(In reply to comment #48)
> Steve, could you bump it in the multimedia overlay?

Alright, bumped
Comment 50 A. Person 2011-07-13 16:21:45 UTC
Thank you Steve!
Comment 51 A. Person 2011-08-07 16:22:11 UTC
makemkv-1.6.13 is out.
Comment 52 Steve Dibb (RETIRED) gentoo-dev 2011-09-02 17:23:41 UTC
1.6.14 is in the overlay.
Comment 53 Marcus Becker 2011-09-02 19:02:49 UTC
(In reply to comment #52)
> 1.6.14 is in the overlay.

!!! Digest verification failed:
!!! /var/lib/layman/multimedia/media-video/makemkv/ChangeLog
!!! Reason: Filesize does not match recorded size
!!! Got: 782
!!! Expected: 652
Comment 54 A. Person 2011-09-24 19:58:40 UTC
1.6.15 is out.
Comment 55 A. Person 2011-10-28 08:27:50 UTC
Hi guys, 1.6.16 is out with many improvements.
Comment 56 Steve Dibb (RETIRED) gentoo-dev 2011-12-02 23:35:14 UTC
Alright, removed the ebuild from the multimedia tree, and put it in the portage tree.  Closing this bug since it's in CVS.  Open a new bug with any other issues, as normal, from now on. :)

Thanks for everyone's help with the ebuilds!