Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 280137 - net-misc/miniupnpd-1.3-r1 Runs out of available handles, logs error message to this effect until disk is full.
Summary: net-misc/miniupnpd-1.3-r1 Runs out of available handles, logs error message t...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: x86 Linux
: High major with 1 vote (vote)
Assignee: Bjarke Istrup Pedersen (RETIRED)
Depends on:
Reported: 2009-08-03 05:46 UTC by Colton Reeder
Modified: 2009-09-21 17:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Output of lsof after a few hours of operation. (lsof,5.12 KB, text/plain)
2009-08-03 05:48 UTC, Colton Reeder
patch for iptcrdr (miniupnpd-1.3-iptcrdr_fix.diff,1.73 KB, patch)
2009-09-21 10:29 UTC, Colton Reeder
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Colton Reeder 2009-08-03 05:46:05 UTC
After about 24 hours or so of operation, miniupnpd starts writing "miniupnpd[(pid)]: accept(http): Too many open files" until disk is filled. Looking at lsof shows it opening *LOTS* of RAW sockets. Close monitoring shows its opening two of these for every port request. Upstream has not heard it from anyone else, the only people reporting this bug are Gentoo users.

Reproducible: Always

Steps to Reproduce:
1.Start miniupnpd
2.Use it.

Actual Results:  
miniupnpd runs out of sockets and fills log files.

Expected Results:  
Not run out of sockets and continue operation.
Comment 1 Colton Reeder 2009-08-03 05:48:15 UTC
Created attachment 199980 [details]
Output of lsof after a few hours of operation.
Comment 2 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2009-08-04 13:26:01 UTC
I can reproduce it, but since the problem seems to only happen on Gentoo, and I can't see what we are doing differently from everyone else, I really don't have an idea of what is wrong.

It would be a combination for several packages that triggers this, or something different.

Any input would be greatly appreciated.
Comment 3 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2009-08-04 13:27:35 UTC
Until the problem is tracked down, it can be worked around be adding a cron job that restarts miniupnpd every 6 hours (before it should be able to eat all the avaliable handles)
Comment 4 Colton Reeder 2009-09-13 07:08:11 UTC
I believe we are a few versions out of date in portage. Could we get it updated and see what happens. Ive tried installing it manually, but Im having problems with some includes in one of the files.
Comment 5 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2009-09-13 09:48:07 UTC
The last two changes from 2009/08/20 and 2009/09/04 is missing, but I'll created an updated version of the ebuild, with those two patches included too.

If all goes well, expect a 1.3-r2 release within a few hours :-)
Comment 6 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2009-09-13 14:28:46 UTC
Well, for now I'm having problems with some headers missing, so we will have to wait a little while before it hits the tree.
Comment 7 Colton Reeder 2009-09-21 10:29:00 UTC
Created attachment 204780 [details, diff]
patch for iptcrdr

I didnt make this patch, just am posting it for use. I modified my ebuild to make it work and so far I have no RAW sockets, at all, and Ive made sure it got used.
Comment 8 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2009-09-21 11:06:40 UTC
Yep, I saw it :-)

I'll take another shot at it later and see if I can get my kernel headers fixed, so it will compile.

If I can, it will be bumped to the newest version, and this patch will be included.
Comment 9 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2009-09-21 17:47:40 UTC
Fixed, 1.4_pre20090921 is in the tree.
It contains the fixes applied upstream.