Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 280097 - portage should provide the functionality of app-portage/autounmask
Summary: portage should provide the functionality of app-portage/autounmask
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 215096 319871 (view as bug list)
Depends on:
Blocks: 155723 autouse 281185 299631 330179 335925 345775
  Show dependency tree
 
Reported: 2009-08-02 20:14 UTC by Zac Medico
Modified: 2011-05-17 01:20 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zac Medico gentoo-dev 2009-08-02 20:14:53 UTC
The job of autounmask can be done more efficiently if portage implements it.
Comment 1 Zac Medico gentoo-dev 2010-05-15 20:31:01 UTC
*** Bug 319871 has been marked as a duplicate of this bug. ***
Comment 2 dE 2010-05-16 06:06:16 UTC
Note, you might like to have a look at Bug 319871 for more ideas.
Comment 3 Zac Medico gentoo-dev 2010-08-05 10:12:31 UTC
Now we have support for unmasking of packages with unstable keywords, in these commits and everything in between:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=320a9800e157756f79f1774654774cc460ada5b1
http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=03a201256ab9a8557862e30732ecc9b7de19a885

It's triggered by the --autounmask option. We may enable it by default eventually, but for now I want it disabled by default in order to minimize the impact of bugs.
Comment 4 dE 2010-08-12 07:55:54 UTC
I really don't think setting it to default is a good idea... At least I wont like it.
Comment 5 Sebastian Luther (few) 2010-08-12 08:20:58 UTC
(In reply to comment #4)
> I really don't think setting it to default is a good idea... At least I wont
> like it.
> 

Note that unlike app-portage/autounmask doesn't modify the configuration files, but outputs the changes in a way that it's easy to copy and paste them into the config files.

The --autounmask option is more like a better version of these "You need to change this USE flag for this package" messages, where you have to change stuff again and again.
Comment 6 dE 2010-08-12 08:44:14 UTC
In case a masked package pulls in for e.g... KDE 4.4.5 (assume it's masked), the user will not be notified much about the upgrade (or there wont be a big warning like there should be). This's what I'm afraid of, although I do have a habit of -pv before an emerge.
Comment 7 Zac Medico gentoo-dev 2010-08-12 08:56:04 UTC
With --autounmask, if anything needs to be unmasked then emerge displays the necessary configuration changes and then exits immediately, without doing anything. So, the worst case from having it enabled by default would be for it to consume more time or for it to expose a bug somewhere in the --autounmask code.
Comment 8 Sebastian Luther (few) 2010-08-12 09:07:19 UTC
(In reply to comment #6)
> In case a masked package pulls in for e.g... KDE 4.4.5 (assume it's masked),
> the user will not be notified much about the upgrade (or there wont be a big
> warning like there should be). This's what I'm afraid of, although I do have a
> habit of -pv before an emerge.
> 

First thing to note is that it wont unmask stuff that is masked by package.mask. The only thing it does in this regard is to allow stuff with "~arch" keywords on "arch" systems.

If one keyword change makes another keyword change necessary, then this second change will be displayed too. All changes have a comment added that tells the user the reason why this change was necessary. 
Comment 9 dE 2010-08-12 13:26:38 UTC
It appears we have a bit of confusion around. I thought --autounmask has the ability to modify portage.unmask.
Comment 10 Zac Medico gentoo-dev 2010-08-23 06:29:56 UTC
This is in 2.2_rc68, but I'll leave this bug open until it's in an unmasked version.
Comment 11 dE 2010-08-23 09:06:48 UTC
I think autounmask should add entries to package.keyword automatically. This was the thing I originally intended.
Comment 12 Walter 2010-08-24 08:22:05 UTC
I would also like to see an option for fully-automatedness... (unmask, unkeyword, +use flags on dependencies needing recompilation, etc.) 
Comment 13 Sebastian Luther (few) 2010-08-24 08:35:43 UTC
(In reply to comment #11)
> I think autounmask should add entries to package.keyword automatically. This
> was the thing I originally intended.
> 

You shouldn't blindly trust a tool to modify your config files. Just think of duplicated/overlapping entries, entries that contradict with existing entries, ...

(In reply to comment #12)
> I would also like to see an option for fully-automatedness... (unmask,
> unkeyword, +use flags on dependencies needing recompilation, etc.) 
> 

What else than automatically modifying config files are you missing?
Comment 14 Walter 2010-08-24 09:06:08 UTC
> (In reply to comment #13)

> > I would also like to see an option for fully-automatedness... (unmask,
> > unkeyword, +use flags on dependencies needing recompilation, etc.) 
> 
> What else than automatically modifying config files are you missing?

Please see related bugs for background.  I am interested in 'just do whatever necessary to get package X installed' functionality in a temporary, dedicated, virtualised environment.  Having to write code to awkwardly work around each of the various potential reasons for a blocked package installation is stupid and not something a human should have to worry about in this situation.

Whilst portage is great, it tends to be tailored towards human use, and the absence of automated issue-resolution functionality is a real limitation.
Comment 15 Zac Medico gentoo-dev 2010-09-04 07:38:07 UTC
This is fixed in portage-2.1.9.

Please file new bugs for any related feature requests or complaints.
Comment 16 dE 2010-09-04 12:56:06 UTC
Strange. I have 2.2_rc67 installed.
Comment 17 Zac Medico gentoo-dev 2010-09-04 16:49:08 UTC
(In reply to comment #16)
> Strange. I have 2.2_rc67 installed.

If you're using portage-2.2_rc* then you need at least 2.2_rc68 for --autounmask support.
Comment 18 dE 2010-09-05 03:32:29 UTC
Ok.
Comment 19 Zac Medico gentoo-dev 2010-12-02 01:36:02 UTC
*** Bug 215096 has been marked as a duplicate of this bug. ***
Comment 20 Oskar Stangenberg 2011-01-09 13:39:16 UTC
i think it would be a good idea to add the autounmask in its current state to the FEATURES. Then anyone can decide if this option should be on or off
Also you could add a second option to also change the files if someone really wants that
Comment 21 Zac Medico gentoo-dev 2011-01-09 14:20:37 UTC
You can set EMERGE_DEFAULT_OPTS="--autounmask" in /etc/make.conf if you want it enabled by default. It's not enabled by default now because it breaks app-portage/autounmask, it's not as well tested, and it doesn't support all same cases (package.mask is currently unsupported).
Comment 22 dE 2011-01-09 17:28:51 UTC
And also use.mask
Comment 24 Zac Medico gentoo-dev 2011-05-17 01:20:02 UTC
Now there's also a --autounmask-write option to enable writing to config files (see bug 345775). All of the features of app-portage/autounmask should be implemented now, so --autounmask will be enabled by default:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=bd486e676cf4fb1893f8d06220c1f60ed04760f2