Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 280023 - Re-keyword dev-python/matplotlib-0.98.5.3
Summary: Re-keyword dev-python/matplotlib-0.98.5.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords: KEYWORDREQ
: 279881 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-02 11:26 UTC by Sébastien Fabbro (RETIRED)
Modified: 2009-10-05 21:37 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sébastien Fabbro (RETIRED) gentoo-dev 2009-08-02 11:26:29 UTC
ppc, could you please rekeyword dev-python/matplotlib-0.98.5.3? You probably need to keyword a few other dependencies such as dev-python/configobj, dev-python/pycxx, dev-python/traits too.

Thanks.
Comment 1 Jeremy Stent 2009-08-06 17:52:29 UTC
I notice that trying to build this with the 'doc' USE flag tries to pull in graphviz with the 'png' USE flag.  However, graphviz no longer has a 'png' USE flag.
Could you please remove this USE dependency for graphviz?
Comment 2 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-08-06 18:03:59 UTC
(In reply to comment #1)

Older versions of media-gfx/graphviz still have "png" USE flag. Fixed.
Comment 3 Samuli Suominen gentoo-dev 2009-08-10 13:42:26 UTC
*** Bug 279881 has been marked as a duplicate of this bug. ***
Comment 4 Thomas Capricelli 2009-08-27 22:11:54 UTC
i'm hit by the same compilation error as Bug 279881  which is marked as duplicate for this one.
---------------
src/mplutils.cpp: In constructor ‘Printf::Printf(const char*, ...)’:
src/mplutils.cpp:17: error: ‘vsprintf’ was not declared in this scope
-----------

Using stable x86 here, and gcc 4.4.1..
Comment 5 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-10-05 21:37:45 UTC
ppc stable, fixing the bug.
Thomas, if you still got your issue, please open a new bug.