Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 279955 - [patch] media-plugins/audacious-plugins: add oss4 use flag
Summary: [patch] media-plugins/audacious-plugins: add oss4 use flag
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
: 334301 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-01 21:58 UTC by John Ratliff
Modified: 2010-08-24 15:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patched ebuild (audacious-plugins-2.1-r2.ebuild,3.40 KB, text/plain)
2009-08-01 21:59 UTC, John Ratliff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Ratliff 2009-08-01 21:58:43 UTC
Audacious plugins needs oss4 support to allow audacious to control the volume within the program if you are using oss4.

Reproducible: Always
Comment 1 John Ratliff 2009-08-01 21:59:57 UTC
Created attachment 199848 [details]
patched ebuild

ebuild demonstrating a possible oss4 use flag. tested on amd64
Comment 2 Wormo (RETIRED) gentoo-dev 2009-08-02 22:20:09 UTC
Thanks for submitting your ebuild enhancement! Assigning to maintainers.
Comment 3 Tony Vroon gentoo-dev 2009-08-02 22:34:55 UTC
Is OSSv4 in the portage tree?
Comment 4 John Ratliff 2009-08-03 11:24:15 UTC
It's not in the main portage tree, but you can find it in the oss-overlay.
Comment 5 Samuli Suominen (RETIRED) gentoo-dev 2009-08-03 11:33:45 UTC
(In reply to comment #4)
> It's not in the main portage tree, but you can find it in the oss-overlay.
> 

So.. copy audacious to oss-overlay and maintain the support there. Doesn't belong to main tree.
Comment 6 John Ratliff 2009-08-03 23:45:41 UTC
I have submitted this to the oss-overlay and it is now available there.
Comment 7 Tony Vroon gentoo-dev 2009-08-09 20:52:32 UTC
Thank you for your contribution to the OSS4 overlay. Unfortunately, I am unable to accept this patch for the main tree until OSSv4 is available there.
Comment 8 Samuli Suominen (RETIRED) gentoo-dev 2010-08-24 15:39:55 UTC
*** Bug 334301 has been marked as a duplicate of this bug. ***