Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 279862 - app-misc/mc version bump 4.7.0-pre1
Summary: app-misc/mc version bump 4.7.0-pre1
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Samuli Suominen
URL: http://www.midnight-commander.org/dow...
Whiteboard:
Keywords:
: 270963 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-01 06:22 UTC by Opportunist
Modified: 2009-08-05 11:29 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Opportunist 2009-08-01 06:22:34 UTC
Midnight Commander 4.7.0-pre1

We have finally released the first preliminary Midnight Commander release 4.7.0-pre1! 

This release incorporates many code refactoring changes, user interface improvements, numerous bugfixes and new features. 
Changelog

Major changes since 4.6.2: 
Changes in the core
Native UTF-8 support; 
Support for filename charset selection in panels; 
Reworked 'Find File' dialog; 
New unified search/replace engine with multiple search types: plain, wildcard, regexp and hex; 
Extended 'Learn Keys' capability; 
Locale-based codepage autodetection; 
Initial support for Doxygen generated docs; 
Build system updates (autoconf); 
Translation updates; 
Multiple x86_64 fixes. 
Editor
Various editor enhancements (mark/move/copy/paste vertical blocks); 
Multiple syntax file updates; 
Source code navigation through ctags/etags TAGS files; 
New option: 'Persistent selection'; 
Delete/Backspace deletes selected block if 'Persistent selection' is off; 
Ability to shift blocks to the right with Tab key and to the left with Complete key if 'Persistent selection' is off; 
Show line numbers (optional); 
Highlighting of tabs and trailing spaces (optional); 
Added some hotkeys. 
Miscellaneous
Show free space on current file system; 
Show size of selected files in mini-status bar. 
Bugfixes
Editor undo fixes; 
Upstreamed many fixes from the distributions; 
Fixed segfaults on fish permission checks; 
Fixed fish symlinks handling and fancy names escaping; 
Various mc.ext fixes; 
Command line completion fixes (mainly escaping); 
Small fixes in history handling (locale independent .mc/history entries); 
Code cleanups, various memleaks fixed (many thanks to valgrind). 

The new release can be downloaded at the following URL: http://www.midnight-commander.org/downloads . 

We would like to stress that this is a preliminary release, which means that it is not yet ready for production use. The goal of this release is to attract new testers so that we can further improve Midnight Commander. Any comments, bug reports and suggestions are gladly welcomed in form of tickets at our new home http://www.midnight-commander.org (please search before submitting new ticket!). 

It is recommended to build Midnight Commander with '--enable-charset' option to enable complete support for character set translations. Hopefully this will become a default in future.

Reproducible: Always
Comment 1 Wormo (RETIRED) gentoo-dev 2009-08-01 18:10:07 UTC
Thanks for the release announcement, assigning to mc maintainers.
Comment 2 Samuli Suominen gentoo-dev 2009-08-02 14:00:53 UTC
*** Bug 270963 has been marked as a duplicate of this bug. ***
Comment 3 Samuli Suominen gentoo-dev 2009-08-02 14:35:01 UTC
In portage.
Comment 4 Nikos Chantziaras 2009-08-02 15:43:30 UTC
I see that the "slang" USE flag is still enabled by default. Now that Unicode works with ncurses too, which of those two screen libs is better for mc? If it's ncurses, slang should perhaps get disabled by default now?
Comment 5 Samuli Suominen gentoo-dev 2009-08-02 15:48:31 UTC
(In reply to comment #4)
> I see that the "slang" USE flag is still enabled by default. Now that Unicode
> works with ncurses too, which of those two screen libs is better for mc? If
> it's ncurses, slang should perhaps get disabled by default now?
> 

./configure --help

<... snip ...>

  --with-screen=LIB        Compile with screen library: slang or
                           ncurses [slang if found]

<... snip ...>

Upstream default.