Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 279787 - media-video/SDLcam: fails to build with glibc-2.10
Summary: media-video/SDLcam: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-07-31 11:36 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-08 20:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (SDLcam-0.8.2:20090731-103033.log,57.12 KB, text/plain)
2009-07-31 11:36 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-31 11:36:37 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2] and [3].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
[3] http://blog.flameeyes.eu/2009/07/08/how-_not_-to-fix-glibc-2-10-function-collisions
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-31 11:36:54 UTC
Created attachment 199733 [details]
Build log
Comment 2 Víctor Ostorga (RETIRED) gentoo-dev 2009-08-08 20:46:31 UTC
Fixed in portage