Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 279555 - gnome-base/gnome-menus-2.26.2
Summary: gnome-base/gnome-menus-2.26.2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 282061 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-07-29 06:36 UTC by Davide
Modified: 2009-11-10 09:21 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Davide 2009-07-29 06:36:09 UTC
New version of the package broke links home,desktop,computer etc. from the menu. If I restart X applications menu disappera, after gentoo restart it reapper again :D

Reproducible: Always
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-07-29 07:48:47 UTC
If you read the ewarn, this is kind of expected. I've added a note to the migration guide that menus might disappear immediately during the upgrade process. Thanks for reporting.
Comment 2 Davide 2009-07-29 07:53:02 UTC
> echo $DESKTOP_SESSION
> gnome

I did it but menu links are always broken
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-07-29 08:07:35 UTC
Ok, what versions of gnome-session and gdm do you have ? You should have gnome-session-2.26.2 if you don't use gdm-2.26.

Could you also print what the output of
$ env | egrep XDG

once you are logged in ?
Comment 4 Davide 2009-07-29 08:44:21 UTC
(In reply to comment #3)
> Ok, what versions of gnome-session and gdm do you have ? You should have
> gnome-session-2.26.2 if you don't use gdm-2.26.
> 
> Could you also print what the output of
> $ env | egrep XDG
> 
> once you are logged in ?
> 

i'm using gnome-session-2.26.2 with gdm-2.20.10-r1

intel4 netcelli # env | egrep XDG
XDG_SESSION_COOKIE=ffc48ca200506213f1a59666494bb3d8-1248849883.183542-2059458952
XDG_CONFIG_DIRS=/etc/xdg
XDG_DATA_DIRS=/usr/local/share:/usr/share:/usr/share/gdm

Comment 5 Roy Bamford gentoo-dev 2009-07-29 20:09:35 UTC
The Applications menu in Gnome 2.26.2 appeares to have changed its path name from /etc/xdg/menus/gnome-applications.menu to /etc/xdg/menus/applications.menu

At least, a symlink made it all work againg for me.
Comment 6 Davide 2009-07-30 05:37:12 UTC
(In reply to comment #5)
> The Applications menu in Gnome 2.26.2 appeares to have changed its path name
> from /etc/xdg/menus/gnome-applications.menu to /etc/xdg/menus/applications.menu
> 
> At least, a symlink made it all work againg for me.
> 

/etc/xdg/menus/gnome-applications.menu doesn not exist and other file contains only some category name
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-07-30 07:15:18 UTC
Please rebuild gnome-menus-2.26.2, also it seems that even though you are using gnome-session, XDG_MENU_PREFIX isn't exported as it should. Could you list what's under /etc/X11/xinit/xinitrc.d/ (ls -l). There should be a 10-xdm-menu-gnome file in executable mode.
Comment 8 Davide 2009-07-30 07:19:02 UTC
(In reply to comment #7)
> Please rebuild gnome-menus-2.26.2, also it seems that even though you are using
> gnome-session, XDG_MENU_PREFIX isn't exported as it should. Could you list
> what's under /etc/X11/xinit/xinitrc.d/ (ls -l). There should be a
> 10-xdm-menu-gnome file in executable mode.
> 

> # echo $XDG_MENU_PREFIX
variable is not set

> ls -l /etc/X11/xinit/xinitrc.d/
-rwxr-xr-x 1 root root 115 30 lug 08:49 10-xdg-menu-gnome
-rwxr-xr-x 1 root root 243 23 lug 08:41 30-dbus
-rwxr-xr-x 1 root root 181 21 lug 11:53 49-keychain
-rwxr-xr-x 1 root root 246 21 lug 11:53 50-ssh-agent
-rwxr-xr-x 1 root root 241 21 lug 11:49 70-seahorse-agent
-rw-r--r-- 1 root root 272 27 mag 10:54 90-consolekit
Comment 9 Gilles Dartiguelongue gentoo-dev 2009-07-30 07:27:15 UTC
there is no reason the variable would be unset according to what you paste.

Please add -x at the end of the shebang of 10-xdg-menu-gnome then attach your .xsession-errors, it should show us what going wrong.
Comment 10 Davide 2009-07-30 08:30:46 UTC
(In reply to comment #9)
> there is no reason the variable would be unset according to what you paste.
> 
> Please add -x at the end of the shebang of 10-xdg-menu-gnome then attach your
> .xsession-errors, it should show us what going wrong.
> 

If i add -x option and restart X, i cant use gnome all is blocked; anyway this is the .xsession-errors:
/etc/X11/gdm/Xsession: Beginning session setup...
which: no keychain in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.3.2:/opt/blackdown-jdk-1.4.2.03/bin:/opt/blackdown-jdk-1.4.2.03/jre/bin:/usr/games/bin)
/etc/X11/gdm/Xsession: Setup done, will execute: /usr/bin/seahorse-agent --execute gnome-session
GNOME_KEYRING_SOCKET=/tmp/keyring-KVpz9Y/socket
SSH_AUTH_SOCK=/tmp/keyring-KVpz9Y/socket.ssh
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:84: Murrine configuration option "highlight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:85: Murrine configuration option "lightborder_ratio" will be deprecated in future releases. Please use "lightborder_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:84: Murrine configuration option "highlight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:85: Murrine configuration option "lightborder_ratio" will be deprecated in future releases. Please use "lightborder_shade" instead.

(gnome-settings-daemon:3445): GLib-GObject-CRITICAL **: g_param_spec_flags: assertion `G_TYPE_IS_FLAGS (flags_type)' failed

(gnome-settings-daemon:3445): GLib-GObject-CRITICAL **: g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:84: Murrine configuration option "highlight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:85: Murrine configuration option "lightborder_ratio" will be deprecated in future releases. Please use "lightborder_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:84: Murrine configuration option "highlight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:85: Murrine configuration option "lightborder_ratio" will be deprecated in future releases. Please use "lightborder_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:84: Murrine configuration option "highlight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:85: Murrine configuration option "lightborder_ratio" will be deprecated in future releases. Please use "lightborder_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:84: Murrine configuration option "highlight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:85: Murrine configuration option "lightborder_ratio" will be deprecated in future releases. Please use "lightborder_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:84: Murrine configuration option "highlight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:85: Murrine configuration option "lightborder_ratio" will be deprecated in future releases. Please use "lightborder_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:84: Murrine configuration option "highlight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:85: Murrine configuration option "lightborder_ratio" will be deprecated in future releases. Please use "lightborder_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:84: Murrine configuration option "highlight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:85: Murrine configuration option "lightborder_ratio" will be deprecated in future releases. Please use "lightborder_shade" instead.
** (empathy:3462): DEBUG: mission_control_get_presence_actual: MC not running.
** (empathy:3462): DEBUG: mission_control_get_presence_message_actual: MC not running.
evolution-alarm-notify-Message: Setting timeout for 49020 1248991200 1248942180
evolution-alarm-notify-Message:  Fri Jul 31 00:00:00 2009

evolution-alarm-notify-Message:  Thu Jul 30 10:23:00 2009

** (empathy:3462): DEBUG: _parse_parameter: param "fallback-socks5-proxies" has invalid signature
** (empathy:3462): DEBUG: mission_control_get_presence_actual: MC not running.
** (empathy:3462): DEBUG: mission_control_get_connection_status: MC not running.
** (empathy:3462): DEBUG: mission_control_get_connection_status: MC not running.
** (empathy:3462): DEBUG: mission_control_get_presence_actual: MC not running.
** (empathy:3462): DEBUG: mission_control_get_connection_status: MC not running.
** (empathy:3462): DEBUG: mission_control_get_connection_status: MC not running.
** (empathy:3462): DEBUG: mission_control_get_online_connections: MC not running.
** (empathy:3462): DEBUG: mission_control_get_tpconnection: MC not running.
** (empathy:3462): DEBUG: mission_control_get_tpconnection: MC not running.
Initializing nautilus-open-terminal extension

** (gnome-power-manager:3459): WARNING **: ERROR: No governor 'nothing' available

** (gnome-power-manager:3459): WARNING **: ERROR: No 'SetCPUFreqPerformance' setting for current governor

(gnome-panel:3452): Gdk-WARNING **: gdkdrawable-x11.c:952 drawable is not a pixmap or window
Impossibile aprire il file .desktop «epiphany.desktop» per il lanciatore da pannello
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:84: Murrine configuration option "highlight_ratio" will be deprecated in future releases. Please use "highlight_shade" instead.
/usr/share/themes/MurrinaCandido/gtk-2.0/gtkrc:85: Murrine configuration option "lightborder_ratio" will be deprecated in future releases. Please use "lightborder_shade" instead.
** Message: Initializing gksu extension...
1.1.9

** (nautilus:3454): WARNING **: Unable to add monitor: Not supported

** (nautilus:3454): WARNING **: Can not calculate _NET_NUMBER_OF_DESKTOPS

** (nautilus:3454): WARNING **: Can not calculate _NET_NUMBER_OF_DESKTOPS

** (nautilus:3454): WARNING **: Can not get _NET_WORKAREA

** (nautilus:3454): WARNING **: Can not determine workarea, guessing at layout
/usr/lib64/python2.6/site-packages/deluge/ui/tracker_icons.py:70: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  log.debug("%s %s %s" % (url, e, e.message))

** (gnome-settings-daemon:3445): WARNING **: No screensaver available
Comment 11 Davide 2009-07-30 16:52:48 UTC
i can't figure out why menu isnt k for me; even downgrading to previous version links of home,desktop are broken
Comment 12 Jory A. Pratt gentoo-dev 2009-07-31 03:23:39 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > The Applications menu in Gnome 2.26.2 appeares to have changed its path name
> > from /etc/xdg/menus/gnome-applications.menu to /etc/xdg/menus/applications.menu
> > 
> > At least, a symlink made it all work againg for me.
> > 
> 
> /etc/xdg/menus/gnome-applications.menu doesn not exist and other file contains
> only some category name
> 

are you using kdm by chance? My wife was using kdm and had no menus in gnome, as soon as she switched to gdm menus where once again populated.
Comment 13 Davide 2009-07-31 05:42:27 UTC
(In reply to comment #12)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > The Applications menu in Gnome 2.26.2 appeares to have changed its path name
> > > from /etc/xdg/menus/gnome-applications.menu to /etc/xdg/menus/applications.menu
> > > 
> > > At least, a symlink made it all work againg for me.
> > > 
> > 
> > /etc/xdg/menus/gnome-applications.menu doesn not exist and other file contains
> > only some category name
> > 
> 
> are you using kdm by chance? My wife was using kdm and had no menus in gnome,
> as soon as she switched to gdm menus where once again populated.
> 
Applications menu is fixed now (symlink gnome-applications.menu to application.menu) but links are broken
Comment 14 Gilles Dartiguelongue gentoo-dev 2009-07-31 23:31:16 UTC
what happens if you replace export XDG_MENU_PREFIX... by $command="$command XDG_MENU_PREFIX=gnome-". I haven't tryied it but the idea is that agents usualy print their env variables once started to stdout so it is in the context of all the following commands in the $command variable.
Comment 15 Davide 2009-08-01 05:54:32 UTC
(In reply to comment #14)
> what happens if you replace export XDG_MENU_PREFIX... by $command="$command
> XDG_MENU_PREFIX=gnome-". I haven't tryied it but the idea is that agents usualy
> print their env variables once started to stdout so it is in the context of all
> the following commands in the $command variable.
> 

> echo $XDG_MENU_PREFIX
gnome-

Comment 16 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-08-03 15:14:26 UTC
So, it appears to work fine if you export XSESSION=Gnome and have *no* .xinitrc.  

If you want a custom .xinitrc, then you need to actual export XDG_MENU_PREFIX=gnome- in it directly, as the system files in /etc/X11/xinit/xinitrc.d are *not* sourced.
Comment 17 Marti Raudsepp 2009-08-03 15:42:57 UTC
> If you want a custom .xinitrc, then you need to actual export
> XDG_MENU_PREFIX=gnome- in it directly, as the system files in
> /etc/X11/xinit/xinitrc.d are *not* sourced.

I think this is not a particularly elegant solution, but whatever. The documentation must also be updated: http://www.gentoo.org/doc/en/gnome-config.xml#doc_chap2_sect2
Comment 18 Gilles Dartiguelongue gentoo-dev 2009-08-03 22:04:08 UTC
ebuild and migration guide updated, writing up something for gnome-config doc but my desktop failed on me so it'll be not before wednesday.
Comment 19 Jory A. Pratt gentoo-dev 2009-08-04 01:22:09 UTC
(In reply to comment #16)
> So, it appears to work fine if you export XSESSION=Gnome and have *no*
> .xinitrc.  
> 
> If you want a custom .xinitrc, then you need to actual export
> XDG_MENU_PREFIX=gnome- in it directly, as the system files in
> /etc/X11/xinit/xinitrc.d are *not* sourced.
> 

This is not actually completely true. If they are using kde with no xinitrc they will still have this problem.
Comment 20 Gilles Dartiguelongue gentoo-dev 2009-08-04 06:46:54 UTC
(In reply to comment #19)
> (In reply to comment #16)
> > So, it appears to work fine if you export XSESSION=Gnome and have *no*
> > .xinitrc.  
> > 
> > If you want a custom .xinitrc, then you need to actual export
> > XDG_MENU_PREFIX=gnome- in it directly, as the system files in
> > /etc/X11/xinit/xinitrc.d are *not* sourced.
> 
> This is not actually completely true. If they are using kde with no xinitrc
> they will still have this problem.

It is assumed that if you want another desktop, you want the .menu for that desktop. If you have a fdo compliant menu editor, it should be able to add items from gnome just fine though.
Comment 21 Gilles Dartiguelongue gentoo-dev 2009-08-13 22:30:13 UTC
gnome-config bug filled as bug #281243. Closing per previous comments.
Comment 22 Gilles Dartiguelongue gentoo-dev 2009-08-20 06:10:32 UTC
*** Bug 282061 has been marked as a duplicate of this bug. ***
Comment 23 Davide 2009-09-06 07:37:11 UTC
Some1 fix the broken links?
Comment 24 Bodo Thiesen 2009-10-14 22:52:35 UTC
In conjunction with enlightenment, the bug remains even after logging out and in again. Reason: The environment variable DESKTOP_SESSION is "e16-gnome" not just "gnome".

With this /etc/X11/xinit/xinitrc.d/10-xdg-menu-gnome, it now works for me, too:

if [ -z "$XDG_MENU_PREFIX" ] && test -n "$(echo "$DESKTOP_SESSION" | grep "gnome")"
then
        export XDG_MENU_PREFIX=gnome-
fi
Comment 25 Matt Michalowski 2009-10-29 00:20:42 UTC
(In reply to comment #24)
> 
> if [ -z "$XDG_MENU_PREFIX" ] && test -n "$(echo "$DESKTOP_SESSION" | grep
> "gnome")"
> then
>         export XDG_MENU_PREFIX=gnome-
> fi
> 

Thanks for that, works with Openbox/GNOME integration too.
Comment 26 Gilles Dartiguelongue gentoo-dev 2009-11-09 22:52:06 UTC
*** Bug 292480 has been marked as a duplicate of this bug. ***
Comment 27 Gilles Dartiguelongue gentoo-dev 2009-11-10 09:21:37 UTC
*** Bug 292480 has been marked as a duplicate of this bug. ***