Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 27910 - R doesn't compile with tcl and tk support
Summary: R doesn't compile with tcl and tk support
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Science Related Packages
Depends on:
Reported: 2003-09-04 03:02 UTC by Fabien Fivaz
Modified: 2004-06-02 05:51 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Config log file (config.R.log,19.50 KB, text/x-log)
2003-09-15 02:32 UTC, Fabien Fivaz
Config log file (config.R.log,19.50 KB, text/plain)
2003-09-15 02:32 UTC, Fabien Fivaz

Note You need to log in before you can comment on or make changes to this bug.
Description Fabien Fivaz 2003-09-04 03:02:36 UTC
For creating GUI's, it's important to have tcl/tk support when using R. The problem 
with my actual version of ebuild is that the minor versions from tcl (8.3.4) and tk 
(8.3.4-r1) are different, thus the configure script from R doesn't compile tcl/tk support.
Comment 1 George Shapovalov (RETIRED) gentoo-dev 2003-09-12 19:07:31 UTC
Hi Fabien.

Where did you get tk-8.4.3-r1? I don't see it in the tree..
Besides installation of R uses system-wide tcl and tk which know nothing about the -r1 part, so this should not be causing anything.

And most importantly: what version of R are you trying to merge? There was tcl/tk related problem in all versions before 1.7.1, however this one is keymasked (for the lack of test reports atm). Could you please try emerging this one and reporting back? I will unmask it the moment you report success..

Comment 2 Fabien Fivaz 2003-09-15 02:28:08 UTC
Dear George, 
I unmerged R, tcl and Tk. Then I merged Tcl version 8.4.2-r1 and Tk 8.4.2-r1. Then I 
tried merging R 1.7.1. Everything works, exept for the tcltk library. I also tried the 
following combinations without success : 
- R 1.6.1 tcl 8.3.4 tk 8.3.4 
- R 1.7.0 tcl 8.4.2-r1 tk 8.4.2-r1 
- R 1.6.1 tcl 8.4.2-r1 tk 8.4.2-r1 
The default R version that emerge builts is 1.6.1 with tcl 8.3.4 and tk 8.3.4-r1. The 
message that tells that minor version differ between tcl and tk, only appears when 
configuring R version 1.6.1, even when I use tk 8.4.3 (not r1). It does not appear when 
configuring version 1.7.0 or 1.7.1. 
Comment 3 Fabien Fivaz 2003-09-15 02:32:29 UTC
Created attachment 17743 [details]
Config log file

Configuration log when emerging version 1.7.1 of R.
Comment 4 Fabien Fivaz 2003-09-15 02:32:41 UTC
Created attachment 17744 [details]
Config log file

Configuration log when emerging version 1.7.1 of R.
Comment 5 Fabien Fivaz 2003-09-23 07:29:14 UTC
Well, I tried installing R from the sources provided by CRAN (1.7.1). And it works, I just 
had to configure and make, without anything. I even didn't had to tell configure to use 
tcltk, it was automatical. So, it seems to be a problem with the R ebuilds and not with 
Tcl or Tk ebuilds. 
Comment 6 Patrick Kursawe (RETIRED) gentoo-dev 2004-03-05 02:22:25 UTC
Can you reproduce your problem with 1.8.0?
Comment 7 Patrick Kursawe (RETIRED) gentoo-dev 2004-03-15 04:23:21 UTC
Hello? Anybody there?
Comment 8 Patrick Kursawe (RETIRED) gentoo-dev 2004-03-22 02:14:26 UTC
No reaction, declaring this NEEDINFO
Comment 9 Fabien Fivaz 2004-06-02 05:51:55 UTC
I tested R-1.9.0 and everything works well, including tcl/tk.