Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 279046 - sci-geosciences/mapnik-world-boundaries-20090514 stable request
Summary: sci-geosciences/mapnik-world-boundaries-20090514 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Sci-geo Project
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks:
 
Reported: 2009-07-25 13:11 UTC by Łukasz Stelmach
Modified: 2014-03-10 17:12 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Open Data Commons Open Database License (ODbL) (dbcl-10,2.33 KB, text/plain)
2012-09-23 14:14 UTC, Todd Wright
Details
mapnik-world-boundaries-20120923.ebuild.diff (mapnik-world-boundaries-20120923.ebuild.diff,1.36 KB, text/plain)
2012-09-23 14:25 UTC, Todd Wright
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Łukasz Stelmach 2009-07-25 13:11:25 UTC
This package provides only data and no code. The meaning of its "unstability" is somehow unclear.

Reproducible: Always

Steps to Reproduce:
Comment 2 Michael Lange 2012-08-07 16:53:45 UTC
also take a look at the link, for the requirement
http://wiki.openstreetmap.org/wiki/Mapnik#Datasets
Comment 3 Todd Wright 2012-09-23 14:14:24 UTC
Created attachment 324704 [details]
Open Data Commons Open Database License (ODbL)

Since 12 September 2012, OpenStreetMap data has been licensed under the Open Database License (ODbL) (attached).

I believe this would apply to the three datasets downloadable from openstreetmap.org.

The two datasets downloaded from naturalearthdata.com are public domain. I'm not sure if that means the ebuild should be split or not.

http://wiki.openstreetmap.org/wiki/Open_Database_License
http://www.naturalearthdata.com/about/terms-of-use/
Comment 4 Todd Wright 2012-09-23 14:25:32 UTC
Created attachment 324706 [details]
mapnik-world-boundaries-20120923.ebuild.diff

I put together an ebuild for my own use which grabs all five data files. I added the dbcl license and also public-domain but as I said, it may need to be split into two ebuilds. (Im not sure on the policy here and the gentoo developer guide didnt specify)

I also updated the homepage url to point to the mapnik wiki page and moved the files to where (I believe) mapnik is expecting them (/usr/share/mapnik doesnt exist on my mapnik-2.1 installation, and I havnt got the rest of the system built yet to test it)
Comment 5 Myckel Habets 2014-02-20 11:14:29 UTC
Builds fine for x86. Please mark stable for x86.
Comment 6 Pacho Ramos gentoo-dev 2014-03-07 23:17:07 UTC
amd64 stable
Comment 7 Johannes Huber gentoo-dev 2014-03-10 17:12:23 UTC
x86 stable. Thanks Myckel. Last arch, closing.