Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 279025 - media-sound/gejengel-0.1.0 failed
Summary: media-sound/gejengel-0.1.0 failed
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Dirk Vanden Boer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-25 10:58 UTC by Ivan Ponomarev
Modified: 2009-08-13 20:07 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gejengel-0.1.0 build.log (gejengel-0.1.0-build.log,49.70 KB, text/plain)
2009-07-25 11:00 UTC, Ivan Ponomarev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Ponomarev 2009-07-25 10:58:50 UTC
* ERROR: media-sound/gejengel-0.1.0 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2236:  Called _eapi2_src_compile
 *               ebuild.sh, line  634:  Called die
 * The specific snippet of code:
 *   		emake || die "emake failed"
 *  The die message:
 *   emake failed

Reproducible: Always

Steps to Reproduce:




unmask ~amd64
sys-devel/automake-1.11
sys-devel/automake-wrapper-4

Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.28-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r5-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_6000+-with-glibc2.2.5
Timestamp of tree: Sat, 25 Jul 2009 07:30:01 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.4-r3
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8-sse3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=k8-sse3 -pipe"
DISTDIR="/mnt/linuxstore/gentoo/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en ru"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/mnt/linuxstore/gentoo/portage-local"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X acl acpi alsa amd64 bzip2 cairo cli cracklib crypt cups dbus dirac dri fam flac glitz gnutls gpm gtk hal iconv ipv6 isdnlog jpeg lcms libnotify libsexy mad midi mmx mmxext mp3 mudflap multilib ncurses nfs nls nptl nptlonly ogg opengl openmp pam pcre perl png pppd python readline reflection session smp spell spl sse sse2 ssl ssse3 startup-notification svg sysfs tcpd theora threads tiff truetype unicode vorbis wavpack x264 xattr xcb xcomposite xfce xinerama xorg xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse ps2mouse evdev" KERNEL="linux" LINGUAS="en ru" USERLAND="GNU" VIDEO_CARDS="nv radeon radeonhd vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Ivan Ponomarev 2009-07-25 11:00:20 UTC
Created attachment 199100 [details]
gejengel-0.1.0 build.log
Comment 2 Samuli Suominen gentoo-dev 2009-07-25 11:05:37 UTC
src/ui/cellrendererhoverbutton.cpp:300: error: ‘class Pango::Layout’ has no member named ‘show_in_cairo_context’

"emerge -pv pango cairo gtk+" output please.
Comment 3 Ivan Ponomarev 2009-07-25 11:40:00 UTC
emerge -pv pango cairo gtk+

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/cairo-1.8.6-r1  USE="X glitz opengl svg xcb -cleartype -debug -directfb -doc" 0 kB
[ebuild   R   ] x11-libs/pango-1.24.2  USE="X -debug -doc" 0 kB
[ebuild   R   ] x11-libs/gtk+-2.14.7-r2  USE="X cups jpeg tiff xinerama -debug -doc -jpeg2k -vim-syntax" 0 kB
Comment 4 Rafał Mużyło 2009-07-25 16:36:18 UTC
I think that should have included pangomm too.
Comment 5 Markos Chandras (RETIRED) gentoo-dev 2009-08-08 18:58:22 UTC
I really cant reproduce this issue

Is pangomm installed? Normally it should be pulled as dependency
Comment 6 Dustin Polke 2009-08-12 15:37:43 UTC
(In reply to comment #5)
> I really cant reproduce this issue
> 
> Is pangomm installed? Normally it should be pulled as dependency

I can confirm this.

dustin@legolas ~ $ emerge -pv pango cairo gtk+

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/cairo-1.8.6-r1  USE="X directfb glitz opengl svg -cleartype -debug -doc -xcb" 0 kB
[ebuild   R   ] x11-libs/pango-1.24.2  USE="X -debug -doc" 0 kB
[ebuild   R   ] x11-libs/gtk+-2.14.7-r2  USE="X cups jpeg jpeg2k tiff vim-syntax -debug -doc -xinerama" 0 kB

pangomm is not installed and not pulled in by anything:

dustin@legolas ~ $ emerge -pv pangomm
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "dev-cpp/pangomm" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-cpp/pangomm-2.24.0 (masked by: ~amd64 keyword)
- dev-cpp/pangomm-2.14.1 (masked by: ~amd64 keyword)

Comment 7 Samuli Suominen gentoo-dev 2009-08-12 15:40:35 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > I really cant reproduce this issue
> > 
> > Is pangomm installed? Normally it should be pulled as dependency
> I can confirm this.

Confirm what?

> 
> dustin@legolas ~ $ emerge -pv pango cairo gtk+
> pangomm is not installed and not pulled in by anything:

As it should be. Pangomm has nothing to do with above. "emerge -pv gejengel" instead.
Comment 8 Dustin Polke 2009-08-12 15:44:39 UTC
> Confirm what?
The bug report of the reporter. I am on amd64 as well. Will give my emerge --info further down.

> As it should be. Pangomm has nothing to do with above. "emerge -pv gejengel"
> instead.
> 
Calculating dependencies... done!
[ebuild  N    ] media-sound/gejengel-0.1.0  USE="alsa dbus ffmpeg flac libnotify mad syslog test -audioscrobbler -debug -openal -pulseaudio" 0 kB


Portage 2.1.6.13 (default/linux/amd64/10.0, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.28-gentoo-r5-stable x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r5-stable-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8100_@_2.10GHz-with-gentoo-1.12.11.1
Timestamp of tree: Wed, 12 Aug 2009 14:45:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -msse4.1"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/bin/mygenkernel /usr/sbin/run-crons /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe -msse4.1"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks fixpackages multilib-strict parallel-fetch protect-owned sandbox sfperms strict test unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://gd.tuwien.ac.at/opsys/linux/gentoo/     ftp://gentoo.inode.at/source/     ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/     ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-z,relro -Wl,-z,now"
LINGUAS="en de"
MAKEOPTS="-j5"
PKGDIR="/home/ftp/binpkg/"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=500"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/modified /usr/portage/local/own /usr/portage/local/layman/alon-barlev /usr/portage/local/layman/science /usr/portage/local/layman/desktop-effects /usr/portage/local/layman/sunrise"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X X509 Xaw3d a52 aac aalib accessibility acl acpi alsa amd64 amr amrnb amrr amrwb apm async audacious audiofile bash-completion battery berkdb bindist bl bluetooth branding bzip2 cairo cardbus cdaudio cdda cdinstall cjk cli cpufreq cracklib crypt css ctype cups curl dbus dga directfb divx dri dts dv dvd dvdr dvdread encode evo exchange exif exiv2 fam fame fbcon fbcondecor fbsplash ffmpeg flac fontforge foomaticdb force-cgi-redirect fortran ftp gd gdbm gif gimp git glade glitz gmedia gmp gnutls gphoto2 gs gsm gstreamer gtk gtkhtml guile hal hddtemp hdf5 iconv icq icu idn ieee1394 imagemagick imap imlib iproute2 isdnlog jack java javascript jikes jpeg jpeg2k kerberos keyscrub kino kpathsea lame laptop latex lcms ldap libcaca libnotify libsamplerate libsexy libv4l2 libwww live lm_sensors logrotate loop-aes lzma lzo mad memlimit mikmod mime mjpeg mmx mmxext mng mono motif mp2 mp3 mp4 mpeg mplayer mudflap multilib musepack ncurses nls nntp nowin nptl nptlonly nsplugin ntp nuv nvidia ogg opengl openmp opensslcrypto pam pch pcmcia pcre pda pdf perl plotutils png posix ppds pppd print python quicktime readline realmedia reflection rtsp ruby rubytests samba sasl sdl server session simplexml slang sndfile soap sockets sou speex spell spl sse sse2 sse3 sse4.1 ssl ssse3 startup-notification stream subversion svg swat sysfs syslog tcpd tetex tga theora threads tiff truetype unicode usb userlocales v4l v4l2 vcd vim-syntax vim-with-x vorbis wifi winbind wma wmf wmp wxwindows x264 xanim xcomposite xfce xinetd xml xmp xorg xpm xsl xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda-intel mpu401" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="fuji ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS_FLAGS
Comment 9 Markos Chandras (RETIRED) gentoo-dev 2009-08-12 16:06:23 UTC
I still cant reproduce it . I can build this application fine on 4 totally different amd64 machines

Please emerge pangomm and try to rebuild this application
Comment 10 Samuli Suominen gentoo-dev 2009-08-13 16:57:03 UTC
+  13 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> gejengel-0.1.0.ebuild:
+  Raise gtkmm depend to >= 2.16 wrt #279025.

Should take care of this.. It pulls in pangomm, cairomm and so forth.
Comment 11 Angelo Babudro 2009-08-13 20:00:04 UTC
I have the same "Pango::Layout" error appearing as shown here, but trying to
emerge pangomm as is suggested does not look straightforward:


# emerge -va pangomm

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] dev-cpp/pangomm-2.24.0  USE="-debug -doc" 973 kB
[blocks B     ] <dev-cpp/gtkmm-2.13:2.4 ("<dev-cpp/gtkmm-2.13:2.4" is blocking
dev-cpp/pangomm-2.24.0)

Total: 1 package (1 new), Size of downloads: 973 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'dev-cpp/pangomm-2.24.0', 'merge') pulled in by
    pangomm

  ('installed', '/', 'dev-cpp/gtkmm-2.12.7', 'nomerge') pulled in by
    >=dev-cpp/gtkmm-2.12.3 required by ('installed', '/',
'media-sound/ardour-2.7.1', 'nomerge')
    >=dev-cpp/gtkmm-2.4 required by ('installed', '/',
'dev-cpp/libgnomecanvasmm-2.22.0', 'nomerge')
    >=dev-cpp/gtkmm-2.6 required by ('installed', '/',
'dev-cpp/libglademm-2.6.6', 'nomerge')
Comment 12 Samuli Suominen gentoo-dev 2009-08-13 20:07:18 UTC
dev-cpp/pangomm
dev-cpp/gtkmm
dev-cpp/cairomm

to package.keywords and emerge -C gtkmm, then install it again

and if there's something missing, to .keywords also