Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 278875 - Failed to start the X server, system fails to boot into graphical interface
Summary: Failed to start the X server, system fails to boot into graphical interface
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Infrastructure
Classification: Unclassified
Component: Bugzilla (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-23 21:25 UTC by nenad
Modified: 2011-10-30 23:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nenad 2009-07-23 21:25:06 UTC
The booting screen resolution is messed, then it turns to normal like you load the live cd, it is trying to load local but flashes three times and comes out to an error that looks like this:

failed to load module "synaptics" (module does not exist, 0)
Intel: No matching device section for instance (BusID PCI:0:3:1) found
Module already built-in
GARTInit: Unable to open /dev/agpgart (No such file or directory)
Intel(0): Failed to allocate framebuffer. Is your VideoRAM set too low?
Intel(0): Couldn't allocate video memory

Fatal server error:
AddScreen/ScreenInit failed for driver 0

Failed to start the X server (your graphical interface). It is likely that it is  not set up correctly. You will need to log in on a console and reconfigure the X server. Then restart GDM.

I am reporting this bug from another computer, because I can't login to anything on it. I wiped my whole drive for linux. 

Reproducible: Didn't try




My handbook has a mobile intel 965GM Express Chipset video card
other specific information I do not know because I have no operating system on it to check.
Comment 1 Rémi Cardona gentoo-dev 2009-07-24 16:50:57 UTC
Please attach the _full_ outputs of :
 - emerge --info
 - dmesg
 - Xorg.0.log
 - xorg.conf

Thanks