Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 278665 - app-emulation/kvm-88 much slower than app-emulation/kvm-85-r2
Summary: app-emulation/kvm-88 much slower than app-emulation/kvm-85-r2
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Doug Goldstein (RETIRED)
Depends on:
Reported: 2009-07-22 11:21 UTC by Toralf Förster
Modified: 2010-01-17 10:00 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2009-07-22 11:21:36 UTC
While playing with the kvm image from the kde herd :

$> kvm -hda gentoo_kdevm.img -hdb portage_kdeprefix.img -hdd swap.img -smp 2 -m 768 -vga std -soundhw sb16

I realized, that especially the graphic output is awefully slower than w/ the previous version at my ThinkPad T400:

tfoerste@n22 /usr/local/bin $ uname -a
Linux n22 #1 SMP Mon Jul 20 10:44:52 CEST 2009 i686 Intel(R) Core(TM)2 Duo CPU P8600 @ 2.40GHz GenuineIntel GNU/Linux

Reproducible: Always

tfoerste@n22 /usr/local/bin $ emerge --info
Portage (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, i686)
System uname: Linux-
Timestamp of tree: Wed, 22 Jul 2009 10:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.5.4-r3
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="de en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X aac acl acpi alsa apache2 berkdb bluetooth branding bzip2 cairo cdda cddax cddb cdio cdr cli consolekit cracklib crypt cups curl dbus dri dvd dvdr dvdread eds emboss encode evo exif fam fastbuild firefox fortran gdbm geoip gif gmp gpm gstreamer gtk hyphenation iconv ipv6 isdnlog java jpeg kde ldap libnotify mad mbox midi mikmod mmx mp3 mp4 mpeg mudflap mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime rdesktop readline reflection sdl session slp spell spl sse sse2 ssl ssse3 startup-notification svg sysfs tcpd tiff tk truetype unicode usb vcd vorbis win32codecs wmf x86 xml xorg xpm xscreensaver xulrunner xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard evdev mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" USERLAND="GNU" VIDEO_CARDS="intel"
Comment 1 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-08-01 02:37:09 UTC
For me, 88 is somewhat faster than 85.  Are you sure that you have working kvm (not pure emulation) with 88?
Comment 2 Toralf Förster gentoo-dev 2009-08-01 08:09:49 UTC
(In reply to comment #1)
> Are you sure that you have working kvm (not pure emulation) with 88?
Erm, I hope so b/c I didn't changed anything accept than installing the new version (and tried it again w/ the same negative result).
FWIW I have "-modules" in my USE flags.

Comment 3 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-08-01 15:17:16 UTC
88 claims to work with older modules, but I've never used it that way (nor to I test every with -modules).  Could you try with the correct modules and see if that fixes your problem?
Comment 4 Toralf Förster gentoo-dev 2009-08-03 12:02:46 UTC
Tried it w/ kvm-kmod, but now it seems to be much more slower than w/o that module. BTW during emerge I get :

!!! dobin: /var/tmp/portage/app-emulation/kvm-88-r1/work/qemu-kvm-devel-88/kvm_stat does not exist
>>> Completed installing kvm-88-r1 into /var/tmp/portage/app-emulation/kvm-88-r1/image/

 * QA Notice: file does not exist:
 *      dobin: /var/tmp/portage/app-emulation/kvm-88-r1/work/qemu-kvm-devel-88/kvm_stat does not exist
strip: i686-pc-linux-gnu-strip --strip-unneeded -R .comment
Comment 5 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-08-03 15:33:03 UTC
I'll fix the kvm_stat.  It's an artifact of the reorg of the source tree.

As for the slowness, I'm not sure there's anything I can do at this point.  If I were you, I'd make sure I have good modules loaded (you can get a mismatch between the kvm.ko and the kvm-intel.ko, which can cause huge problems).  If that's the case, you're probably going to have to work it out with upstream, since I'm not a kvm developer.
Comment 6 Toralf Förster gentoo-dev 2009-08-04 09:17:33 UTC
(In reply to comment #5)
> I'd make sure I have good modules loaded (you can get a mismatch
> between the kvm.ko and the kvm-intel.ko, which can cause huge problems). If
> that's the case, you're probably going to have to work it out with upstream,
> since I'm not a kvm developer.
Ok, BTW do I have to de-activate KVM within kernel config completely if I use the moduels provided with kvm-kmod ?

Comment 7 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-08-04 13:03:53 UTC
No, unfortunately.  You have to have KVM enabled as a module in the kernel or other symbols don't get defined.  You don't have to have KVM-intel or KVM-amd enabled, tho.

What I do when I want to be absolutely sure I'm running the kvm-kmod modules (for my validations) is to remove the modules installed by the kernel (/lib/modules/<version>/kernel/arch/x86/kvm/) and leave only the ones installed by kvm-kmod (/lib/modules/<version>/kvm/

You can easily get back the kernel versions by going to your kernel try and running "make modules_install", so you don't even need to save the deleted versions if you don't want to.
Comment 8 Toralf Förster gentoo-dev 2009-08-05 09:27:22 UTC
Ok, moving the original moduels makes it faster, but the graphics stills stutter so I have to slowly move the mouse to not lose it.
So probably something for upstream ? 
Comment 9 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-08-05 13:22:43 UTC
Seems likely, yes.
Comment 10 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-09-21 15:06:16 UTC
I can't maintain kvm anymore.
Comment 11 Doug Goldstein (RETIRED) gentoo-dev 2009-11-23 00:20:04 UTC
retest with app-emulation/qemu-kvm
Comment 12 Toralf Förster gentoo-dev 2009-11-23 10:38:12 UTC
even it is slow, now the graphic itself seems not to be the bottle neck any longer - tested w/ app-emulation/qemu-kvm-0.11.0 (upgraded from app-emulation/qemu-kvm-88-r1 although portage reported a downgrade)
Comment 13 Toralf Förster gentoo-dev 2010-01-17 10:00:58 UTC
too old