Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 2786 - Gaim .58 not build gaim file
Summary: Gaim .58 not build gaim file
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Bruce A. Locke (RETIRED)
Depends on:
Reported: 2002-05-16 15:18 UTC by Robert Davis
Modified: 2003-02-04 19:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

patch to fix (gaim-0.58.ebuild.patch,308 bytes, patch)
2002-05-16 15:40 UTC, Brandon Low (RETIRED)
Details | Diff
Other (better i think) patch (fix,428 bytes, patch)
2002-05-16 20:46 UTC, Jochem Kossen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Davis 2002-05-16 15:18:19 UTC
Updated my gaim from .57 to .58 and got an error.  ran pkg-clean and removed .57
and tried to run gaim from command line.  gaim was not found qpkg -l gaim
doesn't list it either.
Comment 1 Brandon Low (RETIRED) gentoo-dev 2002-05-16 15:40:09 UTC
Created attachment 1017 [details, diff]
patch to fix

This patch takes out the "--enable-distrib" configure option, this option for
some ungodly reason b0rks the config system and causes it to build only
Comment 2 Phil Bordelon (sunflare) 2002-05-16 20:14:25 UTC
Just wanted to confirm this one.  I watched the compile, and it seems to build
both gaim and gaim_applet [the compilation is done twice, and from my experience
with Gaim in other Linux distros and metadistros this is because it's once for
gaim and once for gaim_applet].  It seems that the gaim build is getting borked.
 I looked at the .ebuild and it seems to be copying the file off to somewhere
special, but it's just not working.

I haven't tried the patch yet, though.
Comment 3 Jochem Kossen 2002-05-16 20:46:53 UTC
Created attachment 1022 [details, diff]
Other (better i think) patch

I took this from the 0.57 ebuild, it seemed more logically and it works for
Regards, Jochem
Comment 4 Brandon Low (RETIRED) gentoo-dev 2002-05-16 21:01:50 UTC
it looked like they changed away from the econf method for a reason which is why
I didn't go back to it... maintainer? comments?
Comment 5 Bruce A. Locke (RETIRED) gentoo-dev 2002-05-16 23:37:22 UTC
Working on a fix
Comment 6 Bruce A. Locke (RETIRED) gentoo-dev 2002-05-16 23:48:28 UTC
Should be fixed in 0.58-r1 which should appear in rsync in a few minutes...