Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 278323 - x11-terms/gnome-terminal-2.24.2-r1 right-click open link fails with firefox
Summary: x11-terms/gnome-terminal-2.24.2-r1 right-click open link fails with firefox
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2009-07-19 13:30 UTC by John Masinter
Modified: 2009-10-21 23:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Masinter 2009-07-19 13:30:56 UTC
When in gnome-terminal, you may right-click on any URL and "open link" to open in a browser. 
-With gnome pref set to firefox it fails. 
-With gnome pref set to epiphany, it works.

I use the gnome pref to set browser: gnome --> system --> preferences --> preferred applications --> Internet.

With x11-terms/gnome-terminal-2.24.2-r1 and www-client/mozilla-firefox-3.0.11 it gives a pop-up dialog box error:
"""
Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.
"""
This appears to be a firefox dialog, as the icon in the upper-left corner of the pop-up box is firefox.

This error occurs with gnome preferences set to FireFox and any one of:
"open link with web browser default", "open link in new window", and "open link in new tab".

In preferences, with "open link with web browser default" it shows the command it will use (grayed out) as "firefox %s" and if I run this from the command line it works fine. E.g. "$ firefox http://www.gentoo.org" Also, firefox seems to work fine in every other way for browsing etc.


Reproducible: Always

Steps to Reproduce:
1. gnome-terminal
2. right-click on URL
3. open link


Actual Results:  
firefox error dialog box.

Expected Results:  
open link in firefox.
Comment 1 John Masinter 2009-07-19 13:37:05 UTC
I have opened the firefox error console to view any error output.

I also started firefox from the command line in the foreground, with nothing re-directed, so I can see any error output there.

When re-creating the bug (e.g. in gnome-terminal right-click on URL, select open link) the same pop-up dialog error appears, but not output of any kind to error console or command line.
Comment 2 Jory A. Pratt gentoo-dev 2009-07-20 02:47:14 UTC
(In reply to comment #1)
> I have opened the firefox error console to view any error output.
> 
> I also started firefox from the command line in the foreground, with nothing
> re-directed, so I can see any error output there.
> 
> When re-creating the bug (e.g. in gnome-terminal right-click on URL, select
> open link) the same pop-up dialog error appears, but not output of any kind to
> error console or command line.
> 

If you would check to see if there is a firefox process still running, This may be related to firefox failing to shutdown properly.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-08-26 21:09:35 UTC
I thought this would be related to deprecated command line parameters but firefox just doesn't want to start at all for me. Shows up a window and dies instantly.

Anyway, if there is an error, it would be seen in ~/.xsession-errors. Please attach this file when triggering the bug.
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-09-06 11:54:56 UTC
Please get back to us.
Comment 5 John Masinter 2009-09-06 15:35:25 UTC
There was no another FF process running. I checked that first thing. Several times I made sure to kill all firefox, then start over. Same results.

At the moment I'm emerging world, as my system was fairly out of date.
Hopefully this will resolve, but I don't like to solve problems this way as we never know the root cause and others may be affected by this.

Thanks for the reply. I'll update you soon with a fully up to date system test.