Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 27825 - Firewire DV support needs to be disabled in <2.4.21 kernels
Summary: Firewire DV support needs to be disabled in <2.4.21 kernels
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: x86-kernel@gentoo.org (DEPRECATED)
URL: http://www.linux1394.org/dv1394.html
Whiteboard:
Keywords:
: 35384 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-09-02 19:44 UTC by Arc
Modified: 2003-12-08 16:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arc 2003-09-02 19:44:05 UTC
DV support is listed as being available, albiet experimental, in the 2.4.19 and
2.4.20 kernel sources.  I have confirmed, through four days of frustration, that
it only works with 2.4.21+ kernels.  The URL I listed confirms this.

With 2.4.20 kernels dvcont can control the camcorder, make it play, rewind, etc,
but it cannot receive video through dvgrab, kino, or cinelerra.  Furthermore,
attempts to do so sometimes causes the kernel to panic.

Reproducible: Always
Steps to Reproduce:
1. Emerge a 2.4.20 kernel, such as gentoo-sources
2. Compile with Firewire and DV support
3. Emerge kino or cinelerra (or manually compile dvgrab, command line tool)
4. Attempt to capture video from the camera
Actual Results:  
No video, often program crashes (segfault, etc), other times it reports "lost
frames", and occassionally causes a kernel panic.  On very rare occassions, many
fewer times than I've managed to cause a kernal panic, some video frames were
received.  These cases don't happen nearly often enough to be useful.

Expected Results:  
Video should have been captured.

If 2.4.19 and 2.4.20 kernel sources are to maintain in portage I believe the DV
support should be removed from them.  Doing so may help eliminate alot of stress
by video producers looking at Gentoo as a viable alternative.
Comment 1 Brian Jackson (RETIRED) gentoo-dev 2003-10-29 09:45:42 UTC
it being marked as experimental is enough. People should observe the kernels
warnings. In any case we are in the process of updating all kernels to be
based on at least 2.4.22.
Comment 2 Matthias Muthmann 2003-12-08 16:36:33 UTC
*** Bug 35384 has been marked as a duplicate of this bug. ***