Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 27780 - No fullscreen with mplayer -vo xv with fluxbox-0.9.x
Summary: No fullscreen with mplayer -vo xv with fluxbox-0.9.x
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 28826 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-09-02 09:36 UTC by Christian Apolloni
Modified: 2003-10-09 06:12 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Apolloni 2003-09-02 09:36:26 UTC
With mplayer (now using 0.91) trying to go fullscreen (pressing 'f' from window
mode) with '-vo xv' makes the whole mplayer disappear, if using fluxbox-0.9 (I
tried with 0.9.4 and 0.9.6).

Mplayer still plays, the audio is audible, but it is invisible. Pressing 'f'
again makes the window reappear. In window mode the movie plays correctly and
using '-vo sdl' it plays correctly in window and in fullscreen too.

With fluxbox-0.1.4 -vo xv in fullscreen works correctly.
Comment 1 Christian Apolloni 2003-09-02 09:41:06 UTC
Forgot to mention, I have xfree-4.3.0-r3, nvidia-kernel-1.0.4496-r1 and a GeForce4 Ti 4800 SE.
Comment 2 Joel Hill (RETIRED) gentoo-dev 2003-09-15 14:14:36 UTC
yes this is because there's a major bug in .9.x's window handling it doesn't unset/clear the WM_STATE property when the a window is withdrawn they should have ewmh fullscreen state support but they dont :( ive talked to the fluxbox group but  they seem to have a little interest in fixing it
Comment 3 SpanKY gentoo-dev 2003-09-15 14:52:34 UTC
*** Bug 28826 has been marked as a duplicate of this bug. ***
Comment 4 Sami Näätänen 2003-09-20 02:58:30 UTC
This problem seems to be fixed in the 0.9.6_pre8 version of fluxbox.
Comment 5 Patrick Kursawe (RETIRED) gentoo-dev 2003-10-08 01:14:53 UTC
Ok, if it works in latest stable and latest unstable version, I'd say we
call this WORKSFORME. Christian? Can you confirm this?
Comment 6 Christian Apolloni 2003-10-08 05:18:18 UTC
I am sorry but it seems unsolved here (with pre8 and pre9) and with
mplayer-1.0_pre2 too... :(

Maybe is something dependant on my configuration?
Comment 7 Martin Holzer (RETIRED) gentoo-dev 2003-10-08 05:19:24 UTC
xfree 4.3.0-r3 is stable now
please update and check again

#etc-update and make sure all of your config files are up2date
Comment 8 Christian Apolloni 2003-10-08 08:40:42 UTC
@Martin Holzer

I already had -r3 when I reported the problem (running an ~x86 system).
Comment 9 Christian Apolloni 2003-10-08 08:50:35 UTC
I managed to get fullscreen. I had to keep "f" pressed. Then after the windowed
mplayer starts "blinking" (appearing and disappearing), depressing "f" causes
mplayer to go fullscreen.

I got the idea in my last googling sessin for something useful about this
bug,
when I found:

http://mplayerhq.hu/pipermail/mplayer-users/2003-April/031713.html
Comment 10 Patrick Kursawe (RETIRED) gentoo-dev 2003-10-08 22:58:54 UTC
So... as far as I can see this is a known upstream problem which we can't
fix locally.
Comment 11 Christian Apolloni 2003-10-09 05:34:32 UTC
@Patrick Kursawe

I don'know if it's known also for the version involved here.
Should I report it upstream or somebody has already done it/is going to do
it?
Comment 12 Patrick Kursawe (RETIRED) gentoo-dev 2003-10-09 06:12:22 UTC
Would be nice if you report this. If there are any questions, they know whom
to ask instead of asking me to ask you to check $whatever. Thanks.