Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 277774 - dev-util/kdbg: fails to build with glibc-2.10
Summary: dev-util/kdbg: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-07-14 09:11 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-08 22:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (kdbg-2.1.1:20090714-044639.log,26.69 KB, text/plain)
2009-07-14 09:12 UTC, Diego Elio Pettenò (RETIRED)
Details
fixes compile with glibc-2.10.1 (kdbg.patch,1.97 KB, patch)
2009-08-02 02:17 UTC, Evan Teran
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-14 09:11:29 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2] and [3].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
[3] http://blog.flameeyes.eu/2009/07/08/how-_not_-to-fix-glibc-2-10-function-collisions
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-14 09:12:22 UTC
Created attachment 197887 [details]
Build log
Comment 2 Evan Teran 2009-08-02 02:17:37 UTC
Created attachment 199875 [details, diff]
fixes compile with glibc-2.10.1

this is a quick and easy patch for kdbg. Basically it addresses the issue of things like this:

const char *p = ...;
char *s = strchr(p, x); /* drops the const! */
Comment 3 Evan Teran 2009-08-02 02:19:05 UTC
I forgot to mention, this patch is for kdb-2.1.1. appears to apply cleanly against 2.1.0 as well.
Comment 4 Samuli Suominen gentoo-dev 2009-08-08 22:09:44 UTC
  08 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> kdbg-2.1.1.ebuild,
+  +files/kdbg-2.1.1-glibc-2.10.patch:
+  Fix building with GLIBC 2.10+ wrt #277774, thanks to Evan Teran for patch.