Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 277583 - net-mail/bincimap: fails to build with glibc-2.10
Summary: net-mail/bincimap: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Net-Mail Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-07-13 00:08 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-08 07:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (bincimap-1.2.13:20090712-133422.log,13.34 KB, text/plain)
2009-07-13 00:09 UTC, Diego Elio Pettenò (RETIRED)
Details
This was applied. (bincimap-1.2.13-glibc-2.10.patch,469 bytes, patch)
2009-08-08 07:37 UTC, Samuli Suominen
Details | Diff
But would this have been more appropiate? (bincimap-1.2.13-glibc-2.10.patch,644 bytes, patch)
2009-08-08 07:38 UTC, Samuli Suominen
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-13 00:08:44 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2] and [3].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
[3] http://blog.flameeyes.eu/2009/07/08/how-_not_-to-fix-glibc-2-10-function-collisions
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-13 00:09:03 UTC
Created attachment 197720 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-08-08 07:37:19 UTC
Created attachment 200555 [details, diff]
This was applied.
Comment 3 Samuli Suominen gentoo-dev 2009-08-08 07:38:03 UTC
Created attachment 200557 [details, diff]
But would this have been more appropiate?

Flameeyes, can you check? The first one was applied, not this one.