Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 277315 - dev-embedded/avarice: fails to build with glibc-2.10
Summary: dev-embedded/avarice: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Embedded Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-07-10 13:25 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-07 08:53 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (avarice-2.9:20090710-130731.log,14.08 KB, text/plain)
2009-07-10 13:25 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-10 13:25:10 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2] and [3].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
[3] http://blog.flameeyes.eu/2009/07/08/how-_not_-to-fix-glibc-2-10-function-collisions
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-10 13:25:21 UTC
Created attachment 197462 [details]
Build log
Comment 2 Thomas Capricelli 2009-07-27 20:00:40 UTC
fails here with sys-libs/glibc-2.10.1 and cross-avr/gcc-4.4.1. The error is :


In file included from jtag2run.cc:39:
jtag2.h: In constructor ‘jtag2::jtag2(const char*, char*, bool, bool, bool, bool)’:
jtag2.h:155: warning: large integer implicitly truncated to unsigned type
if x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I.     -march=native -pipe -msse3 -MT jtag2usb.o -MD -MP -MF ".deps/jtag2usb.Tpo" -c -o jtag2usb.o jtag2usb.cc; \
    then mv -f ".deps/jtag2usb.Tpo" ".deps/jtag2usb.Po"; else rm -f ".deps/jtag2usb.Tpo"; exit 1; fi
In file included from jtag2rw.cc:38:
jtag2.h: In constructor ‘jtag2::jtag2(const char*, char*, bool, bool, bool, bool)’:
jtag2.h:155: warning: large integer implicitly truncated to unsigned type
if x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I.     -march=native -pipe -msse3 -MT jtagbp.o -MD -MP -MF ".deps/jtagbp.Tpo" -c -o jtagbp.o jtagbp.cc; \
    then mv -f ".deps/jtagbp.Tpo" ".deps/jtagbp.Po"; else rm -f ".deps/jtagbp.Tpo"; exit 1; fi
if x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I.     -march=native -pipe -msse3 -MT jtaggeneric.o -MD -MP -MF ".deps/jtaggeneric.Tpo" -c -o jtaggeneric.o jtaggeneric.cc; \
    then mv -f ".deps/jtaggeneric.Tpo" ".deps/jtaggeneric.Po"; else rm -f ".deps/jtaggeneric.Tpo"; exit 1; fi
jtag2usb.cc: In function ‘usb_dev_handle* opendev(const char*, emulator, int&)’:
jtag2usb.cc:98: error: invalid conversion from ‘const char*’ to ‘char*’
make[2]: *** [jtag2usb.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/tmp/portage/dev-embedded/avarice-2.9/work/avarice-2.9/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/portage/dev-embedded/avarice-2.9/work/avarice-2.9/src'
make: *** [all-recursive] Error 1
 ^[[31;01m*^[[0m
Comment 3 Samuli Suominen gentoo-dev 2009-08-07 08:53:46 UTC
+*avarice-2.10 (07 Aug 2009)
+
+  07 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> +avarice-2.10.ebuild,
+  +files/avarice-2.10-gcc44.patch:
+  Version bump. Fix building with GCC 4.4+ and GLIBC 2.10+ wrt #277315.

(Patch is from upstream CVS.)