Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 277253 - media-plugins/vdr-undelete: fails to build with glibc-2.10
Summary: media-plugins/vdr-undelete: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo VDR Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-07-09 20:41 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-09 19:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (vdr-undelete-0.0.6-r1:20090709-195232.log,12.32 KB, text/plain)
2009-07-09 20:41 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-09 20:41:06 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2] and [3].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
[3] http://blog.flameeyes.eu/2009/07/08/how-_not_-to-fix-glibc-2-10-function-collisions
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-09 20:41:57 UTC
Created attachment 197406 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-08-09 19:07:19 UTC
fixed, thanks