Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 277237 - [PATCH] sys-fs/encfs-1.5 does not compile with glibc-2.10
Summary: [PATCH] sys-fs/encfs-1.5 does not compile with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Marcelo Goes (RETIRED)
URL:
Whiteboard:
Keywords:
: 280677 (view as bug list)
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-07-09 19:12 UTC by Martin Väth
Modified: 2009-08-07 17:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to make encfs compile with glibc-2.10.1 (encfs-glibc-2.10.patch,299 bytes, patch)
2009-07-09 19:13 UTC, Martin Väth
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Väth 2009-07-09 19:12:01 UTC
encfs-1.5 suffers from the frequent problem of a missing "const" for the
variable storing the return value of strchr(). The trivial patch is appended.
Comment 1 Martin Väth 2009-07-09 19:13:03 UTC
Created attachment 197387 [details, diff]
Patch to make encfs compile with glibc-2.10.1
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-09 20:34:36 UTC
Patch looks okay.
Comment 3 Märt Bakhoff 2009-07-16 21:09:21 UTC
Worked for me. Thank you! 
Comment 4 Samuli Suominen gentoo-dev 2009-08-07 10:45:12 UTC
applied. thanks martin.
Comment 5 Samuli Suominen gentoo-dev 2009-08-07 17:36:50 UTC
*** Bug 280677 has been marked as a duplicate of this bug. ***