Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 277104 - net-misc/socat fails tests
Summary: net-misc/socat fails tests
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
: 505324 (view as bug list)
Depends on: 294586
Blocks:
  Show dependency tree
 
Reported: 2009-07-08 21:19 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2014-03-22 15:32 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (socat-1.7.1.1:20090708-203733.log,57.56 KB, text/plain)
2009-07-08 21:19 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-08 21:19:02 UTC
Portage 2.1.6.13 (!../var/cache/portage/tree/profiles/default/linux/x86/2008.0, gcc-4.4.0-asneeded, glibc-2.10.1-r0, 2.6.30-gentoo-r1 i686)
=================================================================
System uname: Linux-2.6.30-gentoo-r1-i686-Quad-Core_AMD_Opteron-tm-_Processor_2350-with-gentoo-2.0.1
Timestamp of tree: Wed, 08 Jul 2009 19:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p24
dev-java/java-config: 1.3.7-r1, 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/glftpd/etc /opt/glftpd/ftp-data /opt/openfire/resources/security/ /opt/openjms/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/bufrtables /usr/share/config /var/bind /var/lib/hsqldb /var/phxd /var/spool/torque /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict test test-fail-continue unmerge-orphans userfetch"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo"
INSTALL_MASK="  /usr/share/doc  /usr/share/man  /usr/share/info"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j14"
PKGDIR="/var/spool/portage/packages"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/tree-tinderbox"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups dri fortran gdbm gpm iconv ipv6 isdnlog java5 java6 midi mudflap ncurses nls nostatic nptl nptlonly openmp pam pcre perl pppd python qt3support readline reflection ruby session spl ssl sysfs tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-08 21:19:22 UTC
Created attachment 197261 [details]
Build log
Comment 2 Peter Volkov (RETIRED) gentoo-dev 2009-07-09 15:06:08 UTC
Upstream states:

"please note that the purpose of these tests is to check the integrity of 
the socat program, not of its environment - so do not overestimate their 
significance. I am pretty sure that socat itself is working correctly 
(at least "as designed")."

So I'm not sure what to do in such situation.
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-09 15:10:37 UTC
I'd suggest checking, on Linux kernel, if the ipv6 and sctp support is enabled in the kernel, and if not skip over tests.
Comment 4 Peter Volkov (RETIRED) gentoo-dev 2009-07-09 15:19:06 UTC
Well, this what we should check but last time I've tried to fix testsuite I remember there was some strange bug due to difference in bash versions on my and upstream systems... But let's keep this bug open and thank you for report.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2009-07-09 21:19:47 UTC
Compare bug #270855 comment #6. These tests are OK to fail. They could be improved to not fail when the OS lacks some features. That requires a fairly large patch, and in the mean time the test suite is verbose enough for any user to figure out whether a failure is really important. We could of course set 
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2009-07-09 21:21:35 UTC
(In reply to comment #5)
> We could of course set 

... something like this:

Index: socat-1.7.1.1.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-misc/socat/socat-1.7.1.1.ebuild,v
retrieving revision 1.8
diff -u -B -r1.8 socat-1.7.1.1.ebuild
--- socat-1.7.1.1.ebuild        22 Jun 2009 16:19:30 -0000      1.8
+++ socat-1.7.1.1.ebuild        9 Jul 2009 21:21:22 -0000
@@ -34,7 +34,7 @@
 }

 src_test() {
-       TMPDIR="${T}" emake test || die 'self test failed'
+       TMPDIR="${T}" emake test || ewarn "emake test failed"
 }

 src_install() {
Comment 7 Jeroen Roovers (RETIRED) gentoo-dev 2009-11-25 14:34:01 UTC
*** Bug 294586 has been marked as a duplicate of this bug. ***
Comment 8 Jeroen Roovers (RETIRED) gentoo-dev 2014-03-22 14:59:05 UTC
*** Bug 505324 has been marked as a duplicate of this bug. ***
Comment 9 Jeroen Roovers (RETIRED) gentoo-dev 2014-03-22 15:32:49 UTC
RESTRICT=test is in place in 1.7.2.4-r1 and 2.0.0_beta7-r1.