Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 277098 - sci-biology/qrna: fails to build with glibc-2.10
Summary: sci-biology/qrna: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Science Biology related packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-07-08 20:38 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-05 19:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (qrna-2.0.3c:20090708-202004.log,2.11 KB, text/plain)
2009-07-08 20:38 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-08 20:38:23 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-08 20:38:37 UTC
Created attachment 197253 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-08-05 19:33:05 UTC
Fixed *this* issue, but GCC 4.4.1 dies with "Internal compiler" error anyway with this package, unless you enforce -O0 or -g instead of -O2... After that there's even more problems.

Anyway, this bug is fixed, if you care enough -> new issues -> new bugs