Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 276886 - net-libs/libnipper: fails to build with glibc-2.10
Summary: net-libs/libnipper: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mike Auty
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-07-07 08:59 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-07-10 06:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (libnipper-0.12.6:20090707-022541.log,7.08 KB, text/plain)
2009-07-07 09:02 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-07 08:59:24 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-07 09:02:13 UTC
Created attachment 197014 [details]
Build log
Comment 2 Mike Auty gentoo-dev 2009-07-10 06:36:10 UTC
Thanks very much, I contacted the author, and this has been fixed in 0.12.6-r1.ebuild.