Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 276847 - app-text/kbedic: fails to build with glibc-2.10
Summary: app-text/kbedic: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mario Tanev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-07-06 22:39 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-07 09:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (kbedic-4.0:20090706-212832.log,14.88 KB, text/plain)
2009-07-06 22:39 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-06 22:39:33 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is. Also make sure to fix it rather than sidestepping the issue [2].

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
[2] http://blog.flameeyes.eu/2009/07/02/how-_not_-to-fix-gcc-4-4-bugs
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-06 22:39:58 UTC
Created attachment 196978 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-08-07 09:02:22 UTC
+  07 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+  -files/kbedic-3.1-gcc3.diff, -files/kbedic-3.1-location.diff,
+  kbedic-4.0.ebuild, +files/kbedic-4.0-gcc44.patch, -files/kbedic.desktop:
+  Fix building with GCC 4.4+ and GLIBC 2.10+ wrt #276847. Remove .desktop
+  entry from invalid location. Remove invalid aRts depend.
+