Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 276298 - sci-chemistry/gchemutils: fails to build with glibc-2.10
Summary: sci-chemistry/gchemutils: fails to build with glibc-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Jeffrey Gardner (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-07-02 21:06 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-08 08:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (gchemutils-0.10.3:20090702-210446.log,47.42 KB, text/plain)
2009-07-02 21:07 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-02 21:06:49 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-02 21:07:05 UTC
Created attachment 196447 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-08-08 08:44:18 UTC
+  08 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+  gchemutils-0.10.3.ebuild, +files/gchemutils-0.10.3-glibc-2.10.patch:
+  Remove invalid USE debug inherited with gnome2.eclass. Disable mozilla
+  plug-in because it needs =xulrunner-1.8* wrt #280049. Fix building with
+  GLIBC 2.10+ wrt #276298. Port from built_with_use to EAPI=2 USE deps. Fix
+  missing deps intltool and rarian.