Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 276240 - x11-misc/xnc removal request (was: fails to build with glibc-2.10)
Summary: x11-misc/xnc removal request (was: fails to build with glibc-2.10)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Desktop Misc. Team
URL:
Whiteboard: Pending removal: 2009-09-01
Keywords: PMASKED
: 274379 (view as bug list)
Depends on:
Blocks: 252513 glibc-2.10
  Show dependency tree
 
Reported: 2009-07-02 14:09 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-09-04 08:29 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (xnc-5.0.4:20090702-135941.log,173.79 KB, text/plain)
2009-07-02 14:09 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-02 14:09:35 UTC
There are a few changes in glibc-2.10 that might make your software fail to build with it, please refer to my blog post [1] if you're not sure what the problem is.

And no I don't usually provide emerge --info with these bugs because they are caused by glibc-2.10!

Thanks, Diego

[1] http://blog.flameeyes.eu/2009/05/24/c-libraries-galore
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-07-02 14:09:50 UTC
Created attachment 196367 [details]
Build log
Comment 2 Samuli Suominen gentoo-dev 2009-08-09 20:20:04 UTC
It also has O_CREAT problems I believe this one fails with 2.9 as well?
Comment 3 Samuli Suominen gentoo-dev 2009-08-10 17:58:22 UTC
*** Bug 274379 has been marked as a duplicate of this bug. ***
Comment 4 Samuli Suominen gentoo-dev 2009-09-04 08:29:06 UTC
Removed from tree by maintainers.