Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 276231 - media-libs/libmp4v2-1.5.0.1-r2 compiles incorrectly with GCC4.4
Summary: media-libs/libmp4v2-1.5.0.1-r2 compiles incorrectly with GCC4.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-07-02 13:30 UTC by Vladimir Skuratovich
Modified: 2009-07-13 21:12 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
A patch that fixes the problem (mp4v2-and-gcc4.patch,1.17 KB, patch)
2009-07-02 13:31 UTC, Vladimir Skuratovich
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Skuratovich 2009-07-02 13:30:16 UTC
Libmp4v2 v.1.5.0.1 is miscompiled with GCC 4.4, at least on AMD64, and as a result it fails to open AAC files.



Reproducible: Always

Steps to Reproduce:
1. Install GCC 4.4 and switch to it
2. Emerge libmp4v2, faad2 and cmus
3. Try to play any AAC file in cmus, or add it to a playlist

Actual Results:  
The file isn't added to the playlist, and you get an error message when attempting to play it

Expected Results:  
The file should play normally

A patch for libmp4v2 and the ebuild is included.

It seems that a 'hack' used by the developers of libmp4v2 doesn't work any more when compiled with GCC 4.4. There seems to be little to no performance benefit from it, and the 'normal' version was there, but compiled out - so I simply reverted to the 'normal' version.

AAC files play as expected after the fix.

This is the first time I report a bug here, so if I've done something incorrectly, please tell me.
Comment 1 Vladimir Skuratovich 2009-07-02 13:31:50 UTC
Created attachment 196358 [details, diff]
A patch that fixes the problem
Comment 2 Rafał Mużyło 2009-07-03 02:06:28 UTC
Let me guess: somewhere in the build.log
there's something like
"... does break strict aliasing" -
a warning, that in-tree versions of portage
don't catch yet (though it's supposed to be fix in cvs).
Comment 3 Vladimir Skuratovich 2009-07-03 15:09:19 UTC
No, I don't see any such warnings, although there should be. The optimization level was set to -Os in both cases.
Comment 4 Samuli Suominen gentoo-dev 2009-07-10 16:37:05 UTC
dunno, try 1.9.0 (it's still masked, the package got a new upstream)
Comment 5 Samuli Suominen gentoo-dev 2009-07-11 16:13:59 UTC
(In reply to comment #4)
> dunno, try 1.9.0 (it's still masked, the package got a new upstream)
> 

unmasked now into ~arch
Comment 6 Samuli Suominen gentoo-dev 2009-07-13 21:11:14 UTC
(In reply to comment #0)
> 1. Install GCC 4.4 and switch to it
> 2. Emerge libmp4v2, faad2 and cmus
> 3. Try to play any AAC file in cmus, or add it to a playlist

I've just tried this. Following file,

01 Cowboys From Hell.m4a: ISO Media, MPEG v4 system, iTunes AAC-LC

Is playing fine here. Start cmus, hit "5" to fileview, hit "y" to add files, hit "3" for playlist and play a song.

And the code isn't in the include anymore.

Closing as FIXED (by 1.9.0) -- Thanks for reporting.