Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 276130 - media-gfx/blender-2.48a-r3 fails to compile with MAKEOPTS="-j -l 2.33"
Summary: media-gfx/blender-2.48a-r3 fails to compile with MAKEOPTS="-j -l 2.33"
Status: RESOLVED DUPLICATE of bug 302688
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Luca Barbato
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-01 23:03 UTC by Thomas Jones
Modified: 2011-10-29 21:27 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Jones 2009-07-01 23:03:49 UTC
I have MAKEOPTS="-j -l 2.33" in my make.conf this cause blender's ebuild to fail src_compile because the ebuild filters the -l option with this line

scons ${MAKEOPTS/-l[0-9]} || die \

which will not catch the above use of -l




Reproducible: Always

Steps to Reproduce:
1. set MAKEOPTS to something with -l that has more than one digit in the argument to -l
2. emerge blender
Comment 1 Thomas Jones 2009-07-01 23:51:52 UTC
possibly it could do this instead

scons `echo "${MAKEOPTS}" | sed 's/ -l [0-9]\+\(\.[0-9]*\)//'`
Comment 2 Thomas Jones 2009-07-04 18:28:44 UTC
(In reply to comment #1)
> possibly it could do this instead
> 
> scons `echo "${MAKEOPTS}" | sed 's/ -l [0-9]\+\(\.[0-9]*\)//'`
> 

err nevermind that's broken too...
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2009-07-05 08:40:03 UTC
Maybe something like 

 sed 's:-l [0-9.]\+::'

could work...
Comment 4 Daniel Nilsson 2010-10-02 10:30:48 UTC
I just hit this bug by having "-l4.5" in MAKEOPTS.
This bug seems to be related to bug #302688 where it is suggested to use the code from bug #241684.
As a workaround I ran emerge like this:
MAKEOPTS=-j4 emerge blender
Comment 5 Sebastian Pipping gentoo-dev 2011-10-29 21:27:05 UTC
I believe this is a duplicate of bug #302688.

FYI I have requested handling of these options from the scons-utils eclass at bug #388889.

*** This bug has been marked as a duplicate of bug 302688 ***