Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 276124 - app-office/openoffice problem amdfam10 cflag
Summary: app-office/openoffice problem amdfam10 cflag
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-01 21:05 UTC by Martin
Modified: 2009-07-13 06:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin 2009-07-01 21:05:42 UTC
I have tried to emerge OpenOffice with the march=amdfam10 cflag and it didnt finish. If I change this CFLAG to -march=athlon64, OpenOffice compile and work OK.


emerge --info

Portage 2.2_rc33 (default/linux/amd64/2008.0/desktop, gcc-4.3.3, glibc-2.10.1-r0, 2.6.30-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r1-x86_64-AMD_Phenom-tm-_9550_Quad-Core_Processor-with-gentoo-2.0.1
Timestamp of tree: Wed, 01 Jul 2009 12:30:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p24
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=amdfam10 -pipe -fomit-frame-pointer -msse -msse2 -msse3 -mmmx -m3dnow -mfpmath=sse"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=amdfam10 -pipe -fomit-frame-pointer -msse -msse2 -msse3 -mmmx -m3dnow -mfpmath=sse"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.localhost.net.ar/"
LANG="es_AR.UTF-8"
LC_ALL="es_AR.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="es"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/desktop-effects /usr/local/portage/layman/jokey /usr/local/portage/layman/sunrise"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X Xaw3d aac aalib acl acpi alsa amd64 amrnb amrwb apm ares audiofile avi bash-completion bcmath berkdb bitmap-fonts bittorrent bluetooth branding bzip2 cairo calendar cddax cdio cdparanoia cdr cli consolekit cracklib crypt cups dbus directfb dri dvd dvdr dvdread eds emboss encode esd evo exif fam fbcon ffmpeg firefox fortran ftp gcj gd gdbm gif glitz gnome gphoto2 gpm gstreamer gtk gtk2 hal iconv imlib isdnlog jabber java javascript jpeg jpeg2 ldap libcaca libdvdread libg++ libnotify libv4l2 libwww lm_sensors mad maildir matroska mbrola mcal metalink midi mikmod mmx mmx2 mmxext mozdevelop mp2 mp3 mpeg mplayer msn mudflap multilib musicbrainz mysql ncurses nls nptl nptlonly nsplugin obex ogg old-daemons opengl openmp oss pam pcre pdf perl plotutils png ppds pppd python qt3support quicktime radio readline reflection rtsp samba sdl server session slang sms spell spl sqlite sqlite3 sse sse2 sse3 ssl ssse3 startup-notification svg symlink sysfs taglib tcpd theora threads threadsafe tidy tiff truetype truetype-fonts type1-fonts udev unicode usb userlocales v4l v4l2 vcd vorbis x264 xattr xcb xcomposite xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda-intel bt87x usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es" NETBEANS_MODULES="j2ee mobility php visualweb xml ide websvccommon cnd apisupport java nb groovy gsf harness dlight enterprise profiler webcommon" USERLAND="GNU" VIDEO_CARDS="nvidia fbdev nv none"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-07-03 07:04:01 UTC
Works for me with -march=barcelona (which is the same as amdfam10):

shanghai:~# cat /var/db/pkg/app-office/openoffice-3.1.0/CFLAGS
-march=barcelona -pipe -DGL_GLEXT_PROTOTYPES

First try to reproduce the problem with ccache being disabled. If that still fails with -march=amdfam10 then please attach the compressed build.log file to this bug.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-07-13 06:31:43 UTC
Please do what I suggested in my prevoius post. Reopen this bug and provide the requested information in case that still doesn't fix your problem.