Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 275856 - media-gfx/sam2p-0.46 build error, invalid reference, ld returned 1 as status
Summary: media-gfx/sam2p-0.46 build error, invalid reference, ld returned 1 as status
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-29 17:54 UTC by Sebastian Wiesner
Modified: 2010-05-31 09:16 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Output of 'emerge --info' (emerge.info,3.86 KB, text/plain)
2009-06-29 17:56 UTC, Sebastian Wiesner
Details
portage build.log (build.log,20.08 KB, text/plain)
2009-06-29 17:58 UTC, Sebastian Wiesner
Details
build.log (media-gfx:sam2p-0.46:20090803-212544.log,19.81 KB, text/plain)
2009-08-03 21:28 UTC, Bertrand Jacquin
Details
Output of emerge --info (emerge--info,10.36 KB, text/plain)
2010-03-22 17:00 UTC, Pierre ROUDIER
Details
Output of emerge -pqv (emerge-pqv,59 bytes, text/plain)
2010-03-22 17:00 UTC, Pierre ROUDIER
Details
Complete build log (build.log,20.30 KB, text/plain)
2010-03-22 17:01 UTC, Pierre ROUDIER
Details
Ebuild environment (environment,104.94 KB, text/plain)
2010-03-22 17:01 UTC, Pierre ROUDIER
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Wiesner 2009-06-29 17:54:09 UTC
While building media-gfx/samp-0.46 on my ~amd64 system, the following error occures:

sam2p_main.o: In function `one_liner(SimBuffer::B&, char const* const*)':
sam2p_main.cpp:(.text+0x3db0): undefined reference to `Rule::Cache::PR_PNGAuto'
sam2p_main.cpp:(.text+0x3dc2): undefined reference to `Rule::Cache::PR_None'
collect2: ld gab 1 als Ende-Status zurück
make: *** [sam2p] Error 1
 * 
 * ERROR: media-gfx/sam2p-0.46 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2752:  Called die
 * The specific snippet of code:
 *       emake || die "make failed"
 *  The die message:
 *   make failed


Reproducible: Always
Comment 1 Sebastian Wiesner 2009-06-29 17:56:06 UTC
Created attachment 196097 [details]
Output of 'emerge --info'
Comment 2 Sebastian Wiesner 2009-06-29 17:58:04 UTC
Created attachment 196098 [details]
portage build.log
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2009-07-04 18:25:50 UTC
This package compiles without any error on my ~amd64 machine...

Does the package compile successfully after you disabled ccache?
Comment 4 Sebastian Wiesner 2009-07-05 15:35:48 UTC
No,

disabling ccache doesnt`t fix it for me.
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2009-07-13 13:28:44 UTC
Please attach a build.log file which contains english messages.

  LANG="C" emerge -1 sam2p
Comment 6 Bertrand Jacquin 2009-08-03 21:26:35 UTC
Hi,

I can get the same error. Following build.log

Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.10.1-r0, 2.6.30-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r4-x86_64-Pentium-R-_Dual-Core_CPU_E5200_@_2.50GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 03 Aug 2009 15:00:01 +0000
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1, 3.1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.0
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS=""
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages noinfo parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS=" http://ftp.free.fr/mirrors/ftp.gentoo.org/ ftp://ftp.ipv6.uni-muenster.de/pub/linux/distributions/gentoo http://trumpetti.atm.tut.fi/gentoo/ http://ftp.heanet.ie/pub/gentoo/ http://ftp.snt.ipv6.utwente.nl/pub/os/linux/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/ http://mirror.uni-c.dk/pub/gentoo/ http://mirror.ovh.net/gentoo-distfiles/ http://mirror.meleeweb.net/pub/linux/gentoo/"
LDFLAGS="-Wl,-O1"
LINGUAS="fr fr_FR br_FR br"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/enlightenment /usr/local/portage/layman/sunrise /usr/local/portage/layman/games /opt/meleeweb/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac alsa amd64 amr bash-completion bzip2 cairo cleartype cli cracklib crypt curl dga dirac divx dri exif faac faad ffmpeg flac gif gnutls gpg gsm gstreamer hardened iconv imagemagick ipv6 isdnlog jpeg ldap mad mmx mng mp3 mudflap multilib musepack ncurses nls nptl nptlonly ogg opengl openmp pam pcre png pppd pulseaudio quicktime readline realmedia reflection schroedinger sdl session smp speex spl sse sse2 ssl ssse3 svg sysfs syslog theora threads toolame truetype twolame unicode vim-syntax vorbis wavpack wmp x264 xcb xft xine xorg xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR br_FR br" QEMU_SOFTMMU_TARGETS="i386" QEMU_USER_TARGETS="i386" USERLAND="GNU" VIDEO_CARDS="intel vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 7 Bertrand Jacquin 2009-08-03 21:28:22 UTC
Created attachment 200055 [details]
build.log
Comment 8 Pierre ROUDIER 2010-03-22 17:00:04 UTC
Created attachment 224713 [details]
Output of emerge --info
Comment 9 Pierre ROUDIER 2010-03-22 17:00:34 UTC
Created attachment 224715 [details]
Output of emerge -pqv
Comment 10 Pierre ROUDIER 2010-03-22 17:01:07 UTC
Created attachment 224717 [details]
Complete build log
Comment 11 Pierre ROUDIER 2010-03-22 17:01:23 UTC
Created attachment 224719 [details]
Ebuild environment
Comment 12 Pierre ROUDIER 2010-03-22 17:01:54 UTC
(In reply to comment #0)

I have the same problem here but the latest available version of sam2p (0.47) does compile and run smoothly..

I downloaded if from from http://code.google.com/p/sam2p/downloads/list

I'm going to attach the build log, the environment, the output of emerge --info and -pqv so that you have more information.

Note: i'm trying to emerge sam2p with the gif use flag enabled but disabling it doesn't change anything.

Comment 13 Alessandro De Carli 2010-05-30 15:19:28 UTC
I have the same bug, also tried with ccache disabled, same effect. What is the solution? 
Comment 14 Alessandro De Carli 2010-05-31 09:13:33 UTC
In order to being able to update my system I just masked this version of sam2p.
Comment 15 Alessandro De Carli 2010-05-31 09:16:22 UTC
In order to update my system I just masked this version of sam2p.