Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 275854 - sys-apps/portage: allow alternative values for the SYNC variable
Summary: sys-apps/portage: allow alternative values for the SYNC variable
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 404405 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-06-29 17:51 UTC by Andre Knispel
Modified: 2014-05-18 23:27 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andre Knispel 2009-06-29 17:51:57 UTC
The SYNC variable in /etc/make.conf should be able to take alternative values (maybe through a SYNC_2, SYNC_3,... or SYNC_ALTERNATIVE or just SYNC="server1 server2 ..."). The reason is simple: if you have a local portage rsync server and maybe a notebook or something else that moves between networks, it won't be able to access the local mirror from another location. Good would be to check if the server is available and if not just try the next one.

Reproducible: Always
Comment 1 Zac Medico gentoo-dev 2012-05-17 04:41:58 UTC
*** Bug 404405 has been marked as a duplicate of this bug. ***
Comment 2 Brian Dolbec gentoo-dev 2014-05-18 23:27:50 UTC
The SYNC variable has been obsoleted by the repos.conf configuration system