Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 275724 - gentoo-x86 access: David Abbott (dabbott) (betelgeuse, due 2010-03-09)
Summary: gentoo-x86 access: David Abbott (dabbott) (betelgeuse, due 2010-03-09)
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Developers/Staff
Classification: Unclassified
Component: New Developers (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Recruiting Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-28 18:39 UTC by Roy Bamford
Modified: 2011-09-17 18:41 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
attached to bug in error (deleted)
2010-03-06 15:17 UTC, David Abbott
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roy Bamford gentoo-dev 2009-06-28 18:39:22 UTC
Comprookie2000 of linuxcrazy.com has expressed an interest in helping out with Gentoo PR. He has already been doing it with his podcasts of both developers and users.

Reproducible: Always

Steps to Reproduce:
1. Browse to www.linuxcrazy.com and listen to a few gentoo developer podcasts
2. Listen between the lines.
3.

Actual Results:  
Comprookie2000 would be an asset to Gentoo PR.
I've started mentoring him for his staff quiz.
rane has offered to help him with xml


PR need to respond to accept Comprookie2000 onto the team.
Comment 1 Roy Bamford gentoo-dev 2009-06-28 18:41:25 UTC
Added pr@ as a cc:
Comment 2 Kurt Lieber (RETIRED) gentoo-dev 2009-06-28 19:15:02 UTC
As noted via email, PR needs all the help it can get, so Comprookie2000 is welcome to join.
Comment 3 Łukasz Damentko (RETIRED) gentoo-dev 2009-06-28 19:39:04 UTC
Indeed, PR project could surely use fresh blood. David has already spent enormous amount of time on promoting Gentoo and his credentials are really good. He did multiple interviews with our key developers and even managed to get us to BBC web page once. :-)

David, feel free to contact me if you need help with your quizzes or anything else regarding your recruitment.
Comment 4 Christina Gianelloni (RETIRED) gentoo-dev 2009-06-29 13:22:49 UTC
As stated, PR could use additional assistance. 
David, what aspects of PR are you interested in working in and what new ideas are you bringing? (with new blood usually comes new ideas, but if not that's ok too)
Comment 5 David Abbott gentoo-dev 2009-06-29 16:12:58 UTC
As I try to do with the podcasts, let users get an inside look at their developers and what projects they work on, their enjoyment of being a Gentoo developer, what changes are coming up. I would like to have project members get together in a round table like discussion on the future plans, changes in the project, the goals, interesting programs, tips etc. This could be done by a conference call or on irc. 

I would also like to have a monthly Gentoo community news with information on Gentoo specific web sites, (I know of a Gentoo community site that is being put together for a Dec release) blockers and how to fix them, new programs in the tree, new developers, tips and how-to's, best forum posts and or tips, interesting users etc.

I really want to improve the communication over all, between developers, developers and users. I would like to start a project or sub-project to help developers relay information and free up their time for more developing and less admin type work that they don't want to or just don't have the time. Could be they need to track down an upstream developer, tell the users about a new .config file, contact an entire herd for feedback.  
Comment 6 Markos Chandras (RETIRED) gentoo-dev 2009-06-29 16:18:29 UTC
Please bring him on board. He is doing an excellent PR job
Comment 7 Roy Bamford gentoo-dev 2009-07-11 19:34:45 UTC
Forwarded staff quiz to recruiters@g.o a few minutes ago
Comment 8 Tobias Heinlein (RETIRED) gentoo-dev 2009-07-11 21:40:42 UTC
David, I will be your recruiter. If the quiz you sent via mail this morning is the final version, please contact me by IRC or email to schedule the first review session.

(If you think that recruiters aren't paying attention to this bug at any later point in time, it's your job to ping us on IRC if you don't want any delays.)
Comment 9 Denis Dupeyron (RETIRED) gentoo-dev 2009-07-12 03:57:10 UTC
There was a mid air collision here. I was talking to David while Tobias assigned himself as the recruiter. Anyway, while you guys were sleeping in Europe David was thoroughly reviewed and almost fully set up.

Denis.
Comment 10 Denis Dupeyron (RETIRED) gentoo-dev 2009-07-16 16:10:26 UTC
David is all set now. Only the announcement is still pending.

Denis.
Comment 11 Denis Dupeyron (RETIRED) gentoo-dev 2009-07-16 16:49:05 UTC
Announcement done, closing. Have fun David.

Denis.
Comment 12 David Abbott gentoo-dev 2009-07-16 16:53:21 UTC
Thanks for your time and understanding, very professional process :)
Comment 13 Denis Dupeyron (RETIRED) gentoo-dev 2009-07-16 17:30:16 UTC
David,

I forgot the list of things you need to do yourself. For some of this we went over it already. Don't hesitate to contact me in case you need any more info about any of this.

What you need to do:
- subscribe to mailing lists with @gentoo.org address
- request forum status bump in #gentoo-forums or by mail to
  forum-mods@gentoo.org (if you have a forums count)
- send yourself mail to create .maildir
- add yourself to mail aliases ( like java@gentoo.org )
  see /var/mail/alias on dev.gentoo.org
- ask team leads to add yourself to herds.xml for the herds you want to
  join or do it yourself if you have the permission to do so
- set lat and lon attributes in LDAP if you want others to know where
  exactly you are located
- set gentooIM if you want people to be able to contact you via other
  means than email
- If you want a blog on blogs.gentoo.org, contact planet@gentoo.org

For the mentor:
- You are also responsible for the commits of your recruit during the first
  month so you should watch the commits of your recruit via gentoo-commits
  mailing list.

Denis.
Comment 14 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2009-07-17 05:20:00 UTC
-core/-dev-announce done by infra per normal recruitment. (1.20am local, sitting in hotel in Montreal).
Comment 15 Roy Bamford gentoo-dev 2009-07-18 13:43:31 UTC
Denis,

Thanks for the reminder. Comprookie2000 is my first mentee.
Comment 16 David Abbott gentoo-dev 2009-10-13 18:09:03 UTC
I am interested in continuing on and taking the ebuild quiz. tove said he will mentor me and I can help him stabilize perl 5.10.1 and also continue to work on the Gentoo Ten Live DVD team, plus my PR duties. solar said he would co mentor. I talked to Roy my staff mentor (NeddySeagoon) and he said "go for it" 
Comment 17 solar (RETIRED) gentoo-dev 2009-10-13 22:32:04 UTC
Tove, Cool thanks. yeah I don't mind being a co-mentor for the day to day stuff on IRC. Just don't have a lot of time for hand holding and reviewing many revisions of a quiz..
Comment 18 David Abbott gentoo-dev 2009-11-03 02:32:47 UTC
ebuild-quiz and end-quiz sent to recruiters@. I also included my staff quiz as it answers some of the questions that are on both the staff quiz and ebuild quiz plus includes my public SSH2 DSA key.
Comment 19 Tomáš Chvátal (RETIRED) gentoo-dev 2010-01-08 12:00:07 UTC
We as QA team members managed to stumble upon quite few Davids patches in bugzilla, mostly proven correct and in perfect shape for addition to main tree.

Since you recruiters are really short-handed i would really like to ask you to
place David onto the top of your list. Since he is already gentoo developer and proving really really usefull.

With best regards

Tomas for the QA team
Comment 20 Petteri Räty (RETIRED) gentoo-dev 2010-01-08 18:53:53 UTC
(In reply to comment #19)
> We as QA team members managed to stumble upon quite few Davids patches in
> bugzilla, mostly proven correct and in perfect shape for addition to main tree.
> 

This is a requirement for all recruits in the first place.
Comment 21 Petteri Räty (RETIRED) gentoo-dev 2010-02-09 21:08:28 UTC
I will be your recruiter. Ping me on IRC or email me to schedule the first review session.
Comment 22 David Abbott gentoo-dev 2010-02-09 22:21:14 UTC
(In reply to comment #21)
> I will be your recruiter. Ping me on IRC or email me to schedule the first
> review session.
> 
email sent
Comment 23 Petteri Räty (RETIRED) gentoo-dev 2010-02-11 22:31:23 UTC
Session scheduled for 2010-02-16 19UTC
Comment 24 David Abbott gentoo-dev 2010-02-16 22:25:40 UTC
(In reply to comment #23)
> Session scheduled for 2010-02-16 19UTC
> 
First session completed, updated ebuild quiz mailed to recruiters@
Comment 25 David Abbott gentoo-dev 2010-02-26 20:59:06 UTC
Sent an updated end quiz to recruiters@ after review with my mentor (tove)
Comment 26 David Abbott gentoo-dev 2010-03-06 15:17:41 UTC
Created attachment 222289 [details]
attached to bug in error

I emailed an updated end quiz to recruiters@ after my review and a session with my mentor.
Comment 27 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-03-06 15:20:01 UTC
Restricting to developers not to leak quiz questions.
Comment 28 Petteri Räty (RETIRED) gentoo-dev 2010-03-06 15:28:56 UTC
(In reply to comment #27)
> Restricting to developers not to leak quiz questions.
> 

infra: please nuke the attachment
Comment 29 David Abbott gentoo-dev 2010-03-06 17:00:45 UTC
Comment on attachment 222289 [details]
attached to bug in error

attached to bug in error
Comment 30 Christian Ruppert (idl0r) gentoo-dev 2010-03-06 19:57:38 UTC
(In reply to comment #28)
> (In reply to comment #27)
> > Restricting to developers not to leak quiz questions.
> > 
> 
> infra: please nuke the attachment
> 

Done.
Comment 31 David Abbott gentoo-dev 2010-10-30 17:39:35 UTC
Latest end quiz sent to recruiters@
Comment 32 David Abbott gentoo-dev 2010-10-31 22:02:52 UTC
(In reply to comment #31)
> Latest end quiz sent to recruiters@
> 
Just sent to recruiters@ cleaned up wondershaper ebuild also ebuild quiz and staff quiz together as some of the questions overlap per my session with Petteri today.
Comment 33 David Abbott gentoo-dev 2011-09-17 18:41:40 UTC
I am going to close the bug for now, if I acquire the skills to proceed, and get more time and motivation I will try again, thanks everyone for your help.