Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 275659 - sys-apps/dbus-1.2.12 and xfce-base/xfdesktop-4.6.1 result in dbus_connection_send_with_reply_and_block
Summary: sys-apps/dbus-1.2.12 and xfce-base/xfdesktop-4.6.1 result in dbus_connection_...
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Doug Goldstein
URL:
Whiteboard:
Keywords:
: 289159 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-06-28 03:21 UTC by Stefan de Konink
Modified: 2010-04-20 19:37 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Latest stock dbus1 hal.conf (hal.conf,3.86 KB, text/plain)
2009-11-17 09:44 UTC, Livid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan de Konink 2009-06-28 03:21:33 UTC
xfdesktop
Xlib:  extension "RANDR" missing on display ":0.0".
xfdesktop[6611]: starting up
process 6611: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "(error) == NULL || !dbus_error_is_set ((error))" failed in file dbus-connection.c line 3301.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
Afgebroken

[don't mind the locale, should be something aborted]

Reproducible: Always

Steps to Reproduce:
1. upgrade system, notice badness




paludis 0.36.1
Paludis build information:
    Compiler:
        CXX:                   x86_64-pc-linux-gnu-g++ 4.3.3
        CXXFLAGS:               -march=athlon64 -O2 -pipe -msse3
        LDFLAGS:               
        DATE:                  2009-06-28T04:17:57+0200

    Libraries:
        C++ Library:           GNU libstdc++ 20090124

    Reduced Privs:
        reduced_uid:           105
        reduced_uid->name:     paludisbuild
        reduced_uid->dir:      /dev/null
        reduced_gid:           1007
        reduced_gid->name:     paludisbuild

    Paths:
        DATADIR:               /usr/share
        LIBDIR:                /usr/lib64
        LIBEXECDIR:            /usr/libexec
        SYSCONFDIR:            /etc
        PYTHONINSTALLDIR:      
        RUBYINSTALLDIR:        


        ACCEPT_KEYWORDS=amd64
        CBUILD=x86_64-pc-linux-gnu
        CFLAGS=-march=athlon64 -O2 -pipe -msse3
        CHOST=x86_64-pc-linux-gnu
        CONFIG_PROTECT= 
        CONFIG_PROTECT_MASK= 
        CPPFLAGS=
        CTARGET=
        CXXFLAGS=-march=athlon64 -O2 -pipe -msse3
        DISTDIR=/usr/portage/distfiles
        FEATURES=sandbox sfperms
        FFLAGS=
        GENTOO_MIRRORS=
        INSTALL_MASK=
        LANG=
        LC_ALL=C
        LDFLAGS=
        LINGUAS=be ca cs da de el es et eu fi fr he hu it ja ko nb_NO nl pa pl pt_BR ro ru sk sv tr uk vi zh_CN zh_TW
        MAKEOPTS=
        PORTAGE_COMPRESS=
        PORTAGE_COMPRESS_FLAGS=
        PORTAGE_CONFIGROOT=
        PORTAGE_RSYNC_EXTRA_OPTS=
        PORTAGE_RSYNC_OPTS=
        PORTAGE_TMPDIR=/var/tmp/paludis
        PORTDIR=/usr/portage
        PORTDIR_OVERLAY=
        SYNC=
        USE=file-icons menu-plugin amd64 alsa_cards_bt87x alsa_cards_ca0106 alsa_cards_hda-intel alsa_cards_intel8x0 alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mmap_emul alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol apache2_modules_actions apache2_modules_alias apache2_modules_auth_basic apache2_modules_authn_alias apache2_modules_authn_anon apache2_modules_authn_dbm apache2_modules_authn_default apache2_modules_authn_file apache2_modules_authz_dbm apache2_modules_authz_default apache2_modules_authz_groupfile apache2_modules_authz_host apache2_modules_authz_owner apache2_modules_authz_user apache2_modules_autoindex apache2_modules_cache apache2_modules_dav apache2_modules_dav_fs apache2_modules_dav_lock apache2_modules_deflate apache2_modules_dir apache2_modules_disk_cache apache2_modules_env apache2_modules_expires apache2_modules_ext_filter apache2_modules_file_cache apache2_modules_filter apache2_modules_headers apache2_modules_include apache2_modules_info apache2_modules_log_config apache2_modules_logio apache2_modules_mem_cache apache2_modules_mime apache2_modules_mime_magic apache2_modules_negotiation apache2_modules_rewrite apache2_modules_setenvif apache2_modules_speling apache2_modules_status apache2_modules_unique_id apache2_modules_userdir apache2_modules_usertrack apache2_modules_vhost_alias cameras_nikon cameras_ptp2 elibc_glibc input_devices_evdev input_devices_hyperpen input_devices_keyboard input_devices_mouse input_devices_wacom kernel_linux lcd_devices_bayrad lcd_devices_cfontz lcd_devices_cfontz633 lcd_devices_glk lcd_devices_hd44780 lcd_devices_lb216 lcd_devices_lcdm001 lcd_devices_mtxorb lcd_devices_ncurses lcd_devices_text linguas_en linguas_nl userland_GNU video_cards_none video_cards_nouveau video_cards_n
Comment 1 Mads 2009-07-01 12:59:20 UTC
Can confirm this, sys-apps/dbus-1.2.12 and xfce-base/xfdesktop-4.6.1 on ~x86. Solved it by adding "=sys-apps/dbus-1.2.12" to package.mask.
Comment 2 Eduard Nicodei 2009-07-05 18:31:12 UTC
I can also confirm this. Running it as root seems to work (of course you will get root's desktop).
For now reverting to dbus-1.2.3 as Mads suggested.
Comment 3 r1k0 2009-07-11 17:08:51 UTC
Have you tried creating /etc/dbus-1/system.d/myuser.conf ?

<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
        <policy user="rik">
            <allow send_destination="org.freedesktop.Hal"
                  send_interface="org.freedesktop.Hal.Device"/>
            <allow send_destination="org.freedesktop.Hal"
                  send_interface="org.freedesktop.Hal.Manager"/>
        </policy>
</busconfig>



creating this file allowed me to run xfdesktop again.
Comment 4 Livid 2009-07-20 06:35:51 UTC
Try adding yourself to plugdev. It's pretty the same as balkira suggested, but a bit cleaner IMO.
Comment 5 Michael Evans 2009-07-28 02:35:48 UTC
This would likely be a bug of dbus for either not automatically adding members of the users group or just -using- the users group for this access.

It's also a bug in relation to the extremely cryptic error message.  (Permission denied error messages should be clearly stated!)
Comment 6 Livid 2009-07-28 15:48:53 UTC
Actually, it's not a bug per se.
Xfdesktop requires access to hal's pluggable devices interface, which, logically, should only be accessible to plugdev group.

Additionaly, error message is less cryptic if dbus is merged with 'debug' USE-flag, since it enables backtrace and actually reports access denied problem.

Only thing, which may be considered a 'bug' is the fact that no one actually told us about change in permissions (via portage news or messages or migration guide etc).
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-11-01 21:44:26 UTC
*** Bug 289159 has been marked as a duplicate of this bug. ***
Comment 8 Gilles Dartiguelongue gentoo-dev 2009-11-01 22:02:38 UTC
If xfdesktop needs special policy, it must itself it itself like any other dbus clients (see networkmanager, cups, consolekit, avahi, ...).
Comment 9 Philip Webb 2009-11-11 20:40:48 UTC
I too ran into the problem that Xfce-4.6.1 wouldn't start on my ASUS 1005HA netbook.  It turned out to be  2  problems in succession: (1) my user had to be added to 'plugdev' in  /etc/group  & (2)  ~/.ICEauthority  was owned by root.
Perhaps I overlooked it, but there should be a warning message on emerging
to alert users to the need to fix (1).  (2) is not part of this bug AFAIK,
but is worth mentioning for completeness.
Comment 10 Gilles Dartiguelongue gentoo-dev 2009-11-12 10:32:58 UTC
adding yourself to plugdev group is said in enough ebuilds already (hal for example).
Comment 11 nm (RETIRED) gentoo-dev 2009-11-17 02:41:14 UTC
(In reply to comment #10)
> adding yourself to plugdev group is said in enough ebuilds already (hal for
> example).

Insufficient. I'm still running into this issue even though my user has always been in the plugdev group. Furthermore, this issue is also present even on stable dbus 1.2.3-r1.

Means that xfdesktop won't show mounted devices, and there's a long list of nonexistant properties (according to xfconf) that appear when running xfdesktop-settings, since the dbus config (which was left at the defaults) is all messed up.
Comment 12 Livid 2009-11-17 09:44:37 UTC
Created attachment 210494 [details]
Latest stock dbus1 hal.conf

Josh, you sure you updated /etc/dbus-1/system.d/hal.conf?
Works like charm for me.
I attach mine for reference.
Comment 13 nm (RETIRED) gentoo-dev 2009-11-17 10:08:15 UTC
(In reply to comment #12)
> Created an attachment (id=210494) [details]
> Latest stock dbus1 hal.conf
> 
> Josh, you sure you updated /etc/dbus-1/system.d/hal.conf?
> Works like charm for me.
> I attach mine for reference.

Yeah, I did. That's the weird thing. It's not something I'd just drop out when running dispatch-conf, but I had to follow the solutions posted by others WRT creating a myconf.foo file with the right bits of org.freedesktop.Hal in place. For some reason, this is only a problem on the laptop -- it lacked the two lines necessary. My desktop's file was correct, though it was merged at a different time. Both running the same HAL and dbus versions. I'll do s'more investigating, as it's very weird to have two different copies.
Comment 14 nm (RETIRED) gentoo-dev 2010-01-05 10:34:04 UTC
My problems are solved -- the laptop in question hadn't been updated in so long that I somehow missed the new "thunar" USE flag for xfdesktop. Now dbus and hal can use the Thunar integration so's the desktop at least draws icons properly and whatnot.

Logs are still full of the xfconf errors that everyone else has seen when running 4.6.x, but that's some other (harmless?) Xfce issue, I guess. Functionality has been restored to my system. Next time maybe the solution won't be as obvious. :)
Comment 15 Daniel Gulotta 2010-04-19 12:23:15 UTC
I got this error message when upgrading from dbus-1.2.3-r1 to dbus-1.2.24.  Re-emerging xfdesktop solved the problem.  Although the dbus ebuild warning message suggested running revdep-rebuild, revdep-rebuild didn't think anything was broken, so I had to re-emerge manually.
Comment 16 Joseph 2010-04-20 05:26:51 UTC
My other two system running xfdesktop fine but on one system I can not start it, I get:

xfdesktop
xfdesktop[31158]: starting up

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/xinerama-stretch" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/style" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/icon-size" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/font-size" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/use-custom-font-size" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/color-style" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/color1" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/color2" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/image-show" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/image-style" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/brightness" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/saturation" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/backdrop/screen0/monitor0/image-path" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/file-icons/show-filesystem" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/file-icons/show-home" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/file-icons/show-trash" does not exist on channel "xfce4-desktop"

(xfdesktop:31158): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/desktop-icons/file-icons/show-removable" does not exist on channel "xfce4-desktop"
process 31158: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "(error) == NULL || !dbus_error_is_set ((error))" failed in file dbus-connection.c line 3346.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
Aborted
Comment 17 Joseph 2010-04-20 17:00:17 UTC
I solved it by downgrading dbus.

it seems to me the new version of dbus-1.2.24 has a problem.
I've downgraded to dbus-1.2.3-r1 and now it is working.
Comment 18 Samuli Suominen gentoo-dev 2010-04-20 17:03:33 UTC
heh, I'm pretty sure there's nothing wrong with anything... and people should just rebuild dbus-glib, thunar and xfdesktop.  likely also xfce4-settings and xfconf. works great here with latest dbus, always has.

Comment 19 Joseph 2010-04-20 17:42:52 UTC
Rebuiding "dbus-glib" helped with one of my XFCE4 system but my main server running KDE-3.5 it didn't help, I recompile "dbus" and "dbus-glib" what other packages do I need to recompile on KDE-3.5?
Comment 20 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-04-20 18:20:59 UTC
Did you rebuild qt-dbus?
Comment 21 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-04-20 18:26:46 UTC
As you're using KDE-3.5, I meant to say did you rebuild dbus-qt3-old?

If rebuilding doesn't help, you'll have to debug this for yourself as one of the reasons we removed KDE-3.5 from the tree, was that the KDE team stopped supporting it.
Comment 22 mephinet 2010-04-20 18:38:18 UTC
(In reply to comment #4)
> Try adding yourself to plugdev. It's pretty the same as balkira suggested, but
> a bit cleaner IMO.

Thanks Livid, this was all that was necessary on my machine to make the dbus error go away. No revdep-rebuild'ing involved...
Comment 23 Joseph 2010-04-20 19:19:02 UTC
qt-dbus ??
I don't even have it installed neither on my XFCE4 (and everything is working) nor on my KDE

I rebuild "dbus-qt3-old" didn't help.
and I've added group "plugdev" but make no difference.

The strange part is that I downgraded to dbus-1.2.23 and plugging USB stick does not generate any pop up window; yes I restarted "dbus"; do I need to log OUT/IN?

The KDE-4 is not for me too many problem:
- there is no kbarcode (application I need) and printing pdf from kde-4.3 (stable) does not work, I'm getting very strange output, pages printing sideway. So, I'm not impress with KDE4 and would rather go with XFCE4 then KDE, have enough of kde-screw-ups.

Comment 24 Samuli Suominen gentoo-dev 2010-04-20 19:24:43 UTC
at any rate this bug was for dbus and thunar/xfdesktop, and problems seem to be solved with one of these:

- add yourself to plugdev group, and make sure it's active (yes, log out from your shell and log back in for example, make sure the active shell is really in the group)

- recompile dbus-glib and/or thunar and xfdesktop

- make sure USE thunar is enabled (it's enabled by default in desktop profile)

- kde 3.5 and even kde 4.x problems are unrelated to this bug
Comment 25 Joseph 2010-04-20 19:37:26 UTC
dbus-1.2.24 (hal) is working now in kde3.5
I went back to 1.2.23 (re-login) and everything was working so I upgraded again to dbus-1.2.24 re-login from current desktop and it not it start working :-/