Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 275643 - media-sound/rhythmbox-0.12.2-r1 requires input-selector element from media-libs/gst-plugins-bad
Summary: media-sound/rhythmbox-0.12.2-r1 requires input-selector element from media-li...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-27 21:29 UTC by Yang Zhao
Modified: 2009-08-24 16:20 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yang Zhao 2009-06-27 21:29:07 UTC
Without media-libs/gst-plugins-bad installed, playback of all media with rhythmbox-0.12.2-r1 fails with: 

yzhao@sui ~ $ rhythmbox
Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox|GStreamer element input-selector|element-input-selector
Rhythmbox-Message: Automatic missing codec installation not supported (helper script missing)
Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox|GStreamer element input-selector|element-input-selector
Rhythmbox-Message: Automatic missing codec installation not supported (helper script missing)

(rhythmbox:21316): Rhythmbox-WARNING **: Unhandled error: Missing element 'input-selector' - check your GStreamer installation.


media-sound/rhythmbox-0.12.2-r1 needs an explicit RDEPEND on media-libs/gst-plugins-bad
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-06-28 09:22:38 UTC
interesting. Could you list the versions of your installed gstreamer components ? (eix -I -c gst)
Comment 2 Yang Zhao 2009-06-28 17:00:47 UTC
(In reply to comment #1)
> interesting. Could you list the versions of your installed gstreamer components
> ? (eix -I -c gst)

[I--] [  ] dev-python/gst-python-0.10.12 (0.10)
[I--] [  ] media-libs/gst-plugins-bad-0.10.11 (0)
[I--] [  ] media-libs/gst-plugins-base-0.10.22 (0.10)
[I--] [  ] media-libs/gst-plugins-good-0.10.14 (0.10)
[I--] [  ] media-libs/gst-plugins-ugly-0.10.11 (0.10)
[I--] [  ] media-libs/gstreamer-0.10.22 (0.10)
[I--] [  ] media-plugins/gst-plugins-a52dec-0.10.11 (0.10)
[I--] [  ] media-plugins/gst-plugins-alsa-0.10.22 (0.10)
[I--] [  ] media-plugins/gst-plugins-cdparanoia-0.10.22 (0.10)
[I--] [  ] media-plugins/gst-plugins-dvdread-0.10.11 (0.10)
[I--] [  ] media-plugins/gst-plugins-esd-0.10.14 (0.10)
[I--] [  ] media-plugins/gst-plugins-faac-0.10.11 (0.10)
[I--] [  ] media-plugins/gst-plugins-faad-0.10.11 (0.10)
[I--] [  ] media-plugins/gst-plugins-ffmpeg-0.10.7 (0.10)
[I--] [  ] media-plugins/gst-plugins-flac-0.10.14 (0.10)
[I--] [  ] media-plugins/gst-plugins-gconf-0.10.14 (0.10)
[I--] [  ] media-plugins/gst-plugins-gio-0.10.22 (0.10)
[I--] [  ] media-plugins/gst-plugins-gnomevfs-0.10.22 (0.10)
[I--] [  ] media-plugins/gst-plugins-lame-0.10.11 (0.10)
[I--] [M~] media-plugins/gst-plugins-libmms-0.10.9 (0.10)
[I--] [  ] media-plugins/gst-plugins-libpng-0.10.14-r1 (0.10)
[I--] [  ] media-plugins/gst-plugins-mad-0.10.11 (0.10)
[I--] [  ] media-plugins/gst-plugins-meta-0.10-r2 (0.10)
[I--] [  ] media-plugins/gst-plugins-mpeg2dec-0.10.11 (0.10)
[I--] [  ] media-plugins/gst-plugins-ogg-0.10.22 (0.10)
[I--] [  ] media-plugins/gst-plugins-pango-0.10.22 (0.10)
[I--] [M~] media-plugins/gst-plugins-pulse-0.10.11 (0.10)
[I--] [  ] media-plugins/gst-plugins-resindvd-0.10.11 (0.10)
[I--] [  ] media-plugins/gst-plugins-shout2-0.10.14 (0.10)
[I--] [M~] media-plugins/gst-plugins-soup-0.10.11 (0.10)
[I--] [M~] media-plugins/gst-plugins-taglib-0.10.11 (0.10)
[I--] [  ] media-plugins/gst-plugins-theora-0.10.22 (0.10)
[I--] [  ] media-plugins/gst-plugins-vorbis-0.10.22 (0.10)
[I--] [  ] media-plugins/gst-plugins-x-0.10.22 (0.10)
[I--] [  ] media-plugins/gst-plugins-x264-0.10.11 (0.10)
[I--] [  ] media-plugins/gst-plugins-xvideo-0.10.22 (0.10)
Comment 3 Mart Raudsepp gentoo-dev 2009-08-23 06:17:41 UTC
rhythmbox doesn't seem to use input-selector itself directly, it uses playbin2 from gst-plugins-base.
playbin2 however does use input-selector and output-selector, whose primary version is in gst-plugins-bad still.

I believe I know what the problem is/was:

At the time of comment #2, you had media-libs/gst-plugins-base-0.10.22, whose playbin2 implementation uses input-selector, but didn't have a private copy of it.
Since gst-plugins-base-0.10.24 it carries a private copy of input-selector until standalone input-selector is considered of good quality enough to be included in gst-plugins-base as a public plugin, instead of gst-plugins-bad. This was upstream bug 586356 (GNOME bugzilla[1]).

So with gst-plugins-base-0.10.24, this bug should be fixed now. Can you confirm?

@GNOME: Should we tweak the depend to || ( >=gst-plugins-base-0.10.24 ( >=gst-plugins-base-0.10.20 >=gst-plugins-bad-0.10.6 )


1. http://bugzilla.gnome.org/show_bug.cgi?id=586356
Comment 4 Rémi Cardona gentoo-dev 2009-08-23 07:27:12 UTC
(In reply to comment #3)
> @GNOME: Should we tweak the depend to || ( >=gst-plugins-base-0.10.24 (
> >=gst-plugins-base-0.10.20 >=gst-plugins-bad-0.10.6 )

Because of the broken RB/pulseaudio interactions with gst <= 0.10.23, I'd say we depend on 0.10.24 directly. 2 birds, one stone.

My 2¢ :)
Comment 5 Yang Zhao 2009-08-23 16:23:41 UTC
(In reply to comment #3)
> So with gst-plugins-base-0.10.24, this bug should be fixed now. Can you
> confirm?

Confirmed.
Comment 6 Gilles Dartiguelongue gentoo-dev 2009-08-23 21:25:38 UTC
Went with leio's solution since it avoids us the trouble of waiting for
gstreamer 0.10.24 stabilization and we don't require stuff that is of no
interest to non pulseaudio users (even though I didn't have that pulseaudio
related bug btw).
Comment 7 Yang Zhao 2009-08-24 14:59:22 UTC
(In reply to comment #6)
> Went with leio's solution since it avoids us the trouble of waiting for
> gstreamer 0.10.24 stabilization and we don't require stuff that is of no
> interest to non pulseaudio users (even though I didn't have that pulseaudio
> related bug btw).

Fix confirmed, thanks.

However, the ebuild currently contains a duplicate entry for gst-plugins-base:

        >=media-libs/gst-plugins-base-0.10.20
        || (
                >=media-libs/gst-plugins-base-0.10.24
                >=media-libs/gst-plugins-bad-0.10.6 )
Comment 8 Gilles Dartiguelongue gentoo-dev 2009-08-24 16:18:56 UTC
that's not a duplicate entry, it's a way to require base at 0.10.20 minimum (which is what the autoconf says) while also requesting an input-selector element which is present in gst-plugins-bad since 0.10.6 and gst-plugins-base since 0.10.24.
Comment 9 Yang Zhao 2009-08-24 16:20:46 UTC
(In reply to comment #8)
> that's not a duplicate entry, it's a way to require base at 0.10.20 minimum
> (which is what the autoconf says) while also requesting an input-selector
> element which is present in gst-plugins-bad since 0.10.6 and gst-plugins-base
> since 0.10.24.

Bah, of course. Brain fart. :)

Closing.