Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 275119 - media-tv/tvtime-1.0.2-r2 fails to build with glibc 2.10.1
Summary: media-tv/tvtime-1.0.2-r2 fails to build with glibc 2.10.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Television related Applications in Gentoo's Portage
URL:
Whiteboard:
Keywords:
: 277488 (view as bug list)
Depends on:
Blocks: glibc-2.10
  Show dependency tree
 
Reported: 2009-06-22 23:34 UTC by Tomasz Długosz
Modified: 2009-08-08 22:28 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
lets compile with >=glibc-2.10 (glibc-2.10.patch,963 bytes, patch)
2009-07-02 19:55 UTC, Markus Rathgeb
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz Długosz 2009-06-22 23:34:30 UTC
build fails

Reproducible: Always

Steps to Reproduce:
1. emerge tvtime


Actual Results:  
this is the output I get:

(...)
if x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..    `/usr/bin/freetype-config --cflags`  -Wall -pedantic -I. -DDATADIR="\"/usr/share/tvtime\"" -DCONFDIR="\"/etc/tvtime\"" -DFIFODIR="\"/tmp\"" -D_LARGEFILE64_SOURCE -DLOCALEDIR="\"/usr/share/locale\"" -I../plugins  -I/usr/include/libxml2   -march=athlon64  -msse3 -pipe -O3 -fomit-frame-pointer -std=gnu99 -MT tvtime-xmltv.o -MD -MP -MF ".deps/tvtime-xmltv.Tpo" \
	  -c -o tvtime-xmltv.o `test -f 'xmltv.c' || echo './'`xmltv.c; \
	then mv -f ".deps/tvtime-xmltv.Tpo" ".deps/tvtime-xmltv.Po"; \
	else rm -f ".deps/tvtime-xmltv.Tpo"; exit 1; \
	fi
xmltv.c:121: error: conflicting types for ‘locale_t’
/usr/include/xlocale.h:43: error: previous declaration of ‘locale_t’ was here
make[2]: *** [tvtime-xmltv.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/media-tv/tvtime-1.0.2-r2/work/tvtime-1.0.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-tv/tvtime-1.0.2-r2/work/tvtime-1.0.2'
make: *** [all] Error 2
 * 
 * ERROR: media-tv/tvtime-1.0.2-r2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2736:  Called die
 * The specific snippet of code:
 *       emake || die "compile problem"
 *  The die message:
 *   compile problem
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-tv/tvtime-1.0.2-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-tv/tvtime-1.0.2-r2/temp/environment'.




This is what I did to check where does /usr/include/xlocale.h come from:
tesla saa7134 # equery b /usr/include/xlocale.h
 * Searching for /usr/include/xlocale.h ... 
sys-libs/glibc-2.10.1 (/usr/include/xlocale.h)
Comment 1 Markus Rathgeb 2009-07-02 19:55:22 UTC
Created attachment 196423 [details, diff]
lets compile with >=glibc-2.10

This patch should let you compile tvtime.
Just adjust your ebuild that tha patch will be applied.

Have you reported upstream?
Comment 2 Tomasz Długosz 2009-07-02 20:37:15 UTC
the patch works for me, thanks a lot!

I didn't report upstream. Should I?
Comment 3 Markus Rathgeb 2009-07-03 18:21:09 UTC
Normally you should always do that if it is a upstream problem (IMHO).
Except it is still correct in current trunk or always reported.

In this case (I have had a look now) it is still known:
http://sourceforge.net/tracker/?func=detail&aid=2808113&group_id=64301&atid=506987
Comment 4 Rafał Mużyło 2009-07-12 11:35:00 UTC
*** Bug 277488 has been marked as a duplicate of this bug. ***
Comment 5 ali77 2009-07-31 18:34:07 UTC
(In reply to comment #2)
> the patch works for me, thanks a lot!

why isn't it possible to emerge --sync it then?
Comment 6 Samuli Suominen gentoo-dev 2009-08-08 22:28:25 UTC
  08 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+  tvtime-1.0.2-r2.ebuild, +files/tvtime-1.0.2-glibc-2.10.patch:
+  Fix building with GLIBC 2.10+ wrt #275119, thanks to Markus Rathgeb for
+  patch.